Page 1 of 1

banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 12:36 am
by letchworthvillage
I've been getting a lot of spam (human) registrations from gmail.com email accounts, so I added *@gmail.com to the ban email list (as 'permanent'), but the system is still allowing gmail accounts to register as new users ... I've removed it from the list, and then readded it (a few times), but no matter what I do, gmail accounts can still register as new users ... Am I missing something? (I am using the latest version of phpbb) Can someone please help me?

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 3:25 am
by Netframe
Banning the gmail.com domain isn't the best idea since it is heavily used by a lot of people as an email source.

However this is just me.

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 4:03 am
by Oyabun1
It is very unlikely the spammers are human. Are you sure the users you think are joining aren't just inactive users that joined before you added the ban? Are you sure the spammers are using @gmail.com accounts, sometimes they use special characters in their addresses that look almost the same but can get around the ban?

See the sticky near the top of this forum, Preventing Spam in phpBB3, for better ways of stopping spammers.

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 12:51 pm
by letchworthvillage
They are definitely human spammers; I've tried different Captchas and they still register ... I know many real people use gmail and I hate to ban it, but the # of spammers using it overwhelms the # of real people ... I know they are spammers because they are coming from IP addresses from China, Ukraine, Poland, Netherlands, etc .... Is there a way to block all IP's that are outside of the USA ?? (or only allow USA IP addresses to register?)

My forum (http://www.letchworthvillage.info/forum/ .. which is a forum for the site www.LetchworthVillage.info) does not have heavy traffic, so it is annoying when 99% of the registrations are spammers and I don't know how to otherwise block them. I do not have problems withs bots, but the human spam farms overseas is what's killing me as an Admin/Moderator.

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 12:58 pm
by KevC
letchworthvillage wrote:They are definitely human spammers; I've tried different Captchas and they still register
They're definitely not human. You're still using captchas which were beaten by the bots nearly a year ago.

You need to be using the Q&A captcha with a non searchable question. eg, enter the first 4 letters of the name of the village.

Do that and they'll stop.

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 1:08 pm
by Brf
When I try to register at your board using a gmail address, I get the message
The e-mail address you entered is not allowed to be used.
so they are not registering that way.

I see your board has only one topic, other than the Welcome one, but I could not read it. That blue-on-grey color scheme is not readable for me.

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 3:21 pm
by letchworthvillage
I was able to fix the gmail issue, but I do realize I will lose all legit gmail users, so I will unban it and try to put the custom field in where I ask a question like you mentioned ... Thanks for all the replies :)

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 3:23 pm
by stevemaury
If you have 3.0.6 or newer, you will not use a custom field - you will use the built-in Q&A CAPTCHA.

Re: banning *@gmail.com not working, please help ...

Posted: Mon Nov 14, 2011 3:43 pm
by letchworthvillage
OK .. I was able to change the captcha to the Q&A captcha ... and I unbanned all email domains .. let's cross our fingers! .. Again, thank you to all that replied. :)