Page 1 of 1

Update Problems (3.08 to 3.09)

Posted: Thu Dec 01, 2011 6:19 am
by Push Latency
Using the automatic update package for 3.08 to 3.09 (MD5: e5648147787c5413783bf81dea2c4fc7), I'm encountering an error during the "Check Files" phase.

I select "check files", and it hangs at 28, then returns an 500 Internal Server Error.

I'm using non-default themes and a Portal plugin; would this have anything to do with it?

I've tried re-uploading the files, but the problem persists. Thank you, in advance, for any help anyone can offer!

Re: Update Problems (3.08 to 3.09)

Posted: Thu Dec 01, 2011 7:08 am
by Oyabun1
It is a problem sometimes caused by the settings on your host's server, they don't allow scripts to run for long enough for the update process to complete.

You may need to do an Offline Conversion.

Re: Update Problems (3.08 to 3.09)

Posted: Fri Dec 02, 2011 1:04 am
by Push Latency
I appreciate your help!

Is this a common problem with boards hosted on GoDaddy servers?

Would it be worth my time to ask that they make a change to the configuration of the server, to allow for a longer script?

Thanks again!

Re: Update Problems (3.08 to 3.09)

Posted: Fri Dec 02, 2011 4:14 am
by Mick
Push Latency wrote:Is this a common problem with boards hosted on GoDaddy servers?
it can be a problem with a lot of hosts, what type of account do you have, free or paid? (presumably paid?)
Push Latency wrote:Would it be worth my time to ask that they make a change to the configuration of the server, to allow for a longer script?
Most definitely, they may do it temporarily for you but I'm not sure how GoDaddy works. If you're paying for your hosting you need to bang on their door.

Please fill out the Support Request Template Generator and post it back here to enable us to assist you better.

Re: Update Problems (3.08 to 3.09)

Posted: Sun Dec 18, 2011 1:10 am
by Push Latency
After speaking with hosting support, I've been told I can "extend the timeout limit as set on the php.ini file in the update package". The person with whom I spoke was relaying information, and I don't think what I heard was correct, but where can I change/extend the "timeout limit" in any of the phpBB files? Is the file I need to change part of the update package, or one of the files in my pre-existing installation that I'm trying to update?

Thank you, very much - in advance, to anyone who can offer assistance.

Re: Update Problems (3.08 to 3.09)

Posted: Sun Dec 18, 2011 3:34 am
by Oyabun1
What a surprise, staff of a hosting company that don't know what they are talking about. The update package doesn't contain a php.ini file and nor does phpBB. That file is specific to PHP.

If you don't have access to the php.ini file, which is not likely if you are on shared hosting then they would need to make the change.

However, depending on what security settings they have in place you may be able to make the temporary adjustment via the .htaccess file in the root of your board installation. Download it (make a backup) and then with a good text editor add these lines to the bottom of it,

Code: Select all

# increase php time-out limits
php_value max_execution_time 300
php_value max_input_time 300
save, and reupload it.

Then try running the update package again. If it doesn't work, unfortunately, you'll have to go back to the host and ask them to change it for you.

Re: Update Problems (3.08 to 3.09)

Posted: Sun Dec 18, 2011 4:24 am
by Push Latency
Thanks for your reply - my first attempt returned a 500 error. I'll try again, but I've checked my work, and it should have worked if it was going to.

Re: Update Problems (3.08 to 3.09)

Posted: Sun Dec 18, 2011 7:47 am
by Mick
Have you checked your server's error log to see where the 500 error is coming from? If it's anything to do with what you tried with .htaccess (put the original back and see if it gives you a 500 error) you will probably have to get your host to make the changes to php.ini.