Updating header title - can't get it right

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Updating header title - can't get it right

Post by Brf »

You must have a blank PAGE_TITLE for your index page then.
User avatar
haggisv
Registered User
Posts: 261
Joined: Wed Dec 20, 2006 3:31 am
Location: Adelaide, Australia
Contact:

Re: Updating header title - can't get it right

Post by haggisv »

Yes you're right, I do.

Any idea how I can make it the way I want it?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52228
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Updating header title - can't get it right

Post by Brf »

What is the way you want it?
User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: Updating header title - can't get it right

Post by HGN »

haggisv wrote:That works perfectly for all pages, except that the home page now has a "- " in front of the title, which does not look right.
I guess you want to skip the " - " in case the PAGE_TITLE is empty.
Use this:

Code: Select all

<title><!-- IF PAGE_TITLE -->{PAGE_TITLE}&nbsp;-&nbsp;<!-- ENDIF --><!-- IF S_IN_MCP -->{L_MCP}&nbsp;-&nbsp;<!-- ELSEIF S_IN_UCP -->{L_UCP}&nbsp;-&nbsp;<!-- ENDIF -->{SITENAME}</title>
User avatar
haggisv
Registered User
Posts: 261
Joined: Wed Dec 20, 2006 3:31 am
Location: Adelaide, Australia
Contact:

Re: Updating header title - can't get it right

Post by haggisv »

HGN wrote:
haggisv wrote:That works perfectly for all pages, except that the home page now has a "- " in front of the title, which does not look right.
I guess you want to skip the " - " in case the PAGE_TITLE is empty.
Use this:

Code: Select all

<title><!-- IF PAGE_TITLE -->{PAGE_TITLE}&nbsp;-&nbsp;<!-- ENDIF --><!-- IF S_IN_MCP -->{L_MCP}&nbsp;-&nbsp;<!-- ELSEIF S_IN_UCP -->{L_UCP}&nbsp;-&nbsp;<!-- ENDIF -->{SITENAME}</title>
Perfect!!! Thank you so much HGN, I owe you one!
User avatar
haggisv
Registered User
Posts: 261
Joined: Wed Dec 20, 2006 3:31 am
Location: Adelaide, Australia
Contact:

Re: Updating header title - can't get it right

Post by haggisv »

I've now got my titles working perfectly, thanks again for all the help guys.

However I'm displaying an atom feed of the forum on another site, and have just noticed that title of the links in that list are still showing the old format of the page titles, ie "<forum name> • <thread title>".

Can someone please advice what modification I need to do to make the atom feed show the <Thread Title>?

Thanks a lot!
User avatar
haggisv
Registered User
Posts: 261
Joined: Wed Dec 20, 2006 3:31 am
Location: Adelaide, Australia
Contact:

Re: Updating header title - can't get it right

Post by haggisv »

Anyone please?
Locked

Return to “[3.0.x] Support Forum”