Page 2 of 2

Re: Updating header title - can't get it right

Posted: Mon Jan 09, 2012 12:21 pm
by Brf
You must have a blank PAGE_TITLE for your index page then.

Re: Updating header title - can't get it right

Posted: Mon Jan 09, 2012 1:24 pm
by haggisv
Yes you're right, I do.

Any idea how I can make it the way I want it?

Re: Updating header title - can't get it right

Posted: Mon Jan 09, 2012 1:28 pm
by Brf
What is the way you want it?

Re: Updating header title - can't get it right

Posted: Mon Jan 09, 2012 10:10 pm
by HGN
haggisv wrote:That works perfectly for all pages, except that the home page now has a "- " in front of the title, which does not look right.
I guess you want to skip the " - " in case the PAGE_TITLE is empty.
Use this:

Code: Select all

<title><!-- IF PAGE_TITLE -->{PAGE_TITLE}&nbsp;-&nbsp;<!-- ENDIF --><!-- IF S_IN_MCP -->{L_MCP}&nbsp;-&nbsp;<!-- ELSEIF S_IN_UCP -->{L_UCP}&nbsp;-&nbsp;<!-- ENDIF -->{SITENAME}</title>

Re: Updating header title - can't get it right

Posted: Tue Jan 10, 2012 1:10 am
by haggisv
HGN wrote:
haggisv wrote:That works perfectly for all pages, except that the home page now has a "- " in front of the title, which does not look right.
I guess you want to skip the " - " in case the PAGE_TITLE is empty.
Use this:

Code: Select all

<title><!-- IF PAGE_TITLE -->{PAGE_TITLE}&nbsp;-&nbsp;<!-- ENDIF --><!-- IF S_IN_MCP -->{L_MCP}&nbsp;-&nbsp;<!-- ELSEIF S_IN_UCP -->{L_UCP}&nbsp;-&nbsp;<!-- ENDIF -->{SITENAME}</title>
Perfect!!! Thank you so much HGN, I owe you one!

Re: Updating header title - can't get it right

Posted: Tue Jun 05, 2012 1:45 am
by haggisv
I've now got my titles working perfectly, thanks again for all the help guys.

However I'm displaying an atom feed of the forum on another site, and have just noticed that title of the links in that list are still showing the old format of the page titles, ie "<forum name> • <thread title>".

Can someone please advice what modification I need to do to make the atom feed show the <Thread Title>?

Thanks a lot!

Re: Updating header title - can't get it right

Posted: Wed Jun 06, 2012 6:33 am
by haggisv
Anyone please?