bbcode errors after upgrading to 3.10

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
baloo
Registered User
Posts: 70
Joined: Mon Feb 11, 2008 12:32 pm

bbcode errors after upgrading to 3.10

Post by baloo » Sat Jan 07, 2012 6:19 am

I've upgraded from .09 to .10.

2 weird issues. I started seeing errors when PMs were sent complaining that bbcode.html couldn't be found in the theme/template directory. It was never there as it was a derivative of prosilver and prosilver had the file. Copying prosilver's bbcode.html to my style solved that problem.

The one that is still nagging me is the following every time there is a post that has bbcode in it(b, img, u etc)

1 of these:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 83: preg_match() [function.preg-match]: No ending delimiter '.' found
followed by 4 of these

Code: Select all

[07-Jan-2012 12:05:49] PHP Warning:  Cannot modify header information - headers already sent by (output started at /home/public_html/mydomain.com/forum/includes/functions.php:3815) in /home/public_html/mydomain.com/forum/includes/functions.php on line 4685
I've checked the files mentioned and compared them to 3.09 and everything seems the same so it's doping my head in. Any pointers would be most welcome.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66921
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: bbcode errors after upgrading to 3.10

Post by Lumpy Burgertushie » Sat Jan 07, 2012 7:39 am

how did you update? do you have any MODs installed?

have you tried replacing the relevant file with a new one to see if it fixes the problem?


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

baloo
Registered User
Posts: 70
Joined: Mon Feb 11, 2008 12:32 pm

Re: bbcode errors after upgrading to 3.10

Post by baloo » Sat Jan 07, 2012 10:36 am

I tried using original message_parser.php and functions.php. Still the same.

I used the automatic update. That caused more issues.

I then dropped a clean 3.10 down, added my mods and then copied over the top of my existing site.

I'm starting to think it might be style related but I'm grasping at straws. If anyone can offer any hints as to what to look for I'd be most thankful.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66921
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: bbcode errors after upgrading to 3.10

Post by Lumpy Burgertushie » Sun Jan 08, 2012 4:01 pm

sounds like maybe you made some type of mistake with one of your MODs.

have you had any reason to open/edit either one of those files?

if so, what are you using to open/edit your phpbb files?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

baloo
Registered User
Posts: 70
Joined: Mon Feb 11, 2008 12:32 pm

Re: bbcode errors after upgrading to 3.10

Post by baloo » Wed Jan 11, 2012 12:37 pm

OK, after much trial and error, I think I have found where the error is coming from occurring. The Database.

I rebuilt a new 3.10 installation and hooked into a 3.09 DB copy I had. No errors.

I then copied all the files from my error producing upgraded 3.10 install onto the newly built 3.10 and I had no errors.

I then imported the 3.10 database into the test install and the errors appeared.

using Autromod (I only ever used Automod) I deinstalled all Mods. Then using stk I cleaned the DB out of anything that wasn't standard.

I still get the errors when someone writes a post that has some bbcode (img, b, quote etc).

I know way less about MySQL than I do about hacking away at PHP files so I am very loathe to try and solve this on my own without any guidance. If anyone can help it would be much appreciated.

Failing that is there a way than I can take a delta of a working db and the current one that just takes post, pm and related (attachments etc) sql dump that I can import into a DB that's not throwing the error ?

Locked

Return to “[3.0.x] Support Forum”