Incomplete links in edit post

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
CarolC1
Registered User
Posts: 500
Joined: Sat Dec 02, 2006 4:26 pm

Incomplete links in edit post

Post by CarolC1 » Sat Jan 14, 2012 4:32 am

Support Request Template
What version of phpBB are you using?
phpBB 3.0.10
What is your board's URL?
Who do you host your board with? No answer given
How did you install your board?
I used the download package from phpBB.com
Is your board a fresh install or a conversion?
Update from a previous version of phpBB3
Do you have any MODs installed?
Yes
Is registration required to reproduce this issue?
No
What version of phpBB3 did you update from?
phpBB 3.0.9
What MODs do you have installed?
Moderator Needed
All City Topic Site Map
What styles do you currently have installed?
prosilver
What language(s) is your board currently using?
British English
Which database type/version are you using?
MySQL 5
What is your level of experience?
New to PHP but not phpBB
When did your problem begin?
Only noticed it since upgrading to 3.0.10
Please describe your problem.
If I go to an old post containing a link, the link looks normal in viewtopic and works correctly, but if I click EDIT on the post, the link is incomplete in the edit screen. What happened to the middle of it? It should show the whole link when you are in Edit, which would be
http://pets.groups.yahoo.com/group/Handicats/messages/832, not
http://pets.groups.yahoo.com/group/Hand ... ssages/832
Generated by SRT Generator
Last edited by CarolC1 on Mon Jan 16, 2012 4:02 pm, edited 1 time in total.

CarolC1
Registered User
Posts: 500
Joined: Sat Dec 02, 2006 4:26 pm

Re: Incomplete links in edit post

Post by CarolC1 » Mon Jan 16, 2012 2:30 am

Still in need of any insight on this. Where should I be looking?

The ellipsis should not be on the edit post screen, should it? :? Shouldn't the entire link be showing?

We can't afford to have anything happen to our links on the board.

Thank you.

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: Incomplete links in edit post

Post by D¡cky » Mon Jan 16, 2012 3:17 am

CarolC1 wrote:The ellipsis should not be on the edit post screen, should it? :? Shouldn't the entire link be showing?
The entire link should be showing when you edit a post.

Did you install a modification to have links open in new windows? Perhaps this one, Links Opening New Windows. This article can cause that problem if an edit is missed or an edit is done incorrectly.

Unfortunately, once a link is broken it cannot be fixed unless you know what the link is supposed to be. You should refrain from editing posts with links until this problem is resolved.
Have you hugged someone today?

CarolC1
Registered User
Posts: 500
Joined: Sat Dec 02, 2006 4:26 pm

Re: Incomplete links in edit post

Post by CarolC1 » Mon Jan 16, 2012 5:17 am

(((((HUG)))))

Fixed. On Nov 29 I removed some old code we had to make links "no follow" and replaced it with the unedited code from a 3.0.9 download. "Links open in new windows" and "no follow" involve edits in the same sections of code. I may have broken it and not noticed, or it may have been broken during the upgrade. Thank you more than you know!

Locked

Return to “[3.0.x] Support Forum”

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 47 guests