"Legend" and "bots" question

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

"Legend" and "bots" question

Post by bhbebe » Tue Jan 31, 2012 4:24 pm

Hi all.
My Legend in bottom of forum looks weird :? Is it possible to fix this so it is not on right side? I want it to be written under registered users in one line.
Also, there r no bots in registered users in last few days, and before usually there were like 3 or 4 of them. What can be problem?

Image

Tnx for help.
Last edited by bhbebe on Tue Jan 31, 2012 9:21 pm, edited 2 times in total.

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "boots" question

Post by HGN » Tue Jan 31, 2012 4:48 pm

That would require something like the following code from /styles/subsilver2/template/index_body.html:

Code: Select all

	<!-- IF LEGEND -->
		<td class="row1" rowspan="2" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<!-- ELSE -->
		<td class="row1" align="center" valign="middle"><img src="{T_THEME_PATH}/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<!-- ENDIF -->
rowspan="2" takes care of spanning the image over two rows.

A link to your board would make it easier to give exact instructions.

*EDIT*
Found a link to your board in another post.

In your /styles/milky_way_red/template/index_body.html you have the following:

Code: Select all

<td class="row1" rowspan="{3}" align="center" valign="middle"><img src="{T_THEME_PATH}/images/online.png" alt="{L_WHO_IS_ONLINE}" /></td>
that should be

Code: Select all

<td class="row1" rowspan="2" align="center" valign="middle"><img src="{T_THEME_PATH}/images/online.png" alt="{L_WHO_IS_ONLINE}" /></td>

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "boots" question

Post by bhbebe » Tue Jan 31, 2012 8:16 pm

Tnx a lot HGN :)
That was problem for "Legend", now it looks great.

And what about these bots? How come they don't show anymore?

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "boots" question

Post by HGN » Tue Jan 31, 2012 9:16 pm

bhbebe wrote:And what about these bots? How come they don't show anymore?
That's hard to tell without knowing what you have doen the last few days with your board. Googles cache shows that Google-bot was on your board this evening.
What does it show on ACP - Spiders/Robots? What is the last visit time of any of the bots?

Have you made modifications to includes/functions.php?

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "boots" question

Post by bhbebe » Tue Jan 31, 2012 9:28 pm

HGN wrote: What does it show on ACP - Spiders/Robots? What is the last visit time of any of the bots?

Have you made modifications to includes/functions.php?
"ACP - Spiders/Robots" area is empty :?
But when I go to "ACP - Users and groups - Menage groups" it shows Bots - 51 members

Didn't make any change to functions.php as far as I know.

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "boots" question

Post by HGN » Tue Jan 31, 2012 9:54 pm

bhbebe wrote:"ACP - Spiders/Robots" area is empty :?
But when I go to "ACP - Users and groups - Menage groups" it shows Bots - 51 members
This means that the bots are still in the users table and assigned to the bots group, but the bots table is empty.
Did you run SQL queries in phpMyAdmin that could have caused this?

Do you have back-ups of the database?

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "boots" question

Post by bhbebe » Tue Jan 31, 2012 10:27 pm

HGN wrote: This means that the bots are still in the users table and assigned to the bots group, but the bots table is empty.
Did you run SQL queries in phpMyAdmin that could have caused this?
No, I didn't.
HGN wrote:
Do you have back-ups of the database?
I did full backup thru phpbb, but It seams that it is not working, like its incomplete (I made it on 28th january)
If u want more details about problem that my forum experienced in couple last day, u can see it here:
http://www.phpbb.com/community/viewtopi ... &t=2149365

But there is backup which did my host on 23rd january (weekly backup). I downloaded it to my comp.

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "bots" question

Post by HGN » Tue Jan 31, 2012 10:36 pm

Try to open the back-up made by your host (in a text editor; depending on the size it may take some time) and find

Code: Select all

INSERT INTO phpbb_bots
You may have to replace phpbb_ by the prefix your tables have.
Then copy paste that whole line starting with the text mentioned before and ending with

Code: Select all

);
This line contains a MySQL query that can be run in phpMyAdmin to restore your bots table.

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "bots" question

Post by bhbebe » Tue Jan 31, 2012 10:46 pm

Don't know if I understand, I am not really good about these things, but do u want me to copy/paste it to you here, or somewhere else? :oops:

Here are the lines

Code: Select all

--
-- Table structure for table `bots`
--

DROP TABLE IF EXISTS `bots`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `bots` (
  `bot_id` mediumint(8) unsigned NOT NULL AUTO_INCREMENT,
  `bot_active` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `bot_name` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `user_id` mediumint(8) unsigned NOT NULL DEFAULT '0',
  `bot_agent` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `bot_ip` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  PRIMARY KEY (`bot_id`),
  KEY `bot_active` (`bot_active`)
) ENGINE=MyISAM AUTO_INCREMENT=53 DEFAULT CHARSET=utf8 COLLATE=utf8_bin;
/*!40101 SET character_set_client = @saved_cs_client */;

--
-- Dumping data for table `bots`
--

LOCK TABLES `bots` WRITE;
/*!40000 ALTER TABLE `bots` DISABLE KEYS */;
INSERT INTO `bots` (`bot_id`, `bot_active`, `bot_name`, `user_id`, `bot_agent`, `bot_ip`) VALUES (1,1,'AdsBot [Google]',3,'AdsBot-Google',''),(2,1,'Alexa [Bot]',4,'ia_archiver',''),(3,1,'Alta Vista [Bot]',5,'Scooter/',''),(4,1,'Ask Jeeves [Bot]',6,'Ask Jeeves',''),(5,1,'Baidu [Spider]',7,'Baiduspider+(',''),(6,1,'Exabot [Bot]',8,'Exabot/',''),(7,1,'FAST Enterprise [Crawler]',9,'FAST Enterprise Crawler',''),(8,1,'FAST WebCrawler [Crawler]',10,'FAST-WebCrawler/',''),(9,1,'Francis [Bot]',11,'http://www.neomo.de/',''),(10,1,'Gigabot [Bot]',12,'Gigabot/',''),(11,1,'Google Adsense [Bot]',13,'Mediapartners-Google',''),(12,1,'Google Desktop',14,'Google Desktop',''),(13,1,'Google Feedfetcher',15,'Feedfetcher-Google',''),(14,1,'Google [Bot]',16,'Googlebot',''),(15,1,'Heise IT-Markt [Crawler]',17,'heise-IT-Markt-Crawler',''),(16,1,'Heritrix [Crawler]',18,'heritrix/1.',''),(17,1,'IBM Research [Bot]',19,'ibm.com/cs/crawler',''),(18,1,'ICCrawler - ICjobs',20,'ICCrawler - ICjobs',''),(19,1,'ichiro [Crawler]',21,'ichiro/',''),(20,1,'Majestic-12 [Bot]',22,'MJ12bot/',''),(21,1,'Metager [Bot]',23,'MetagerBot/',''),(22,1,'MSN NewsBlogs',24,'msnbot-NewsBlogs/',''),(23,1,'MSN [Bot]',25,'msnbot/',''),(24,1,'MSNbot Media',26,'msnbot-media/',''),(25,1,'NG-Search [Bot]',27,'NG-Search/',''),(26,1,'Nutch [Bot]',28,'http://lucene.apache.org/nutch/',''),(27,1,'Nutch/CVS [Bot]',29,'NutchCVS/',''),(28,1,'OmniExplorer [Bot]',30,'OmniExplorer_Bot/',''),(29,1,'Online link [Validator]',31,'online link validator',''),(30,1,'psbot [Picsearch]',32,'psbot/0',''),(31,1,'Seekport [Bot]',33,'Seekbot/',''),(32,1,'Sensis [Crawler]',34,'Sensis Web Crawler',''),(33,1,'SEO Crawler',35,'SEO search Crawler/',''),(34,1,'Seoma [Crawler]',36,'Seoma [SEO Crawler]',''),(35,1,'SEOSearch [Crawler]',37,'SEOsearch/',''),(36,1,'Snappy [Bot]',38,'Snappy/1.1 ( http://www.urltrends.com/ )',''),(37,1,'Steeler [Crawler]',39,'http://www.tkl.iis.u-tokyo.ac.jp/~crawler/',''),(38,1,'Synoo [Bot]',40,'SynooBot/',''),(39,1,'Telekom [Bot]',41,'crawleradmin.t-info@telekom.de',''),(40,1,'TurnitinBot [Bot]',42,'TurnitinBot/',''),(41,1,'Voyager [Bot]',43,'voyager/1.0',''),(42,1,'W3 [Sitesearch]',44,'W3 SiteSearch Crawler',''),(43,1,'W3C [Linkcheck]',45,'W3C-checklink/',''),(44,1,'W3C [Validator]',46,'W3C_*Validator',''),(45,1,'WiseNut [Bot]',47,'http://www.WISEnutbot.com',''),(46,1,'YaCy [Bot]',48,'yacybot',''),(47,1,'Yahoo MMCrawler [Bot]',49,'Yahoo-MMCrawler/',''),(48,1,'Yahoo Slurp [Bot]',50,'Yahoo! DE Slurp',''),(49,1,'Yahoo [Bot]',51,'Yahoo! Slurp',''),(50,1,'YahooSeeker [Bot]',52,'YahooSeeker/',''),(51,1,'Bing [Bot]',818,'bingbot/',''),(52,1,'Facebook',1609,'facebookexternalhit/1.1','');
/*!40000 ALTER TABLE `bots` ENABLE KEYS */;
UNLOCK TABLES;

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "bots" question

Post by HGN » Tue Jan 31, 2012 10:53 pm

Do you know how to run MYSQL queries in phpMyAdmin or do you have the phpBB3 Support Toolkit installed?

Either can be used to run the following query recreating your bots table:

Code: Select all

INSERT INTO `bots` (`bot_id`, `bot_active`, `bot_name`, `user_id`, `bot_agent`, `bot_ip`) VALUES (1,1,'AdsBot [Google]',3,'AdsBot-Google',''),(2,1,'Alexa [Bot]',4,'ia_archiver',''),(3,1,'Alta Vista [Bot]',5,'Scooter/',''),(4,1,'Ask Jeeves [Bot]',6,'Ask Jeeves',''),(5,1,'Baidu [Spider]',7,'Baiduspider+(',''),(6,1,'Exabot [Bot]',8,'Exabot/',''),(7,1,'FAST Enterprise [Crawler]',9,'FAST Enterprise Crawler',''),(8,1,'FAST WebCrawler [Crawler]',10,'FAST-WebCrawler/',''),(9,1,'Francis [Bot]',11,'http://www.neomo.de/',''),(10,1,'Gigabot [Bot]',12,'Gigabot/',''),(11,1,'Google Adsense [Bot]',13,'Mediapartners-Google',''),(12,1,'Google Desktop',14,'Google Desktop',''),(13,1,'Google Feedfetcher',15,'Feedfetcher-Google',''),(14,1,'Google [Bot]',16,'Googlebot',''),(15,1,'Heise IT-Markt [Crawler]',17,'heise-IT-Markt-Crawler',''),(16,1,'Heritrix [Crawler]',18,'heritrix/1.',''),(17,1,'IBM Research [Bot]',19,'ibm.com/cs/crawler',''),(18,1,'ICCrawler - ICjobs',20,'ICCrawler - ICjobs',''),(19,1,'ichiro [Crawler]',21,'ichiro/',''),(20,1,'Majestic-12 [Bot]',22,'MJ12bot/',''),(21,1,'Metager [Bot]',23,'MetagerBot/',''),(22,1,'MSN NewsBlogs',24,'msnbot-NewsBlogs/',''),(23,1,'MSN [Bot]',25,'msnbot/',''),(24,1,'MSNbot Media',26,'msnbot-media/',''),(25,1,'NG-Search [Bot]',27,'NG-Search/',''),(26,1,'Nutch [Bot]',28,'http://lucene.apache.org/nutch/',''),(27,1,'Nutch/CVS [Bot]',29,'NutchCVS/',''),(28,1,'OmniExplorer [Bot]',30,'OmniExplorer_Bot/',''),(29,1,'Online link [Validator]',31,'online link validator',''),(30,1,'psbot [Picsearch]',32,'psbot/0',''),(31,1,'Seekport [Bot]',33,'Seekbot/',''),(32,1,'Sensis [Crawler]',34,'Sensis Web Crawler',''),(33,1,'SEO Crawler',35,'SEO search Crawler/',''),(34,1,'Seoma [Crawler]',36,'Seoma [SEO Crawler]',''),(35,1,'SEOSearch [Crawler]',37,'SEOsearch/',''),(36,1,'Snappy [Bot]',38,'Snappy/1.1 ( http://www.urltrends.com/ )',''),(37,1,'Steeler [Crawler]',39,'http://www.tkl.iis.u-tokyo.ac.jp/~crawler/',''),(38,1,'Synoo [Bot]',40,'SynooBot/',''),(39,1,'Telekom [Bot]',41,'crawleradmin.t-info@telekom.de',''),(40,1,'TurnitinBot [Bot]',42,'TurnitinBot/',''),(41,1,'Voyager [Bot]',43,'voyager/1.0',''),(42,1,'W3 [Sitesearch]',44,'W3 SiteSearch Crawler',''),(43,1,'W3C [Linkcheck]',45,'W3C-checklink/',''),(44,1,'W3C [Validator]',46,'W3C_*Validator',''),(45,1,'WiseNut [Bot]',47,'http://www.WISEnutbot.com',''),(46,1,'YaCy [Bot]',48,'yacybot',''),(47,1,'Yahoo MMCrawler [Bot]',49,'Yahoo-MMCrawler/',''),(48,1,'Yahoo Slurp [Bot]',50,'Yahoo! DE Slurp',''),(49,1,'Yahoo [Bot]',51,'Yahoo! Slurp',''),(50,1,'YahooSeeker [Bot]',52,'YahooSeeker/',''),(51,1,'Bing [Bot]',818,'bingbot/',''),(52,1,'Facebook',1609,'facebookexternalhit/1.1','');
If you don't know how to run the query please tell, so I can give you instructions.

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "bots" question

Post by bhbebe » Tue Jan 31, 2012 10:56 pm

I really don'k know how to run MYSQL queries in phpMyAdmin. I have installed Support toolkit.

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "bots" question

Post by HGN » Tue Jan 31, 2012 11:00 pm

Then in STK go to Admin Tools - Run SQL Query, copy/paste above query (from my post) in there and press Submit (no need for tickmarking show results).

Now goto your ACP and verify the Spiders/Bots page.

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "bots" question

Post by bhbebe » Tue Jan 31, 2012 11:07 pm

Ok, I copy/paste that code u wrote, and when i pressed SUBMIT I got this:

http://i40.tinypic.com/ehyszt.png

Edit: sorry, I just noticed this "(no need for tickmarking show results)."
Will I press submit anyway?

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: "Legend" and "bots" question

Post by HGN » Tue Jan 31, 2012 11:14 pm

Okay, then please first copy the following line and press submit.

Code: Select all

TRUNCATE TABLE bots;
After that copy-paste the other query again and press submit.

bhbebe
Registered User
Posts: 81
Joined: Tue Apr 07, 2009 9:24 am

Re: "Legend" and "bots" question

Post by bhbebe » Tue Jan 31, 2012 11:20 pm

ok, I did it. Info: The SQL query has been run successfully.

I checked ACP - spider/bot and still is empty. does it have to be like that or no?

Locked

Return to “[3.0.x] Support Forum”