Strict Standards help

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

I can access it fine on my computer, my iPhone, and my iPod all 3 take me to this http://death2020.net/install/index.php link
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

Looks at the screenshots I provided
Attachments
Screen Shot 2012-02-02 at 4.45.35 PM.png
Screen Shot 2012-02-02 at 4.45.35 PM.png (209.62 KiB) Viewed 1788 times
Screen Shot 2012-02-02 at 4.45.47 PM.png
Screen Shot 2012-02-02 at 4.45.47 PM.png (294.25 KiB) Viewed 1788 times
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Strict Standards help

Post by Pit$Bull »

Sorry, times out for me.
User avatar
T0ny
Registered User
Posts: 1383
Joined: Sun Jan 29, 2006 8:42 pm
Location: Lancashire
Name: Tony

Re: Strict Standards help

Post by T0ny »

Your host is running PHP version 5.4.0alpha3 (a pre release version) on their servers. That is why you are seeing those warning messages. I'm sure that once PHP 5.4.0 is actually released that phpbb will be updated to work with it.

In the mean time, if you remember who your host is, you could ask them if there is anything they can do to help.
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

Is there a version of this phpbb that I could use that would work with my site?
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Strict Standards help

Post by Pit$Bull »

The current version is 3.0.10 and the only version available.
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

Is there a way to get an older version and don't worry man when I said bro it wasn't out of disrespect it was a sign of respect
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Strict Standards help

Post by Pit$Bull »

An older version won't help if indeed your host is running PHP version 5.4.0alpha3 (a pre release version) on their servers.

You should contact them.
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

On the installation steps it shows this as a yes
Attachments
Screen Shot 2012-02-02 at 6.51.01 PM.png
Screen Shot 2012-02-02 at 6.51.01 PM.png (369.02 KiB) Viewed 1748 times
Screen Shot 2012-02-02 at 6.52.28 PM.png
Screen Shot 2012-02-02 at 6.52.28 PM.png (278.91 KiB) Viewed 1747 times
Pit$Bull
Former Team Member
Posts: 23099
Joined: Sat Dec 02, 2006 4:08 pm
Name: Can't Remember

Re: Strict Standards help

Post by Pit$Bull »

Go ahead and install, what is the problem. The link still doesn't work for me.
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

I"m not putting it back onto my site because it shuts it down for people to get onto. Besides I already provided a screenshot of the problem/error.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Strict Standards help

Post by Oyabun1 »

djrock5782 wrote:Is there a way to get an older version ...
You don't need an older version of phpBB you need an older version of the PHP scripting language. You would need to ask your host to supply a stable version of PHP rather than the development version you are apparently using.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

One of my friends has me with his hosting service and I have no idea the name of his hosting service so I can't ask them for a different version of php because I'm not a registered member of their site
Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: Strict Standards help

Post by Oleg »

Try this.

In startup.php find:

phpBB/includes/startup.php:error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);

replace with:

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com
User avatar
djrock5782
Registered User
Posts: 27
Joined: Thu Feb 02, 2012 12:13 pm

Re: Strict Standards help

Post by djrock5782 »

Oleg wrote:Try this.

In startup.php find:

phpBB/includes/startup.php:error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);

replace with:

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED & ~E_STRICT);
Man thank you so much that worked thanks a bunch
Locked

Return to “[3.0.x] Support Forum”