Syntax Error...

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Syntax Error...

Post by CassieT » Mon Feb 13, 2012 1:22 pm

I don't want to be spoon fed (although I know lots of lovely people on here would do that) because I want to properly understand this for myself so if I can share my thoughts..

I'm getting the error message

Parse error: syntax error, unexpected '}' in /home/rwapco/public_html/forum3/cache/tpl_rePurple_overall_header.html.php on line 10

Does this literally mean that I have an extra } in the overall header that shouldn't be there, and I need to take it out?

If so, why does it reference cache at all?

All I was doing was this - http://www.phpbb.com/kb/article/extendi ... gation-bar - it didn't work so all I did was take out the exact code I'd put in; I have no idea how I've ended up with an extra }

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69453
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Syntax Error...

Post by KevC » Mon Feb 13, 2012 1:40 pm

Yeah you have a typo somewhere in that file. Probably around line 10 give or take a few.

It uses the cached one for speed.

To fix it you can just upload an unedited one, open the cache folder on the server, delete everything except index.htm and htaccess and your error will go away.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Re: Syntax Error...

Post by CassieT » Mon Feb 13, 2012 2:56 pm

Thanks Kevin :P

CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Re: Syntax Error...

Post by CassieT » Mon Feb 13, 2012 3:14 pm

Except, of course, that I didn't back that file up after I added all of the mods..... :oops:

What's the quickest way to find an errant } ? There are 69 of them in that file.....

CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Re: Syntax Error...

Post by CassieT » Mon Feb 13, 2012 3:19 pm

Also, how can this have happened when I removed EXACTLY the same code that I put in? If this error message is right, the errant } is nowhere near where I was editing

I'll know in future to back everything up before I touch it, but all I did was add code. I didn't alter anything, or take anything away. I put in a block of code, and I took the same block of code out

It's a mystery to me

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51889
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Syntax Error...

Post by Brf » Mon Feb 13, 2012 3:35 pm

You are talking about styles/rePurple/template/overall_header.html right? You would not see the } in there. It would be generated when it is compiled when you refresh your template.

CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Re: Syntax Error...

Post by CassieT » Mon Feb 13, 2012 5:18 pm

Brf wrote:You are talking about styles/rePurple/template/overall_header.html right? You would not see the } in there. It would be generated when it is compiled when you refresh your template.
I made the changes, refreshed the template and then got the error

I've spent half the day searching for a }

All I've got now is a stinking headache and a forum which looks ridiculous because I didn't back up one file

I'm stupid. And fed up :(

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Syntax Error...

Post by Oyabun1 » Mon Feb 13, 2012 10:29 pm

It's probably not an incorrect } you are looking for, but rather an extra <!-- ENDIF --> tag. Every closing <!-- ENDIF --> must be matched to an opening <!-- IF something --> tag.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

CassieT
Registered User
Posts: 105
Joined: Mon Oct 22, 2007 8:00 pm

Re: Syntax Error...

Post by CassieT » Mon Feb 13, 2012 10:49 pm

Oyabun1 wrote:It's probably not an incorrect } you are looking for, but rather an extra <!-- ENDIF --> tag. Every closing <!-- ENDIF --> must be matched to an opening <!-- IF something --> tag.
Really?

I do have an odd number of { and } - I just can't work out if I have too many of one or too few of the other

Luckily I'm out all day tomorrow delivering red roses and other unoriginal Valentines flowers :mrgreen: so I will be well away from any computers. This seriously drove me mad today. More so because I was so angry with myself for not saving the changed file when I did some mods weeks ago. I've had to revert to the original file and have got to try and remember how to move the navigation bar again... :roll:

Locked

Return to “[3.0.x] Support Forum”