delete users from Manage groups (prune users wont work)

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
slayer1011
Registered User
Posts: 129
Joined: Sun Jul 03, 2005 11:02 pm
Location: Hamilton, Ontario Canada
Contact:

delete users from Manage groups (prune users wont work)

Post by slayer1011 » Thu Apr 05, 2012 6:24 am

Ok, so what im looking for is a way to view my "newly registered users" group members, and select the known bots / spammers and just be able to select delete from the drop down box.

I have it setup for users to automatically be set to registered after 1 validated post, so the only members in there are bots.

if i try to use the PRUNE USERS as mentioned in sooo many posts, it doesnt let me choose users that are not activated or never logged in.

If i choose all users who never logged in, it could potentially delete legit users who just signed up but havent posted

its just frustrating having to go into each account to delete them, or type the names manually in the prune users section.

Below is a mock up of what i mean
Has anyone seen anythign that will help me do this? or would it be hard to create this modification?

thank you in advance
Image

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69226
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: delete users from Manage groups (prune users wont work)

Post by KevC » Thu Apr 05, 2012 8:05 am

slayer1011 wrote:if i try to use the PRUNE USERS as mentioned in sooo many posts, it doesnt let me choose users that are not activated or never logged in.
That usually means the spambot has used a fake email address and so never got the activation mail and thus will never activate the account anyway so it's a bit irrelevant to delete them.

In the admin panel > users and groups > inactive users, you can see whole pages of inactivated accounts, tick the boxes next to the ones you want and delete them in one go.

But, even better is to read this topic on preventing spam and use the built in Q&A captcha to add a non-searchable Q&A question which will stop them even signing up in the first place.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

slayer1011
Registered User
Posts: 129
Joined: Sun Jul 03, 2005 11:02 pm
Location: Hamilton, Ontario Canada
Contact:

Re: delete users from Manage groups (prune users wont work)

Post by slayer1011 » Thu Apr 05, 2012 5:25 pm

thank you, that helps ALOT

Also i use the Q&A Captha, -12UTC Blcok, and i take advantage of the newly registered user group and use it as a holding area for 0 posters, once they post (and are approved) there moved out of there


again thanks for the help,

this topic can be locked
, i dont really need the mod with now knowing about this. im still learning phpBB3 (2.x.x i was alot better at)

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69226
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: delete users from Manage groups (prune users wont work)

Post by KevC » Thu Apr 05, 2012 6:44 pm

slayer1011 wrote:Also i use the Q&A Captha
Kevin Clark wrote:use the built in Q&A captcha to add a non-searchable Q&A question
Your Q&A is too simple. It asks what is 2+2? Spambots can search for the answer to that and beat the question with ease. You need to ask them to write a word backwards or the colour of a logo image or to add the last 5 letters of a code etc.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: delete users from Manage groups (prune users wont work)

Post by HGN » Thu Apr 05, 2012 11:16 pm

As this actually is a solved support request, the topic has been moved from Mod requests.

Locked

Return to “[3.0.x] Support Forum”