Problem with forum location (parent/subforum problem)

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Frode789
Registered User
Posts: 119
Joined: Sun Jan 06, 2008 7:57 pm
Location: Norway

Problem with forum location (parent/subforum problem)

Post by Frode789 »

Support Request Template
What version of phpBB are you using? phpBB 3.0.10
What is your board's URL? http://www.tera-norge.com/forum/
Who do you host your board with? ipage
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? None, but updated to 3.0.10 a while ago.
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
What MODs do you have installed? Announcement Centre
AJAX checks
NV advanced last topic titles
Share On MOD
ReIMG Image Resizer
What styles do you currently have installed? LolDominion
What language(s) is your board currently using? English (GB) lang pack
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
When did your problem begin? Today when I changed the location of one of my forums. I moved the forum "Guider" (no sub-forums) from the parent category "TERA" to "Community".
Please describe your problem. Then I realized that inside the forum "Guider" was a subforum box (no name on it though). The posts I can see is from the forum "Fanart and media", which is placed on the parent "Community". I decided to check this in ACP, and the two existing forums in that parent are now listed as subforums under "Guider"..

When I try to change any of the 3 forums via the forum settings, they all have "Community" as parent, which is correct. I even tried to delete the "Guide" forum, but then I deleted them all (3). I even tried to move the forum back to the original parent, but then I got an SQL error for some reason.

How can I remove them as subforums? I want no subforums under "Guider", and I don't want the other two forums to be listed under anything other then the parent category.
Generated by SRT Generator
User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: Problem with forum location (parent/subforum problem)

Post by HGN »

You may try to repair it installing the Support Toolkit and run the Support tool Fix Left/Right ID's.
Frode789
Registered User
Posts: 119
Joined: Sun Jan 06, 2008 7:57 pm
Location: Norway

Re: Problem with forum location (parent/subforum problem)

Post by Frode789 »

Worked like a charm! SOLVED.

Thanks.
Locked

Return to “[3.0.x] Support Forum”