Warning. The entered path "files" is not writable

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
tellmethis
Registered User
Posts: 108
Joined: Sun Feb 14, 2010 7:02 pm
Contact:

Warning. The entered path "files" is not writable

Post by tellmethis »

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? http://www.you-global.com/forum
Who do you host your board with? Zang IT (previously known as DotInfo)
How did you install your board? Someone else installed my board for me
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
What version of phpBB3 did you update from? phpBB 3.0.6
What styles do you currently have installed? prosilver
What language(s) is your board currently using? British English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
When did your problem begin? Following installation of 3.0.11, the first message posted and after I tried to upload an attachment by clicking "Add the file".
Please describe your problem. Trying to "Add the file" within a post, I receive a red error message stating:

Could not upload attachment to ./files/53_a8bac7c951f3c38f9ab901bebe08e15d

I notice that in ACP > Posting > Attachment settings that there is:

"Warning. The entered path "files" is not writable"

The name "files" (without the quotes) is in the field Upload Directory. Which I'm guessing has something to do with this.

There is a folder named files in the forum directory, and the files folder contains a swag of files from previous uploads.

I'm wondering whether this has something to do with permission settings on the files folder ? Though I haven't changed anything. I use Fetch 5.7.2 to access via ftp (on MacOSX), but I also have access to the server by Remote Desktop Connection in case that's relevant.

If I "Get Info" on the files folder via Fetch, the Unix equivalent setting shows as rw-rw-rw- and all of the Read and Write boxes are checked, the Execute boxes are unchecked.

What do I do to solve this upload issue ?
Generated by SRT Generator

User avatar
canonknipser
Registered User
Posts: 2096
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Warning. The entered path "files" is not writable

Post by canonknipser »

set the "executes", because on unix it means: "can enter directory"

edit: im talking about the folder "files", not the files themselves, for the files in files-folder it should be "666" or "rw-rw-rw-"
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

User avatar
robertmf
Registered User
Posts: 94
Joined: Wed Sep 25, 2002 7:26 pm
Location: 55 min. by commuter RR outside Filthadelphia
Contact:

Re: Warning. The entered path "files" is not writable

Post by robertmf »

directories :
files store cache and images/avatars/upload
need to be writable to all i.e., chmod 777
DLI Alumni & Friends Community at DLIFLC.ORG

tellmethis
Registered User
Posts: 108
Joined: Sun Feb 14, 2010 7:02 pm
Contact:

Re: Warning. The entered path "files" is not writable

Post by tellmethis »

Thanks guys.

So this is what I do, via ftp using Fetch ...

I've been to each of the folders listed by robertmf, right-clicked, selected Get Info, and in the field alongside the button 'Unix equivalent' typed in 777 then clicked Apply. Then tested the attachment upload, and checked ACP > Posting > Attachment settings ... all the same problem,

I then go BACK to the Get Info window for the folders I changed and clicked Apply, but they've reverted to 666, ie. the Execute boxes have been deselected.

Why does the setting 777 not stick ? What do I do to make the change stick and thereby hopefully solve the problem ? Am I better logging into the server via Remote Desktop Connection, finding the folders in question, and editing permissions via Windows Properties ?

Also, how come these permissions settings aren't simply part of the forum installation ?

User avatar
canonknipser
Registered User
Posts: 2096
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Warning. The entered path "files" is not writable

Post by canonknipser »

tellmethis wrote:Why does the setting 777 not stick ? What do I do to make the change stick and thereby hopefully solve the problem ? Am I better logging into the server via Remote Desktop Connection, finding the folders in question, and editing permissions via Windows Properties ?
I Think you have to ask your host about that - maybe its because you are on a windows server
tellmethis wrote:Also, how come these permissions settings aren't simply part of the forum installation ?
Because, as you can see in your case, giving the right permission in the file-system can be difficult and maybe must be done manually.
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

tellmethis
Registered User
Posts: 108
Joined: Sun Feb 14, 2010 7:02 pm
Contact:

Re: Warning. The entered path "files" is not writable

Post by tellmethis »

Hmm. Well, for the record, I have jumped into Remote Desktop Connection, navigated to 'files', found my way to a window named 'Permissions for files', seen that for Users the box for 'Write' was deselected, so 'Allowed' it instead, and that seems to have solved the problem of adding an attachment.

So should I change this permission setting in the same way for all of the folders:
  • store
  • cache
  • images/avatars/upload
??

User avatar
robertmf
Registered User
Posts: 94
Joined: Wed Sep 25, 2002 7:26 pm
Location: 55 min. by commuter RR outside Filthadelphia
Contact:

Re: Warning. The entered path "files" is not writable

Post by robertmf »

tellmethis wrote:Hmm. Well, for the record, I have jumped into Remote Desktop Connection, navigated to 'files', found my way to a window named 'Permissions for files', seen that for Users the box for 'Write' was deselected, so 'Allowed' it instead, and that seems to have solved the problem of adding an attachment.

So should I change this permission setting in the same way for all of the folders:
  • store
  • cache
  • images/avatars/upload
??
store and cache, yes. If you want to allow users to upload their own avatars, then upload should be 777 also.
DLI Alumni & Friends Community at DLIFLC.ORG

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69719
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Warning. The entered path "files" is not writable

Post by KevC »

-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Locked

Return to “[3.0.x] Support Forum”