Error after upgrading to 3.0.11 - unknown column array

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
EarthSongWoman
Registered User
Posts: 5
Joined: Tue Aug 28, 2012 9:12 pm

Error after upgrading to 3.0.11 - unknown column array

Post by EarthSongWoman » Tue Aug 28, 2012 9:16 pm

I Have just upgraded from 3.0.10 to 3.0.11 using automatic update and now i have an error after I post anything to the forums, the post still makes it to the forum but I get the following:

Return to the index page
General Error
SQL ERROR [ mysql4 ]

Unknown column 'Array' in 'where clause' [1054]

SQL

SELECT user_id, username, user_email, user_lang, user_notify_type, user_jabber, user_boardwatchb, user_notify_status FROM phpbb_users WHERE user_boardwatchb <> 2 AND user_notify_status = 0 AND user_id NOT IN (Array) AND user_type IN (0, 3)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_boardwatch.php
LINE: 81
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1203
CALL: include_boardwatch_users()

FILE: [ROOT]/includes/functions_posting.php
LINE: 2637
CALL: user_notification()

FILE: [ROOT]/posting.php
LINE: 1134
CALL: submit_post()

How can I fix this? Thank you for any help you can give me.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51785
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Error after upgrading to 3.0.11 - unknown column array

Post by Brf » Tue Aug 28, 2012 9:20 pm

You will need to ask your question in the support topic for your boardwatch mod.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Error after upgrading to 3.0.11 - unknown column array

Post by Oyabun1 » Tue Aug 28, 2012 11:19 pm

The fix is here, Re: 3.0.11 compatability.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

EarthSongWoman
Registered User
Posts: 5
Joined: Tue Aug 28, 2012 9:12 pm

Re: Error after upgrading to 3.0.11 - unknown column array

Post by EarthSongWoman » Thu Aug 30, 2012 11:54 am

Thanks for your help - All sorted now!

Locked

Return to “[3.0.x] Support Forum”