parse_message->get_submitted_attachment_data()

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Wed Dec 05, 2012 8:29 am

Have this error in ACP triggered by a Moderator.......Not sure how to decipher it....
Screenshot.png
Screenshot.png (46.33 KiB) Viewed 583 times
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21135
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: parse_message->get_submitted_attachment_data()

Post by Mick » Wed Dec 05, 2012 8:43 am

Please fill out the Support Request Template Generator specifically what happened just prior to this issue happening (edits/MODs etc.) and post it back here to enable us to assist you better.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Wed Dec 05, 2012 8:58 am

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? https://www.ultimateeditionoz.com
Who do you host your board with? Bluehost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
What version of phpBB3 did you update from? phpBB 3.0.10
What MODs do you have installed? ACP - Group name Coloured
ACP Announcement Centre
ACP Announcements Feed
ACP Inactive Users
Anti-Spam ACP
Auto Backup
Automatic Spammer Detection
Avatar in Who is Online
Ban users by x warnings
Contact Admin
Email on Birthday
Forum SEO
Google +1 MOD
Info box Advanced
MCP Ban Hammer
Moderator Needed
ModernDignity "Hello" Name Tag of Newest User Mod
ModernDignity Flash Animated Cumulus Tag Cloud Mod
MSSTI RSS Feed 2.0 with ACP
National Flags
NuCaptcha Plugin
NV "who was here?"
Paypal Donation
PDF24 Articles To PDF
phpBB mChat
phpBB Mood Swings
Post number in viewtopic
Prime Censor Block
Prime Memberlist Filter
Prime Subject Check
Show Password Strength
Thanks for posts
Tinypic Plugin MOD
Top Five
Top Poster of the Month
Topic SEO description and keywords mod
Upcoming Birthday list
User Reminder
Users and Bots on Seperate Lines
VigLink
Visit counter by forum
Warning Reasons
Welcome Newest Member
Welcome on index
Welcome on registration
What styles do you currently have installed? ca_black & pro_silver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? Last 4 weeks......
When did your problem begin? About a month ago.....
Please describe your problem. As per the image supplied.......seems it may be related to the Thanks For Posts Mod.....but having searched via Google extensively....I cant find the solution......it is not impacting the board in any way that I can see.
Generated by SRT Generator
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21135
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: parse_message->get_submitted_attachment_data()

Post by Mick » Wed Dec 05, 2012 9:28 am

Mick wrote:specifically what happened just prior to this issue happening (edits/MODs etc.)
Did this 'just happen'? If you think it may be MOD related you should ask in the support section for that MOD.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Wed Dec 05, 2012 9:34 am

When did your problem begin? About a month ago.
I will. Just thought it pertinent to ask the gurus here as they know the intricacies of PHPBB......

I said "I thought" it might be mod related..........not sure at all. :)
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by HGN » Wed Dec 05, 2012 9:36 am

When does this error occur? (Click this, do that, and then the error occurs.)

What are your CHMOD permissions on the /files folder on your server?

What is on line 1641 (and 10 lines before and after) in your /includes/message_parser.php?

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Wed Dec 05, 2012 9:44 am

1. The error is in the ACP under error log.

2. /files permissions is 777

3.

Code: Select all

				$this->attachment_data[$pos] = $row;
				set_var($this->attachment_data[$pos]['attach_comment'], $_POST['attachment_data'][$pos]['attach_comment'], 'string', true);

				unset($orphan[$row['attach_id']]);
			}
			$db->sql_freeresult($result);
		}

		if (sizeof($orphan))
		{
			trigger_error('NO_ACCESS_ATTACHMENT', E_USER_ERROR);
		}

		ksort($this->attachment_data);
	}

	/**
	* Parse Poll
	*/
	function parse_poll(&$poll)
	{
Googleing found this... http://tracker.phpbb.com/browse/PHPBB3-9789 relevant??
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Thu Dec 06, 2012 8:16 am

Image
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51720
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Brf » Thu Dec 06, 2012 3:39 pm

HGN wrote:When does this error occur? (Click this, do that, and then the error occurs.)
Blackwolf_Oz wrote:1. The error is in the ACP under error log.
HGN did not ask where you are seeing the error. He is asking what actions are causing the error. What are you doing to create the error?

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Thu Dec 06, 2012 8:09 pm

I am not doing a thing.....as I stated,
Have this error in ACP triggered by a Moderator
So, I , am not doing a thing.....it is an error generated by a Moderator, when doing .....I dont know what.
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51720
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Brf » Thu Dec 06, 2012 8:12 pm

Then ask them what they are doing to cause the error.

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Thu Dec 06, 2012 8:34 pm

Doing so now, will advise.
Thanks so much for all the help.
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Oleg » Thu Dec 06, 2012 8:37 pm

Blackwolf_Oz wrote: Googleing found this... http://tracker.phpbb.com/browse/PHPBB3-9789 relevant??
Likely. If you keep getting that message dumped in the logs try the fix posted in the ticket.
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: parse_message->get_submitted_attachment_data()

Post by Blackwolf_Oz » Thu Dec 06, 2012 8:55 pm

Well Blackwolf I saw that error to I was attempting to upload image and I had the "your not allowed to access" message just closed and reopened the forum and all went well have no idea way the error was there maybe I clicked too fast on something wrong can not really say what, it was not the first time I uploaded a image ,

I have no idea way that happened big fellow, sorry I can't help.
Maybe one thing I remember that I had clicked on the "Add the file" when I forgot to select the file , I can not say for sure that the error occurred att that instant.
Looks like that may have been it.
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

Locked

Return to “[3.0.x] Support Forum”