Viewtopic URL with "t=XX" instead of "f=XX&t=XX"

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
kaleidoscope
Registered User
Posts: 20
Joined: Mon Apr 26, 2010 9:18 am

Viewtopic URL with "t=XX" instead of "f=XX&t=XX"

Post by kaleidoscope » Tue Dec 11, 2012 8:24 am

phpBB recognizes URLs in the format of "viewtopic.php?t=(topic number)", but it defaults to opening links up as "viewtopic.php?f=(forum number)&t=(topic number)."

Given that the URLs work already with only the topic number, is there a way to make the board default to linking topics with the topic number only, and get the forum number out of the viewtopic URLs?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Viewtopic URL with "t=XX" instead of "f=XX&t=XX"

Post by Oyabun1 » Tue Dec 11, 2012 8:29 am

Not with standard phpBB. you would need a MOD for that and I'm not aware of one that does exactly that. What benefit do you think making that change will achieve?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

kaleidoscope
Registered User
Posts: 20
Joined: Mon Apr 26, 2010 9:18 am

Re: Viewtopic URL with "t=XX" instead of "f=XX&t=XX"

Post by kaleidoscope » Tue Dec 11, 2012 10:07 am

Basically, it just bothers me. I don't understand why it's even there. The forum number doesn't even do anything.

I can type any bogus forum number and put it into place and it does nothing. I could have a topic that's in f=6&t=48. I can change that to f=99999999999999&t=48 and it'll still load perfectly fine.

It's doing absolutely nothing, and has no reason to be there, and topics load fine without it, so it just seems like it would be preferable for it to not be there.

User avatar
Erik Frèrejean
Former Team Member
Posts: 9899
Joined: Tue Oct 09, 2007 9:09 am
Location: The Netherlands, 3.0.x Support Forum
Name: Erik Frèrejean
Contact:

Re: Viewtopic URL with "t=XX" instead of "f=XX&t=XX"

Post by Erik Frèrejean » Tue Dec 11, 2012 11:57 am

kaleidoscope wrote:Basically, it just bothers me. I don't understand why it's even there. The forum number doesn't even do anything.
That isn't correct. The f flag is used internally. Yes it isn't directly needed for phpBB to operate, it doesn't hurt on the other hand as well.
Support Toolkit | Support Request Template | Knowledge Base | phpBB 3.0.x documentation
I don't give support via PM or IM! (all unsolicited pms will be trashed!)

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51824
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Viewtopic URL with "t=XX" instead of "f=XX&t=XX"

Post by Brf » Tue Dec 11, 2012 3:46 pm

If I am remembering correctly, the f= parameter is most important for Global Announcements. Since global announcements do not have a forum_id in their database entry, the f= is needed in the URL.

Locked

Return to “[3.0.x] Support Forum”