Page 1 of 1

Connection problem with local version [solved]

Posted: Thu Jan 17, 2013 2:53 pm
by Ariane A
Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? http://local
Who do you host your board with? No answer given
How did you install your board? I used a download package provided by another website
What is the most recent action performed on your board? Update from http://forums.phpbb-fr.com
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
What version of phpBB3 did you update from? phpBB 3.0.10
What MODs do you have installed? many but I don't think it's MOD related.
What styles do you currently have installed? basic ones + one from prosilver
What language(s) is your board currently using? french
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP, ok with phpBB
When did your problem begin? A few days ago
Please describe your problem. Hello,
I first looked for help on the french phpbb board, but they couldn't help me.

My board works well online, however, on my personal computer, I cannot login anymore. But it used to work not so long ago!
If I type http://localhost/monReso/, the board local version is displayed, no problem.
If I type my username+password, the connection seems to proceed, the url at this time is:
http://localhost/monReso/ucp.php?mode=l ... 10c568857e
But just afterwards I'm redirected to my online site http://www.monreso.ch !

In phpmyadmin, table phpbb_config:
cookie_domain : localhost - 0
cookie_name : phpbb3_mrLocal - 0
cookie_path : /monreso/ - 0
script_path : /monreso - 0
server_name : localhost - 0

My config.php file:

Code: Select all

<?php
    // phpBB 3.0.x auto-generated configuration file
    // Do not change anything in this file!
    $dbms = 'mysqli';
    $dbhost = 'localhost';
    $dbport = '';
    $dbname = 'monReso';
    $dbuser = 'root';
    $dbpasswd = '';
    $table_prefix = 'phpbb_';
    $acm_type = 'file';
    $load_extensions = '';

    @define('PHPBB_INSTALLED', true);
    // @define('DEBUG', true);
    // @define('DEBUG_EXTRA', true);
    ?>
I stopped and restarted easyphp several times, restarted the computer. I cannot empty the cache as I cannot login.

Thank you for your help.
Generated by SRT Generator

Re: Connection problem with local version

Posted: Thu Jan 17, 2013 2:59 pm
by Mick
You can manually clear the cache by opening the /cache folder on the server and deleting everything except index.htm and .htaccess (if you can see it). Also, make sure cookies and server settings are set correctly for your localhost. You can also try 127.0.0.1 for the domain name in server settings.

Re: Connection problem with local version

Posted: Thu Jan 17, 2013 3:00 pm
by Brf
Ariane A wrote: I cannot empty the cache as I cannot login.
Delete the /cache/data_global.php

Re: Connection problem with local version

Posted: Thu Jan 17, 2013 3:52 pm
by Ariane A
Thank you. I did. But now it says :
Object not found! (url http://localhost/monreso/index.php?sid= ... 186ddc047c)

please contact webmaster...

I also deleted files starting with tpl and sql. A mistake? I'm sorry.

Re: Connection problem with local version

Posted: Thu Jan 17, 2013 3:56 pm
by Brf
Your script path is wrong.

Re: Connection problem with local version

Posted: Thu Jan 17, 2013 4:03 pm
by stevemaury
And your cookie path should be just /.

No problem deleting those files from /cache.

Re: Connection problem with local version

Posted: Thu Jan 17, 2013 6:40 pm
by Ariane A
Thanks to all of you!
I think script path (small caps/capital letters not the same!) was the main problem.

Re: Connection problem with local version

Posted: Fri Jan 18, 2013 5:12 am
by Lumpy Burgertushie
Ariane A wrote:Thanks to all of you!
I think script path (small caps/capital letters not the same!) was the main problem.
yep, windows seems to be the only place that case doesn't matter.

forum and Forum are not the same file/folder name in most of the computer/internet world but they are in the windows world.
you also can not use spaces in file/folder names anywhere but windows.

I find it easiest to only use lower case and never use spaces. that way there is never a worry or mistake.

luck,
robert