Single User Having SQL Errors

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
TopHouse
Registered User
Posts: 204
Joined: Thu Sep 16, 2010 10:43 am
Contact:

Single User Having SQL Errors

Post by TopHouse »

I'm stumped with this and am convinced it's something at the guys end and not my site as no-one at all is having problems except him.

He's using an ipad, so thats a foreign language to me immediately, but if he tries to post he gets errors like this :-

SQL Error [mysql4]

Incorrect string value:
'\xFO\x9F\x98\x80\xOAI...' for
column 'post_text' at row 1 [1366]

An SQL error occured while fetching this page.


So, has anyone any idea what the problem is please?

Thanks,

Dion
Janet Ward
I've Been Banned!
Posts: 64
Joined: Sun Feb 10, 2013 2:45 am

Re: Single User Having SQL Errors

Post by Janet Ward »

TopHouse
Registered User
Posts: 204
Joined: Thu Sep 16, 2010 10:43 am
Contact:

Re: Single User Having SQL Errors

Post by TopHouse »

Doesn't really help, all that shows me is people having problems with their board, this is a single user out of 4000 members who is having the issue.
UnknownTBeast
Registered User
Posts: 58
Joined: Fri May 21, 2010 4:18 pm

Re: Single User Having SQL Errors

Post by UnknownTBeast »

I know on my board, when someone is trying to post Asian characters, they will get a similar error. Can't recall if it is the exact, but you could check with this user if they are trying to post anything 'odd'.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Single User Having SQL Errors

Post by Oyabun1 »

It could be that they are trying to post a character that other users are not and that is the reason only they experience it. You should try the "The Fix" in this article Doesn't have a default value errors or the MySQL Upgrader tool in the Support Toolkit and see if that resolves the error.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
TopHouse
Registered User
Posts: 204
Joined: Thu Sep 16, 2010 10:43 am
Contact:

Re: Single User Having SQL Errors

Post by TopHouse »

[SOLVED]

This is solved and I'm posting the solution for obvious reasons.

The guy with the issue could post quite happily from computers at work etc with no issue, so we had it down to being an issue with either his ipad or how he was using it.

The solution is......


phpbb was choking because he was trying to post ipad smilies to the forum.
tosiara
Registered User
Posts: 12
Joined: Thu Nov 09, 2006 2:36 pm
Location: Vilnius
Contact:

Re: Single User Having SQL Errors

Post by tosiara »

Sorry for bumping old thread, but this is still an issue with 3.0.12 and Ipad/Iphone clients
Is there any bug filed for this?
updown
Registered User
Posts: 542
Joined: Sat Jan 05, 2008 6:53 am

Re: Single User Having SQL Errors

Post by updown »

tosiara wrote:Sorry for bumping old thread, but this is still an issue with 3.0.12 and Ipad/Iphone clients
Is there any bug filed for this?
+1
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Single User Having SQL Errors

Post by Oyabun1 »

It's not a problem with 3.0.12, the issue is caused by the utf8 character set used by MySQL DBMS not supporting 4 byte characters that are outside the MBP (Basic Multilingual Plane). MySQL has added another character set, utf8mb4, but it is only available on MySQL 5.5.3+, which not many web hosts run.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
updown
Registered User
Posts: 542
Joined: Sat Jan 05, 2008 6:53 am

Re: Single User Having SQL Errors

Post by updown »

Oyabun1 wrote:It's not a problem with 3.0.12...
Thanks for the helpful information! Is there a possible workaround like filtering such characters within phpBB before posting to the database?

It may not be a problem with phpBB itself, but as a general problem it is also effecting phpBB-postings - which is very annoying to some iPad-users since they are not aware of the problem.
Locked

Return to “[3.0.x] Support Forum”