bbcodes won't show html replacement

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
evinx
Registered User
Posts: 18
Joined: Sat Feb 16, 2013 11:07 am

bbcodes won't show html replacement

Post by evinx » Wed Mar 06, 2013 8:21 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.11
What is your board's URL? http://guild.evinx.nl/phpbb3
Who do you host your board with? pcextreme.nl
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
What MODs do you have installed? Advanced Smilies Table Details Uninstall

ma 18 feb 2013, 20:56
Custom BBCode Sorting Details Uninstall

di 19 feb 2013, 20:36
Smilies Categories Details Uninstall

di 19 feb 2013, 22:24
Register IP on memberlist Details Uninstall

do 21 feb 2013, 20:48
Auto Backup Details Uninstall

do 21 feb 2013, 21:00
Log connections Details Uninstall

do 21 feb 2013, 21:06
Thanks for posts Details Uninstall

vr 22 feb 2013, 17:42
Paypal Donation Mod Details Uninstall

vr 22 feb 2013, 21:39
Favicon 1.0.2 Details Uninstall

za 23 feb 2013, 14:35
Custom BBCode Permission - (who can use them) Details Uninstall

za 23 feb 2013, 15:20
FAQ Manager Details Uninstall

ma 25 feb 2013, 17:46
UMIL - Unified Mod Install Library Details Uninstall

ma 25 feb 2013, 17:47
Prime Links Details Uninstall

di 26 feb 2013, 18:03
OAuthorize phpBB mod by pu Details Uninstall

wo 27 feb 2013, 16:32
Ultimate Quiz MOD Details Uninstall

za 02 maart 2013, 00:43
Polls Results FX Details Uninstall

za 02 maart 2013, 02:56
Advanced Show Poll Voters Details Uninstall

za 02 maart 2013, 03:51
phpBB mChat Details Uninstall

za 02 maart 2013, 22:02
Points MOD Details Uninstall

ma 04 maart 2013, 20:14
ACP Announcement Centre Details Uninstall

ma 04 maart 2013, 22:05
I forgot - Send Username and Password Details Uninstall

wo 06 maart 2013, 19:11
What styles do you currently have installed? dirtyboard2.0
What language(s) is your board currently using? Dutch (NL)
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? demo
What password can be used to view this issue? Demo112
When did your problem begin? yesterday after reloading templates
Please describe your problem. if i post something like

Code: Select all

 [code]<a href='domein.nl">link to page </a>
[/code]

it will viewed as

Code: Select all

 [code] <a href='domein.nl">link to page </a>
[/code]

the

Code: Select all

[code]tags
[/code] stay on the post

thats the same with

Code: Select all

[attachment=0]image or something[/attachment]
if its a image the image will be placed between the 2 tags

Code: Select all

    [attachment=0]img[/attachment]
what can i do or what went wrong ?

please help me
Generated by SRT Generator

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50495
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: bbcodes won't show html replacement

Post by stevemaury » Wed Mar 06, 2013 9:02 pm

For starters, your board is version 3.0.11 but your style is for version 3.0.4. Switch to prosilver and see if the problem remains.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

evinx
Registered User
Posts: 18
Joined: Sat Feb 16, 2013 11:07 am

Re: bbcodes won't show html replacement

Post by evinx » Thu Mar 07, 2013 8:11 pm

thats true but every thing work fine until yesterday

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: bbcodes won't show html replacement

Post by Oyabun1 » Thu Mar 07, 2013 10:27 pm

stevemaury wrote: Switch to prosilver and see if the problem remains.
Did you try prosilver?
evinx wrote:When did your problem begin? yesterday after reloading templates
Why did you "reload" the templates? If it was after installing a MOD check the edits for the MOD were made correctly there may be a code error.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

evinx
Registered User
Posts: 18
Joined: Sat Feb 16, 2013 11:07 am

Re: bbcodes won't show html replacement

Post by evinx » Fri Mar 08, 2013 7:41 pm

sorry :) hahaha yes i try on prosilver but not working also

in what files are the default bbcodes


i have to refresh templates for editing some things like

birthday name and age now its only names
i turn that back and the problem is still there so its not my code edit :)

maybe i can post the files where the bbcode request - replacments - codes ect are standing

but if you can tell me what files that are :)



very sorry for my bad english i hope you understand me :)

evinx
Registered User
Posts: 18
Joined: Sat Feb 16, 2013 11:07 am

Re: bbcodes won't show html replacement

Post by evinx » Sun Mar 17, 2013 12:01 pm

bump ?

mikedijital
Registered User
Posts: 39
Joined: Fri Dec 28, 2012 6:05 am

Re: bbcodes won't show html replacement

Post by mikedijital » Sun Mar 17, 2013 1:41 pm

when you say you " reloaded the templates "

do you mean you hit the refresh template link in the admin control panel in the styles tab

or

You reuploaded to template files from your original phpbb software you downloaded to your server, overwriting the ones that were glitching up on you that were on your server already

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: bbcodes won't show html replacement

Post by HGN » Sun Mar 17, 2013 9:56 pm

evinx wrote:ma 18 feb 2013, 20:56
Custom BBCode Sorting Details Uninstall

za 23 feb 2013, 14:35
Custom BBCode Permission - (who can use them) Details Uninstall
At least two of your MOD's could have caused this in case you made mistakes with your edits.
Also, are you sure the permission from the last quoted MOD allow usage of all BBCodes?

The issue could be in several files. Are you able to run a MySQL query to see if the problem occurs during posting or during parsing the posts?
If you are able to run a MySQL query, make a post on your board with the following text:

Code: Select all

[b]Vetgedrukt[/b]
[color=#FF0000]Red[/color]
[kleur=#FF0000]Rood[/kleur]
Check the post_id of that post.

Then run the following MySQL query and show the results here.

Code: Select all

SELECT post_text, bbcode_bitfield, bbcode_uid FROM phpbb_posts WHERE post_id = berichtnummer
In case the table prefix is other than phpbb_ you need to change that to the correct table prefix.
Replace berichtnummer with the id of the post you placed on your board.

evinx
Registered User
Posts: 18
Joined: Sat Feb 16, 2013 11:07 am

Re: bbcodes won't show html replacement

Post by evinx » Sat Mar 23, 2013 7:08 pm

Code: Select all

CREATE TABLE IF NOT EXISTS `phpbb_posts` (
  `post_id` mediumint(8) unsigned NOT NULL AUTO_INCREMENT,
  `topic_id` mediumint(8) unsigned NOT NULL DEFAULT '0',
  `forum_id` mediumint(8) unsigned NOT NULL DEFAULT '0',
  `poster_id` mediumint(8) unsigned NOT NULL DEFAULT '0',
  `icon_id` mediumint(8) unsigned NOT NULL DEFAULT '0',
  `poster_ip` varchar(40) COLLATE utf8_bin NOT NULL DEFAULT '',
  `post_time` int(11) unsigned NOT NULL DEFAULT '0',
  `post_approved` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `post_reported` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `enable_bbcode` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `enable_smilies` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `enable_magic_url` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `enable_sig` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `post_username` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `post_subject` varchar(255) CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL DEFAULT '',
  `post_text` mediumtext CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
  `post_checksum` varchar(32) COLLATE utf8_bin NOT NULL DEFAULT '',
  `post_attachment` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `bbcode_bitfield` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `bbcode_uid` varchar(8) COLLATE utf8_bin NOT NULL DEFAULT '',
  `post_postcount` tinyint(1) unsigned NOT NULL DEFAULT '1',
  `post_edit_time` int(11) unsigned NOT NULL DEFAULT '0',
  `post_edit_reason` varchar(255) COLLATE utf8_bin NOT NULL DEFAULT '',
  `post_edit_user` mediumint(8) unsigned NOT NULL DEFAULT '0',
  `post_edit_count` smallint(4) unsigned NOT NULL DEFAULT '0',
  `post_edit_locked` tinyint(1) unsigned NOT NULL DEFAULT '0',
  `points_received` mediumint(8) unsigned NOT NULL DEFAULT '0',
  PRIMARY KEY (`post_id`),
  KEY `forum_id` (`forum_id`),
  KEY `topic_id` (`topic_id`),
  KEY `poster_ip` (`poster_ip`),
  KEY `poster_id` (`poster_id`),
  KEY `post_approved` (`post_approved`),
  KEY `post_username` (`post_username`),
  KEY `tid_post_time` (`topic_id`,`post_time`),
  FULLTEXT KEY `post_subject` (`post_subject`),
  FULLTEXT KEY `post_text` (`post_text`),
  FULLTEXT KEY `post_content` (`post_subject`,`post_text`)
) ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_bin AUTO_INCREMENT=210 ;

--
-- Gegevens worden uitgevoerd voor tabel `phpbb_posts`
--

INSERT INTO `phpbb_posts` (`post_text`, `bbcode_bitfield`, `bbcode_uid`) VALUES
('[b:3vyw5kyc]Vetgedrukt[/b:3vyw5kyc]\n[color=#FF0000:3vyw5kyc]Red[/color:3vyw5kyc]\n[kleur=#FF0000:3vyw5kyc]Rood[/kleur:3vyw5kyc]', 'QgAAAAAAAAAAAAAAgA==', '3vyw5kyc');

/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;


[kleur=red]ROOD[/kleur]
this code is working some times for now :)

User avatar
HGN
Former Team Member
Posts: 4706
Joined: Wed Dec 03, 2008 1:53 pm
Location: The Netherlands
Name: Alfred
Contact:

Re: bbcodes won't show html replacement

Post by HGN » Mon Mar 25, 2013 12:36 am

Where does that code come from?

Looking at your board, you now disallowed usage of and [color] bbcodes?

Locked

Return to “[3.0.x] Support Forum”