Whois function not working

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Whois function not working

Post by Solidjeuh »

Hello,

The Whois function is not working on my forum.
I guess it's port 43 that needs to be open on my host?
I asked that on their helpdesk, And the are refusing to use open that port for security reasons.

They gave me a .pdf file with the ports my host is using ( see screenshot at the bottom )
Now, is there any way that I can get the Whois function to work please?

Image

The Whois page:

Image
I don't suffer from insanity. I enjoy every minute of it.
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Whois function not working

Post by Oyabun1 »

The information from your host isn't very helpful because it only says which ports are in use not which can be used. However, if your host has disabled the fsockopen() function (which may be the problem) then you won't be able to make a connection with the user_ipwhois function on any port.

You can do a simple check, it's not necessarily certain, for the fsockopen() function:
  1. Download this script – support_info.php
  2. Upload it to the root of your board installation.
  3. Navigate your browser to the file (generally, just replace index.php in your board address with support_info .php, so for example, the address here would be https://www.phpbb.com/community/support_info.php)
  4. Select: PHP info
  5. Copy and paste the information it shows in the blue box to here.
  6. (The file has an option to delete itself. The file doesn't present much of a risk, but it is a good idea to clean up unnecessary files.)
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
User avatar
Solidjeuh
Registered User
Posts: 522
Joined: Wed Oct 06, 2010 11:20 pm
Location: Aalst / Belgium
Name: Andy Dm
Contact:

Re: Whois function not working

Post by Solidjeuh »

It's open

PHP Values
PHP version: 5.3.25
upload_max_filesize: 96 MB
post_max_size: 96 MB
memory_limit: 128 MB
∴ Maximum file upload size: ≤ 96 MB
Max execution time: 50 secs
Max input time: 60 secs
output_buffer: No
file_uploads enabled: Yes
fsockopen(): Yes
allow_url_fopen: Yes
GD library loaded
[phpBB Debug] PHP Warning: in file [ROOT]/support_info.php on line 547: exec() has been disabled for security reasons
ImageMagick exists
getimagesize remote: Working
getimagesize local: Working
I don't suffer from insanity. I enjoy every minute of it.
Locked

Return to “[3.0.x] Support Forum”