{URL} in BBcode - Incorrect string value

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

{URL} in BBcode - Incorrect string value

Post by sotis » Wed Oct 02, 2013 4:09 pm

Hi everybody,

When I try to add new or edit old BBcode and if I add {URL}, {LOCAL_URL} or {RELATIVE_URL} on the "BBCode usage" I got this error:

Code: Select all

SQL ERROR [ mysql4 ]

Incorrect string value: '\x80-\xFFa-z...' for column 'first_pass_match' at row 1 [1366]

SQL



BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 758
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/acp/acp_bbcodes.php
LINE: 234
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/functions_module.php
LINE: 507
CALL: acp_bbcodes->main()

FILE: [ROOT]/adm/index.php
LINE: 76
CALL: p_master->load_active()
And I know for "doesnt-have-a-default-value-problem" in database and I already did that fix. Also I tried to add BBcode with fresh phpBB3 files on the same database and there was no problem.
So I think it is probably some file I edited, which is not in the right encoding.

My question is: Which files are involved in that process for adding BBcode in database, so I can check these files?

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: {URL} in BBcode - Incorrect string value

Post by Oyabun1 » Wed Oct 02, 2013 10:52 pm

Have you updated your board to 3.0.12 yet? There was a change in the handling of LOCAL_URL in the latest version.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Re: {URL} in BBcode - Incorrect string value

Post by sotis » Thu Oct 03, 2013 3:23 pm

Yes I updated to 3.0.12, but the problem is for a bit of time ago. It doesn't exist with fresh phpBB3 files on the same database.
I think it is from the edits in wrong encoding I made on some file, but it is hard for me to find which one. So if you can tell me which files are involved with adding BBcode in the database?

Edit:
OK, I found the problem.
Because of Cyrillic characters in the domain names I made an edits how it is suggested here:
http://area51.phpbb.com/phpBB/viewtopic ... 67#p203967
And in the posts it is very nice but it messed my BBcode and some mods. And unfortunately as I see I can't have nice links in the posts and properly working BBcodes :cry:

So when it will be support for non-English characters in the domain names?
Last edited by sotis on Wed Nov 05, 2014 6:39 pm, edited 1 time in total.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: {URL} in BBcode - Incorrect string value

Post by Oyabun1 » Thu Oct 03, 2013 9:34 pm

sotis wrote:So when it will be support for non-English characters in the domain names?
When it is done.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

Locked

Return to “[3.0.x] Support Forum”