Error with add Topic and Reply!

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

Error with add Topic and Reply!

Post by james2222 » Mon Dec 02, 2013 2:05 pm

Hi all,

Can anyone help me please?

My Last update was phpBB3 Version 3.0.12
on my forums was done on the 11/11/2013
And since the I no one and am as amdin can add a new Topic or a reply! :(
As when you try I get this page up...

General Error

SQL ERROR [ mysql4 ]

Field 'event_attendees' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_topics (topic_poster, topic_time, topic_last_view_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (54, 1385992573, 1385992573, 51, 0, 1, 'test', '[007]Bullock 007', 'AA0000', 0, 0, 0)

BACKTRACE


FILE: [ROOT]/includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1983
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/posting.php
LINE: 1141
CALL: submit_post()




BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 602
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1983
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/posting.php
LINE: 1141
CALL: submit_post()



And I have tryed to add the old " includes " files, But still no joy, And I have tryed to reupload the new phpBB3 Version 3.0.12 as well. :?

Please can you help me.

Thank you

James - [007] Clan Leader

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69417
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Error with add Topic and Reply!

Post by KevC » Mon Dec 02, 2013 2:08 pm

The error is with what ever MOD the 'event attendees' field is coming from.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

Re: Error with add Topic and Reply!

Post by james2222 » Mon Dec 02, 2013 2:22 pm

Kevin Clark wrote:The error is with what ever MOD the 'event attendees' field is coming from.

Hell Kevin Clark,

Thank you for your reply, I am a novice about all this and MOD's :oops:

Please can you tell me a walkthrough how to fix this?

Take care

James - [007] Clan Leader

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50859
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Error with add Topic and Reply!

Post by stevemaury » Mon Dec 02, 2013 2:25 pm

As the forum description says, there is no MOD support in this forum. You need to get support wherever you got that MOD.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

Re: Error with add Topic and Reply!

Post by james2222 » Mon Dec 02, 2013 2:42 pm

Hi

I got it from this website on downloads https://www.phpbb.com/downloads/?from=submenu :?

Take care

James - [007] Clan Leader

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69417
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Error with add Topic and Reply!

Post by KevC » Mon Dec 02, 2013 2:48 pm

MOD support is on the page where you downloaded it. They're supported by the author.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69417
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Error with add Topic and Reply!

Post by KevC » Mon Dec 02, 2013 3:28 pm

Not the MODs in development forum.

Which MOD have you added? What's it called?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

Re: Error with add Topic and Reply!

Post by james2222 » Tue Dec 03, 2013 12:56 am

Hi

All I have done is download phpBB3 Version 3.0.12 as the forums said it was out of date, But I took out the... config.php, the /images and /files folders. Like I always do when I update and the skin I use is.. CoDFaction

I still don't know how to fix my forums.

Link http://www.007-clan.co.uk/forum/


Take care

James - [007] Clan Leader

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Error with add Topic and Reply!

Post by Oyabun1 » Tue Dec 03, 2013 1:19 am

event_attendees isn't a standard field in a phpBB database so must have come from somewhere else.

Please fill out the Support Request Template and post it back here to enable us to assist you better.

What method did you use to update, it sounds like you did a file replacement? Have you updated your style, it seems to be many versions out of date?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

" NEW TOPICE " And " REGISTER " Button errors

Post by james2222 » Thu Dec 05, 2013 11:56 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.12
What is your board's URL? http://www.007-clan.co.uk/forum/
Who do you host your board with? http://www.3ix.org/index.php
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
What version of phpBB3 did you update from? phpBB 3.0.11
What styles do you currently have installed? CoDFaction
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP but not phpBB
What username can be used to view this issue? Waagehiqizieh
What password can be used to view this issue? Testmyforum007
When did your problem begin? About 3 weeks after the new update to phpBB 3.0.11
Please describe your problem.

1, When you try and add a new message to " NEW TOPICE " it comes up with a error page! But as a Admin it still comes up with a error page but a lot more info messages, That you can't see as a none Admin, But here is what I can see as a Admin.

General Error

SQL ERROR [ mysql4 ]

Field 'event_attendees' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_topics (topic_poster, topic_time, topic_last_view_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (54, 1385843007, 1385843007, 64, 0, 1, 'test', '[007]Bullock 007', 'AA0000', 0, 0, 0)

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1983
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/posting.php
LINE: 1141
CALL: submit_post()

But you will see just as a user a different one which you will be able to see when you login.

2, Now the " REGISTER " Button don't work as well it comes up with " Creating a new account is currently not possible. "

I think that is all that is not working, I have try to reinstall again but it still stays the same.

When I do a new update I do not upload " config.php, the /images and /files folders. "

But the rest of the files I do, But I have always done that for over 5 years now, So That should not be the fault.

Please can you help me fix my forums? If must I don't mind letting you have my admin login info as well if you need it.

Thank you and take care

James / [007] Clan Leader
Generated by SRT Generator

james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

Re: Error with add Topic and Reply!

Post by james2222 » Fri Dec 06, 2013 5:23 am

Hi,

I have fixed the REGISTER " Button, But still can't add a new topic.

User avatar
COD3M4ST3R-X
Registered User
Posts: 2269
Joined: Sat Aug 02, 2008 5:47 am
Location: Lahore,Pakistan

Re: Error with add Topic and Reply!

Post by COD3M4ST3R-X » Fri Dec 06, 2013 5:46 am

Does the same error occurs with the default Prosilver style? Since, you say you don't have any MODs installed.
Did you updated your Style to 3.0.12?
“Need and struggle are what excite and inspire us.”

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69417
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Error with add Topic and Reply!

Post by KevC » Fri Dec 06, 2013 8:55 am

james2222 wrote:Do you have any MODs installed? No
This is not correct.
You've added some sort of calendar MOD which is adding an event flag, which is where the error is coming from.

So you have 2 options.

- You ask the MOD author what the fix is.
- You upload all new files and clean the database to get back to a MOD free board.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

james2222
Registered User
Posts: 14
Joined: Mon Dec 02, 2013 1:40 pm

Re: Error with add Topic and Reply!

Post by james2222 » Sat Dec 07, 2013 10:25 pm

HI,

I have never had this error before until I installed 3.0.12 phpBB Download from 3.0.11 phpBB Download !

I have done a search in all files for calendar and there was some in my old 2009 prosilver style, So I reinstalled the prosilver style without the calendar files and still no joy, Not only that I am not using that style anyway but I still updated it.

I give up :?

I am thinking of reinstalling 3.0.11 phpBB ? to see if that does it!

And yes I have tried all the other style's and I still can't add a " NEW TOPIC "

Thank you

James - [007] Clan Leader

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69417
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Error with add Topic and Reply!

Post by KevC » Sat Dec 07, 2013 10:28 pm

Do you want to keep the calendar MOD?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Locked

Return to “[3.0.x] Support Forum”