Page 1 of 1

Not sending notification emails when a reply is posted

Posted: Wed Dec 18, 2013 7:15 pm
by yogi3
My forum www.pronas.pl using version 3.0.12 and not sending notification emails when a reply is posted. I am using SMTP server, I setup package size to 0, I changed queue time to 6 seconds, I also tried to comment flush in cron.php, nothing helped.

Sending mass e-mails working withot any issue, as well as registration confirmation and PW notification. Strange is that I cannot see queue.php in cache folder.

Any idea what else can I do to make it run ?

Re: Not sending notification emails when a reply is posted

Posted: Wed Dec 18, 2013 8:33 pm
by Lumpy Burgertushie
are you subscribed to the topic or the forum?

are you expecting a new email for every reply to the topic? that is not how it works. you only get one email no matter how many replies were made to the topic since you were there last.

once you visit the topic you will get a new email when there are any new replies to the topic.


robert

Re: Not sending notification emails when a reply is posted

Posted: Wed Dec 18, 2013 8:41 pm
by yogi3
I checked "Notify me when a reply is posted" and yes I know how it should work, problem is that I never ever get even single e-mail that was sent as notification.

You can register on my forum and create test topic, then I will reply for it, and then you will see that you will not receive notification e-mail from my forum.

Any idea what else should I do to make it work ?

Re: Not sending notification emails when a reply is posted

Posted: Thu Dec 19, 2013 10:05 am
by yogi3
Anyone can help ?

Re: Not sending notification emails when a reply is posted

Posted: Thu Dec 19, 2013 10:38 am
by Oyabun1
You are using phpBB-SEO which is a fork of phpBB we do not support. You would need to seek support by following the link in the footer of your board.

Re: Not sending notification emails when a reply is posted

Posted: Sat Dec 21, 2013 8:01 am
by yogi3
Just let me know which part of code is responisble for sending notification emails when a reply is posted. If I know that I will be able to compare it with fresh installation maybe this is a way to found solution for me?

Re: Not sending notification emails when a reply is posted

Posted: Sat Dec 21, 2013 8:40 am
by Oyabun1
The point is that phpBB-SEO is substantially different to the standard product, that is why we can't support it.

Very little in phpBB is done with a single piece of code. In standard phpBB notifications are mainly handled by /posting.php and /includes/functions_messenger.php

Re: Not sending notification emails when a reply is posted

Posted: Sat Dec 21, 2013 2:58 pm
by yogi3
I made some test, I copied files you mention to my forum but it didn`t solved the problem, so I changed config.php in fresh phpbb to force it to connect to pronas.pl database. Then I checked emails notification and now I can confirm it is working. So I am sure that problem is not related to data base or to server, it is for sure code issue. Question is where is the bug, like I told you I overwrited old files that you mention by fresh files but it not solved my problem. So maybe there is other code that can be related to my problem. Is there any way to debug it ?

Re: Not sending notification emails when a reply is posted

Posted: Sat Dec 31, 2016 7:32 pm
by no_comment
I have this problem with all my forums:
http://3sudest.eu.org
My version is 3.0.14. :(