Install.xml will not open on Mac

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Install.xml will not open on Mac

Post by DragonMaster1 » Thu Jan 30, 2014 8:26 am

I find that the newer mods that have an install.xml and modx.prosilver.en.xsl in the folder will not open in a mac browser. This is odd since most all of my old mods are also lie this and have no problem opening.

How can I view these install directions do do the code installs now?

Thanks in Advance!

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69092
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Install.xml will not open on Mac

Post by KevC » Thu Jan 30, 2014 9:28 am

I sometimes find they open in safari but not firefox and vice versa but I haven't come across any that don't show correctly.

Which MOD are you looking at. I'll try it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Thu Jan 30, 2014 10:07 am

My old ones all pen in Safari but now the new ones don't unless I open it with BBEdit and make a new .xml file in Dreamweaver and change the header code to this and open it in the same folder as the other files....as you know:

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="modx.prosilver.en.xsl"?>
<!--For security purposes, please check: http
://www.phpbb.com/mods/ for the latest version of this MOD. Although MODs are checked before being allowed in the MODs Database there is no guarantee that there are no security problems within the MOD. No support will be given for MODs not found within the MODs Database which can be found at http://www.phpbb.com/mods/-->
<mod xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.phpbb.com/mods/xml/modx-1.2.3.xsd">

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Thu Jan 30, 2014 10:08 am

OH....that is Ajax Chat

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69092
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Install.xml will not open on Mac

Post by KevC » Thu Jan 30, 2014 10:27 am

You mean the one from here circa 2006?
http://www.ajaxchat.org/Download/
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Install.xml will not open on Mac

Post by Oyabun1 » Thu Jan 30, 2014 11:49 am

Are you unzipping the MOD package first before trying to read in the install.xml file?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Thu Jan 30, 2014 9:08 pm

Yes I was referring to the old file, it was the first one I just tried for an example.

And OF COURSE unzipping it first as how could it do anything otherwise?

User avatar
Lumpy Burgertushie
Registered User
Posts: 66320
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Install.xml will not open on Mac

Post by Lumpy Burgertushie » Thu Jan 30, 2014 9:31 pm

DragonMaster1 wrote:Yes I was referring to the old file, it was the first one I just tried for an example.

And OF COURSE unzipping it first as how could it do anything otherwise?
you could be trying to read the file while it is still zipped.

don't know about MAC zip programs but everyone I ever tried opens the file in a window to ask you where you want to unzip it to. from that window you can double click on any file in the zip and try to open it.

often it does not work because the zip program does not know what program to open the file with.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Thu Jan 30, 2014 9:43 pm

Clicking a Mac zip creates a folder next to it the the uncompressed items in it

User avatar
Lumpy Burgertushie
Registered User
Posts: 66320
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Install.xml will not open on Mac

Post by Lumpy Burgertushie » Thu Jan 30, 2014 9:55 pm

same thing they do for pcs. can you double click on one of the files listed in that folder and try to open it?

that is what he was referring to.


also, you need to set your file associations so that xml files open in whatever program you want them to.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Thu Jan 30, 2014 11:33 pm

Apparent you have NO Mac experience.

Clicking them opens with their default application unless you set it otherwise. The default is Xcode but then you can drag and drop it on the Safari dock icon and it opens as a BLANK screen which is exactly what I was writing in about. And not ALL do that only some. But I know how to open then as I said in my first post by changing the header. BUT....doing THAT more then a couple times is a BIG PITA and it should NOT have to be done. Dragging to Safari OR setting Safari as their default app SHOULD open them where they CAN be read but not all of them do this. So what is the problem there and HOW can it be fixed OTHER than having to keep changing the header????

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69092
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Install.xml will not open on Mac

Post by KevC » Fri Jan 31, 2014 10:10 am

DragonMaster1 wrote:Yes I was referring to the old file, it was the first one I just tried for an example.
That particular MOD does not have any xml files in it. In that instance, you would have to ask the author about installation.

Do you have an example of a normal MOD from here that has an xml that won't open so I can try it?
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Fri Jan 31, 2014 11:58 am

This was one I downloaded several years ago and that filer just happened to be open and YES IT DID have install.xml files in it

Besides that point many of the current ones which I didn't feel like going through then ALSO have install.xml files of which about half of then open when dragged to Safari with a BLANK SCREEN and THAT was what I was writing about.

So how do others get these open PROPERLY and WITHOUT having to manually change their header?

User avatar
battye
Extension Customisations
Extension Customisations
Posts: 10933
Joined: Wed Feb 11, 2004 11:02 am
Location: Australia
Contact:

Re: Install.xml will not open on Mac

Post by battye » Fri Jan 31, 2014 12:55 pm

As Kevin Clark said, can you please provide an example of a file that won't open?

Just a link to a MOD you've downloaded and can't open would be fine - just something that we can try for ourselves as a number of us use Macs and we can try and replicate this issue.
Customisations Team Member

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Fri Jan 31, 2014 5:38 pm

This is STUPID....

You KNOW as well as I that this is a major problem as there are numerous complaints about it

SO...I went to the Mods Database and picked the 1st ADD ON that is there: Zodiac_Signs_1_0_3.zip

DOES NOT OPEN if dragged to Safari

Locked

Return to “[3.0.x] Support Forum”