Install.xml will not open on Mac

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69101
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Install.xml will not open on Mac

Post by KevC » Wed Mar 19, 2014 11:59 am

Pixel8r wrote:
Kevin Clark wrote:We've been asking you for examples of MODs where you see this and so far you've only provided one example and that worked fine for me in firefox.

We can't fix things if you don't tell us which of the hundreds of MODs you're getting it on.
Ok here's an example of one I tried today and just got a blank with safari and Firefox.

https://www.phpbb.com/customise/db/mod/ ... code_box_3

I was trying the upgrade XML from 3.0.12 to 3.0.13

I can honestly say that most mod XML install files are now unreadable in Mac Safari and Firefox. Be good if this is fixed.
Mac firefox on the left, safari on the right.

Works fine for me.

I downloaded, double clicked to decompress and dragged the install xml file in to the browser window.
Attachments
Screen shot 2014-03-19 at 11.58.06.png
Screen shot 2014-03-19 at 11.58.06.png (125.21 KiB) Viewed 1098 times
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Wed Mar 19, 2014 1:26 pm

ODD who this works for some and NOT for others

I would THINK that THAT would count as a PROBLEM :?:

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21129
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Install.xml will not open on Mac

Post by Mick » Wed Mar 19, 2014 6:09 pm

DragonMaster1 wrote:THAT would count as a PROBLEM
It is but not a phpBB issue otherwise there would be, literally, thousands of such posts especially in the discussion/support areas for each MOD. You have probably read this but just in case Opening a modification for the first time.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Pixel8r
Registered User
Posts: 177
Joined: Mon Nov 30, 2009 4:39 pm
Contact:

Re: Install.xml will not open on Mac

Post by Pixel8r » Wed Mar 19, 2014 6:43 pm

Kevin Clark wrote:
Pixel8r wrote:
Kevin Clark wrote: Mac firefox on the left, safari on the right.

Works fine for me.

I downloaded, double clicked to decompress and dragged the install xml file in to the browser window.
I have just tried opening the XML listed above on another mac, it displayed correctly in firefox on this one but again the safari window was blank.

BTW the computer I tried it on yesterday was a brand new Mac Pro with a freshly installed version of Safari and Firefox, so it isn't some configuration problem from what I can see.

It very unpredictable if it works or not so there is obviously a problem that needs fixing.
24knews.com - We live on the edge of chaos.

User avatar
Pixel8r
Registered User
Posts: 177
Joined: Mon Nov 30, 2009 4:39 pm
Contact:

Re: Install.xml will not open on Mac

Post by Pixel8r » Wed Mar 19, 2014 6:45 pm

Mick wrote:
DragonMaster1 wrote:THAT would count as a PROBLEM
It is but not a phpBB issue otherwise there would be, literally, thousands of such posts especially in the discussion/support areas for each MOD. You have probably read this but just in case Opening a modification for the first time.
You will probably start to see more mac users come out and confirm the problem now there is a thread about it.
24knews.com - We live on the edge of chaos.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21129
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Install.xml will not open on Mac

Post by Mick » Wed Mar 19, 2014 7:00 pm

Pixel8r wrote:You will probably start to see more mac users come out and confirm the problem now there is a thread about it
I'm sure that if it was that big a problem there would already be hundreds of topics (not threads) on the subject stretching back to 3.0.0. As far as I'm aware XML is compatible with both MS and Mac platforms.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
Pixel8r
Registered User
Posts: 177
Joined: Mon Nov 30, 2009 4:39 pm
Contact:

Re: Install.xml will not open on Mac

Post by Pixel8r » Wed Mar 19, 2014 7:44 pm

Mick wrote:
Pixel8r wrote:You will probably start to see more mac users come out and confirm the problem now there is a thread about it
I'm sure that if it was that big a problem there would already be hundreds of topics (not threads) on the subject stretching back to 3.0.0. As far as I'm aware XML is compatible with both MS and Mac platforms.
I have always used macs and yes they did open the phpBB MOD XML files fine for years, but around over the last 6 months there started being a problem opening them. Quiet often now I just end up opening the XML files in a txt editor and trying to decode the instructions. Sometimes browsers work, most of the time they just display a blank page. There is obviously a problem which is related to opening XML files on a mac, sorry I don't have a pc to test them on.
24knews.com - We live on the edge of chaos.

User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Re: Install.xml will not open on Mac

Post by DragonMaster1 » Wed Mar 19, 2014 7:45 pm

Mick wrote:
Pixel8r wrote:You will probably start to see more mac users come out and confirm the problem now there is a thread about it
I'm sure that if it was that big a problem there would already be hundreds of topics (not threads) on the subject stretching back to 3.0.0. As far as I'm aware XML is compatible with both MS and Mac platforms.

Image

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21129
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Install.xml will not open on Mac

Post by Mick » Wed Mar 19, 2014 7:57 pm

I don't see, hear or speak any evil. If you seriously think this is a phpBB issue post a bug report.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Install.xml will not open on Mac

Post by RMcGirr83 » Wed Mar 19, 2014 8:08 pm

I wonder if it has anything to do with https:// instead of http:// for the xml download from phpBB. I've never run into it but I don't use/own a Mac.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
Pixel8r
Registered User
Posts: 177
Joined: Mon Nov 30, 2009 4:39 pm
Contact:

Re: Install.xml will not open on Mac

Post by Pixel8r » Wed Mar 19, 2014 9:39 pm

RMcGirr83 wrote:I wonder if it has anything to do with https:// instead of http:// for the xml download from phpBB. I've never run into it but I don't use/own a Mac.
I can't see how it would make a difference how the zip file is downloaded, the contents of it are not changed in anyway. I think this is part of the problem that most don't use macs so don't see the issue.

I download a MOD zip file, expand the zip into a folder, locate the install.XML and right click and say to open in a browser. Like I have been saying it always used to work fine, but around six months or so ago I noticed that they were sometimes displaying blank. It has gradually got worse, so it makes me think there has been some change to the code that has gradually been taken up which is causing it.

Glad that DragonMaster1 has now given me a way to modify the code to make them open again, maybe I will get on with doing some updates again.
24knews.com - We live on the edge of chaos.

User avatar
Pixel8r
Registered User
Posts: 177
Joined: Mon Nov 30, 2009 4:39 pm
Contact:

Re: Install.xml will not open on Mac

Post by Pixel8r » Wed Mar 19, 2014 9:40 pm

Mick wrote:I don't see, hear or speak any evil. If you seriously think this is a phpBB issue post a bug report.
Ok will do when I get time.
24knews.com - We live on the edge of chaos.

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Install.xml will not open on Mac

Post by Oyabun1 » Wed Mar 19, 2014 10:04 pm

Pixel8r wrote:
RMcGirr83 wrote:I wonder if it has anything to do with https:// instead of http:// for the xml download from phpBB. I've never run into it but I don't use/own a Mac.
I can't see how it would make a difference how the zip file is downloaded, the contents of it are not changed in anyway. I think this is part of the problem that most don't use macs so don't see the issue.
I'm pretty sure Rich isn't referring to the zip file butter rather the path of the XML schema definition in the install XML file.

Older MODs will have the path as something like:
xmlns="http://www.phpbb.com/mods/xml/modx-1.2.2.xsd"
New MODs will have:
xmlns="http[color=#FF0000]s[/color]://www.phpbb.com/mods/xml/modx-1.2.6.xsd"
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Install.xml will not open on Mac

Post by RMcGirr83 » Thu Mar 20, 2014 10:50 am

Oyabun1 wrote:I'm pretty sure Rich isn't referring to the zip file butter rather the path of the XML schema definition in the install XML file.

Older MODs will have the path as something like:
xmlns="http://www.phpbb.com/mods/xml/modx-1.2.2.xsd"
New MODs will have:
xmlns="http[color=#FF0000]s[/color]://www.phpbb.com/mods/xml/modx-1.2.6.xsd"
Precisely
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
sleevedbiker
Registered User
Posts: 789
Joined: Mon Oct 12, 2009 4:33 pm

Re: Install.xml will not open on Mac

Post by sleevedbiker » Sat Aug 16, 2014 3:57 am

here's an example for you... Safari on MAC not windows shows Blank mod.XML files, for an example statistics_on_index_1_0_1 when opened to safari shows...
Screen Shot 2014-08-15 at 11.56.37 PM.png
Screen Shot 2014-08-15 at 11.56.37 PM.png (89.99 KiB) Viewed 654 times
And yes there are other topics on this problem.. I even created a topic on this two years ago with no resolution.
You ride with an outlaw, You die with an outlaw

Locked

Return to “[3.0.x] Support Forum”