GALLERY_USERS_TABLE' doesn't exist

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
obnoxiousblue
Registered User
Posts: 92
Joined: Wed Dec 17, 2008 6:57 pm

GALLERY_USERS_TABLE' doesn't exist

Post by obnoxiousblue »

Recently installed the PHPBB Gallery Mod, and it seemed to be working for me... I hadn't set permissions for any other users yet.

Today, my calendar MOD was fixed by the mod author who was very generous in taking a look for me.

After the repair, whenever a user clicks a topic on my boards it generates this error:

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Table 'db484658323.GALLERY_USERS_TABLE' doesn't exist [1146]

SQL

SELECT u.*, z.friend, z.foe, p.*, gu.personal_album_id, gu.user_images FROM (phpbb_users u CROSS JOIN phpbb_posts p) LEFT JOIN phpbb_zebra z ON (z.user_id = 54 AND z.zebra_id = p.poster_id) LEFT JOIN GALLERY_USERS_TABLE gu ON (gu.user_id = p.poster_id) WHERE p.post_id IN (72359, 72360, 72366, 72371, 72374, 72382, 72432, 72434, 72469, 72522, 72523, 72524, 72525, 72529, 72558, 72568, 72569, 72572, 72579, 72584, 72588, 72600, 72631, 72632, 73233) AND u.user_id = p.poster_id

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/viewtopic.php
LINE: 1026
CALL: dbal_mysql->sql_query()
Thus, rendering my boards completely inaccessable at the moment.
I posted over in the Gallery Mod support thread before realizing this was a board-wide error and didnt seem isolated to just the gallery folder.
Can someone point me to a thread on how to fix this issue? Or create the necessary file to get my boards back and running?

obnoxiousblue
Registered User
Posts: 92
Joined: Wed Dec 17, 2008 6:57 pm

Re: GALLERY_USERS_TABLE' doesn't exist

Post by obnoxiousblue »

Fixed for now! Seems like there were files unedited...

User avatar
robertmf
Registered User
Posts: 94
Joined: Wed Sep 25, 2002 7:26 pm
Location: 55 min. by commuter RR outside Filthadelphia
Contact:

Re: GALLERY_USERS_TABLE' doesn't exist

Post by robertmf »

:? Please, what was your complete solution :?
DLI Alumni & Friends Community at DLIFLC.ORG

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: GALLERY_USERS_TABLE' doesn't exist

Post by Oyabun1 »

Seems that it was completing all steps in the install instructions for the MOD.

To receive MOD support please visit our Modifications Database and post in the specific MOD’s designated support area. The link to the support area for each released MOD is also available in the first post of each released MOD listed in the MOD Database Releases forum.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
robertmf
Registered User
Posts: 94
Joined: Wed Sep 25, 2002 7:26 pm
Location: 55 min. by commuter RR outside Filthadelphia
Contact:

Re: GALLERY_USERS_TABLE' doesn't exist

Post by robertmf »

Thanks. I had forgotten about the XML files in the extinct MODS. What I was after are the phpbb version code changes files at Area51
https://area51.phpbb.com/code-changes/3.0.12/

I won't be upgrading to 3.1x until the photo gallery ext is available.
DLI Alumni & Friends Community at DLIFLC.ORG

Locked

Return to “[3.0.x] Support Forum”