Won't send Emails or Verifications

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Won't send Emails or Verifications

Post by ArieDesigns » Tue Jun 10, 2014 6:46 am

I'm having a very simple but confusing Issue. When members register and I have it set to "user verification" no email is being sent out. When I send out "Mass Email" to the members, there is nothing either. No BBC or anything.

And yet I receive no known error in any of the logs. Any thoughts? Is there a setting somewhere I should look?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21666
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Won't send Emails or Verifications

Post by Mick » Tue Jun 10, 2014 6:50 am

Either of these may help you: wiki Email Troubleshooting and 3.2.2.2. Email settings
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Tue Jun 10, 2014 6:36 pm

I followed the instructions and either found myself with the same problem, or I would get an error. No email ever was sent out. I'm really confused by this, since it means no member is getting notifications for anything.

User avatar
tbackoff
Former Team Member
Posts: 7022
Joined: Thu Jun 04, 2009 1:41 am
Location: cheerleading practice
Name: Tabitha Backoff

Re: Won't send Emails or Verifications

Post by tbackoff » Tue Jun 10, 2014 8:01 pm

What settings are you using for e-mail (E-mail Settings under the GENERAL tab). Also, please fill out the Support Request Template and post it back here to enable us to assist you better.
Flying is the second best thrill to cheerleaders; being caught is the first.

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Tue Jun 10, 2014 8:27 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.12
What is your board's URL? http://www.thetenrealms.net
Who do you host your board with? Dreamhost
How did you install your board? I used a tool provided by my host
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
What MODs do you have installed? Register IP on memberlist
NuCaptcha Plugin
ACP User Colour Management
Referrers
Static Pages
Zodiac Signs
What styles do you currently have installed? alerion (Default), Prosilver & Afterburner
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
When did your problem begin? The problem started shortly after install when I changed the default email to the one registered to the site. (Or is my best guess).
Please describe your problem. Something is wrong with our email/notification. It process's like its suppose to, no errors, but nothing is being sent out. People register and receive no activation emails, I send out a mass email and it says that it was sent, but nobody receives anything. After tinkering with the settings I start getting the expected errors but once everything is back to what it should be, nothing happens.
Generated by SRT Generator

Now that is a from I want. :D

Settings:
Enable board-wide e-mails: Enabled
Users send e-mail via board: Disabled
E-mail function name: mail
E-mail package size: 20
Contact e-mail address: ***@gmail.com
Return e-mail address: ***@gmail.com
E-mail signature:

SMTP settings: No
SMTP server address: blank
SMTP server port: Blank
Authentication method for SMTP: PLAIN
SMTP username: blank
SMTP password: Blank (although it is trying to auto-input my forum password but shouldn't be there.)

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Won't send Emails or Verifications

Post by Oyabun1 » Tue Jun 10, 2014 10:29 pm

ArieDesigns wrote:When did your problem begin? The problem started shortly after install when I changed the default email to the one registered to the site. (Or is my best guess).

Settings:
Enable board-wide e-mails: Enabled
Users send e-mail via board: Disabled
E-mail function name: mail
E-mail package size: 20
Contact e-mail address: ***@gmail.com
Return e-mail address: ***@gmail.com
E-mail signature:
How is a Gmail account "registered" to your site?

Assuming your account with your host allows the sending of email your host should have provided information about their email settings. If you don't have that check their FAQs or ask them.

Many hosts now require use of an SMTP service not the mail() function. Also, many hosts require the sender to be an email account on their server not a 3rd party account such as Gmail.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Tue Jun 10, 2014 10:33 pm

I am not 100% I understand the question. The contact and return emails were my personal (g)email account and I changed it to a new email. Just in the contact area it was changed.

I'll check in with my host.

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51874
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Won't send Emails or Verifications

Post by Brf » Wed Jun 11, 2014 12:52 am

ArieDesigns wrote: The problem started shortly after install when I changed the default email to the one registered to the site.
We are unclear what you mean by this. What is a "default email"? If you are not using SMTP, the outgoing email is whatever your host has setup for PHP mail.

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Wed Jun 11, 2014 6:28 am

I am sorry, my terminology wasn't appropriate.

I only changed the email in the Email Setting area and no where else. From one Gmail to another Gmail. I had meant the default for sending emails out would come from.. but apparently I supplied that incorrectly.

User avatar
PinoyEngine™
Registered User
Posts: 244
Joined: Fri Apr 24, 2009 7:12 am

Re: Won't send Emails or Verifications

Post by PinoyEngine™ » Wed Jun 11, 2014 11:34 am

  • Are you sending the verification using your personal Gmail or your server default mail system?
    Because it seems that your SMTP setting for GMAIL is incomplete try the settings instructed here: https://www.digitalocean.com/community/ ... mtp-server
  • If you are sending the verification using your server mail setting, contact your hosting provider.

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Wed Jun 11, 2014 5:15 pm

I emailed my Host. Still waiting on a response.

It should be sending things from my server mail settings and just tagging on the email in the Email settings. I'll try and hook up the smtp and hope that does it.

Thanks!

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51874
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Won't send Emails or Verifications

Post by Brf » Thu Jun 12, 2014 12:05 am

ArieDesigns wrote: I only changed the email in the Email Setting area and no where else. From one Gmail to another Gmail. I had meant the default for sending emails out would come from.. but apparently I supplied that incorrectly.
There are two addresses in the email settings, "contact" and "return". They are used only in the email header, but really have no effect on where the email "comes from". If you are not using SMTP, then the email "comes from" wherever your host has php mail coming from. Hosts often block email from going out if the header addresses are not related to the address of your host.

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Thu Jun 12, 2014 12:07 am

Yup, it's my host.

So i've turned on SMTP, and got all the settings in place and i'm getting this error:
E-mail error
» EMAIL/SMTP
/adm/index.php

Could not get mail server response codes.
Backtrace
Connecting to smtp.gmail.com:465

User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Won't send Emails or Verifications

Post by Oyabun1 » Thu Jun 12, 2014 12:16 am

Does your host allow the use of a 3rd party SMTP service?
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests

User avatar
ArieDesigns
Registered User
Posts: 34
Joined: Mon Oct 10, 2005 5:12 am
Contact:

Re: Won't send Emails or Verifications

Post by ArieDesigns » Thu Jun 12, 2014 12:21 am

The reply from my tech support email.
I'm happy to assist you. I checked the logs for the form on your site and
found that the emails are being bounced by the server due to our anti
spam policy which won't allow email sent from the server using
non-Dreamhost outgoing servers or "send from" email addresses. You can
read more details on this policy here:

http://wiki.dreamhost.com/Sender_Domain ... d_Spoofing

Your mail form uses the visitor's email address as the 'From' address
which in most cases is not a Dreamhost hosted email address. Due to the
spam policy above, the server will block mail being sent off the server
if the email addresses are not using Dreamhost mail servers. So what you
will need to do is either set the mail form to use your Dreamhost hosted
address as the 'From' address.

Or you will need to find another mail form that will allow you to set a
fixed email address as the 'From' address. This way you can set a
Dreamhost hosted email address in the form as the 'From' address.

I do apologize if this has caused any inconvenience. If you have any
other questions or need additional assistance, please let me know and I
will assist you further.


Best regards,
So I don't even know. :( I don't think i have a bad password. I've turned on IMAP via my email settings...

Locked

Return to “[3.0.x] Support Forum”