Invalid argument supplied for foreach()

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
syfodyas
Registered User
Posts: 3
Joined: Mon Apr 13, 2015 1:59 am

Invalid argument supplied for foreach()

Post by syfodyas »

Support Request Template
What version of phpBB are you using? phpBB 3.0.13-PL1
What is your board's URL? http://thepixelsquad.com/dmforum1/
Who do you host your board with? Home Web Server
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
What MODs do you have installed? "Genders"
"Safe Gamertag"
What styles do you currently have installed? proDVGF
What language(s) is your board currently using? American English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
When did your problem begin? It began after I installed two mods.
Please describe your problem. Hello everyone,
I am new to the PHPBB and stuff like this in general, but I can pick up on things pretty quickly, so I like to think. Well...anyway, I installed PHPBB, a style, and two mods. I also began setting up the forums and whatnot. I noticed that random pages I get an error "[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 1312: Invalid argument supplied for foreach()"

Now, I dont know alot about this, like I said, so I went to Google. I couldnt find exact problems, so I thought I would download notepad++ and take a look at the line with the error. The problem is, I have no idea what I am looking at. Anyone know what would cause this? I cannot tell you if the error was there before the mods of after. I seem to get the error on following pages...

"Board Settings" in the ACP
At the top of the registration page

So far, thats all I am seeing. Anyone know what might be able to give me a hand?
Generated by SRT Generator
User avatar
Oyabun1
Former Team Member
Posts: 23162
Joined: Sun May 17, 2009 1:05 pm
Location: Australia
Name: Bill

Re: Invalid argument supplied for foreach()

Post by Oyabun1 »

See Installing MODs the Right Way for some good advice.

The problem doesn't occur with the standard software so is almost certainly from a MOD or more likely an error when installing a MOD.

If you only used Notpad++ after the error occured I don't know what you used to make the file changes to install the MODs. An inappropriate editor could have caused numerous problems.

On your index page below "Who is online" (Array) shows. That appears to be an error that may be related or may be a separate issue.

Check the edits for the MODs to make sure the correct code is in the correct place.
                      Support Request Template
3.0.x: Knowledge Base Styles Support MOD Requests
3.1.x: Knowledge BaseStyles SupportExtension Requests
syfodyas
Registered User
Posts: 3
Joined: Mon Apr 13, 2015 1:59 am

Re: Invalid argument supplied for foreach()

Post by syfodyas »

Thanks for the help.

I toyed around a bit, and ended up doing a fresh install. I removed the mods and still had some issues...so I figured why not. Thanks for the links too!
Locked

Return to “[3.0.x] Support Forum”