Page 1 of 1

Cannot log in

Posted: Tue Apr 26, 2016 11:12 pm
by FreeBaGeL
When I try to log in to my forum I get the errors below, and the login is unsuccessful. I haven't made any changes to the forum in years so I'm guessing this has to do with my webhost upgrading to the latest version of PHP.

Code: Select all

Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /home/moyer921/clan-loh.com/forums/includes/utf/utf_tools.php on line 1663
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1663)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1663)
[phpBB Debug] PHP Notice: in file /includes/session.php on line 1007: Cannot modify header information - headers already sent by (output started at /includes/utf/utf_tools.php:1663)

Warning: Cannot modify header information - headers already sent by (output started at /home/moyer921/clan-loh.com/forums/includes/utf/utf_tools.php:1663) in /home/moyer921/clan-loh.com/forums/includes/functions.php on line 4284

Warning: Cannot modify header information - headers already sent by (output started at /home/moyer921/clan-loh.com/forums/includes/utf/utf_tools.php:1663) in /home/moyer921/clan-loh.com/forums/includes/functions.php on line 4286

Warning: Cannot modify header information - headers already sent by (output started at /home/moyer921/clan-loh.com/forums/includes/utf/utf_tools.php:1663) in /home/moyer921/clan-loh.com/forums/includes/functions.php on line 4287

Warning: Cannot modify header information - headers already sent by (output started at /home/moyer921/clan-loh.com/forums/includes/utf/utf_tools.php:1663) in /home/moyer921/clan-loh.com/forums/includes/functions.php on line 4288
As I understand it, my theme will no longer work with phpbb 3.1. The theme I'm using is fairly heavily modified and getting those modifications moved over to a new theme would take time, and this is a critical time of year for my forum. I need to get it back up and running ASAP and I can worry about a 3.1 upgrade later during more of a downtime. Do I have any options for fixing this error outside of upgrading to 3.1 and re-building all my theme modificaitons by hand?

My current version is 3.0.7

Re: Cannot log in

Posted: Tue Apr 26, 2016 11:20 pm
by 3Di

Re: Cannot log in

Posted: Tue Apr 26, 2016 11:25 pm
by FreeBaGeL
Unfortunately I don't seem to have an /includes/startup.php file

Re: Cannot log in

Posted: Tue Apr 26, 2016 11:32 pm
by 3Di
FreeBaGeL wrote:
Unfortunately I don't seem to have an /includes/startup.php file
FreeBaGeL wrote:My current version is 3.0.7
Hmm, I do not remember if 3.0.7 is missing that file though.

No probs, please run the tool into my signature (right install) so we can see what kind of issue is there.

Thanks.

Re: Cannot log in

Posted: Tue Apr 26, 2016 11:34 pm
by kasimi
As far as I understand the issue you can apply this fix if you use PHP5. Otherwise, do this.

Re: Cannot log in

Posted: Tue Apr 26, 2016 11:41 pm
by 3Di
As a matter of fact while lurking at my 3.0.4 to 3.0.6 old Board's backup I can confirm that the above mentioned file isn't there.

Re: Cannot log in

Posted: Tue Apr 26, 2016 11:45 pm
by FreeBaGeL
Thanks everyone!

The link in Kasimi's post resolved the issue!

I'll ride this out a few more weeks and then start getting caught up with upgrades. Thanks!