Page 1 of 2

automatic login problem

Posted: Tue May 17, 2016 12:20 am
by Flegy33
Hello,

Last several days trying to solved automatic login problem, after automatic login on next visit it show me as loged in but on refresh it logout account.


forum domain: http://www.maxko-forum.info

cookies settings:
http://screencast.com/t/Cz2gJqaKezE

in chrome resources it show:
http://screencast.com/t/xOVDGaApw

it look to me as it have double values in cookie because it save for maxko_ and phpbb3_

Any suggestion how to solved problem is welcome.

Re: automatic login problem

Posted: Tue May 17, 2016 3:30 am
by Lumpy Burgertushie
you site is not currently setting any phpbb cookies at all.

robert

Re: automatic login problem

Posted: Tue May 17, 2016 10:04 am
by Flegy33
how you mean dosent setting any cookies ?

test account

id: test
pw: maxko33

Re: automatic login problem

Posted: Tue May 17, 2016 11:34 am
by Mick
Are you behind some kind of proxy, cloudflare or similar?

I'm seeing this when I check your cookies:
Error: No phpBB was detected at the specified URL
Which is often down to incorrect proxy settings.

Have a read of Knowledge Base - Fixing incorrect cookie settings

Re: automatic login problem

Posted: Tue May 17, 2016 9:50 pm
by Flegy33
no dosent using proxy its my dedicate server where hosting few webs using cpanel. Yes I read it few time but still not sure what I can do to solved problem. Any suggestion?

Re: automatic login problem

Posted: Tue May 17, 2016 10:17 pm
by Flegy33
maybe in error logs can see something but how to make phpbb to show errors ? others webs on hosting showing errors fine .

Re: automatic login problem

Posted: Wed May 18, 2016 9:37 pm
by Flegy33
bump still need help with my problem.

Re: automatic login problem

Posted: Wed May 18, 2016 9:57 pm
by 3Di
Flegy33 wrote:bump still need help with my problem.
Your site is setting cookies just for maxko..

run this tool so that we can see your real cookie settings and try to help you

http://3di.space/32/viewtopic.php?f=3&t=2

Re: automatic login problem

Posted: Wed May 18, 2016 10:02 pm
by Flegy33
when run script got this http://screencast.com/t/kAn4tHAdpwsm

Re: automatic login problem

Posted: Wed May 18, 2016 10:34 pm
by 3Di
Flegy33 wrote:when run script got this http://screencast.com/t/kAn4tHAdpwsm
This error seems due to a known issue with MS SQL and also mysql, anyway.

You are running phpBB 3.0.7-pl1 files on a phpBb 3.0.12 DB.. that's a mess, so to start.

Anyway, I reduced the file in order to be ran for the cookies to be seen, save it as

right_cookie.php https://gist.github.com/3D-I/c0c18059dd ... e4bf09d381


Do Not please post screenshots but the text within the code BBcode tags, thank you.

Re: automatic login problem

Posted: Wed May 18, 2016 10:39 pm
by Flegy33
long time ago I only changed db version in table to dont getting anymore warrning msg in admin panel. Scary to upgrade files because maybe destroy something.

http://screencast.com/t/PmhNY7fc

Re: automatic login problem

Posted: Wed May 18, 2016 10:40 pm
by Flegy33
also on forum linking dosent work maybe it give more clue about problem?

http://www.maxko-forum.info/viewforum.php?f=47 it need open http://titan.maxko.org

Re: automatic login problem

Posted: Wed May 18, 2016 10:51 pm
by 3Di
Flegy33 wrote:long time ago I only changed db version in table to dont getting anymore warrning msg in admin panel. Scary to upgrade files because maybe destroy something.

http://screencast.com/t/PmhNY7fc
maxko-2.png
You need to remove the DOT in front of the Cookie domain, purge the browser's cache and retry.
Flegy33 wrote:also on forum linking dosent work maybe it give more clue about problem?

http://www.maxko-forum.info/viewforum.php?f=47 it need open http://titan.maxko.org
http://titan.maxko.org uses PHPSESSID for cookies. Not the phpBB ones as far as I can see.

Re: automatic login problem

Posted: Wed May 18, 2016 10:54 pm
by Flegy33
going try for cookie domain maxko-forum.info to be. Also link what I gived you it linking to others webs but it only open blank This 2 on forum http://screencast.com/t/ovKq4P1y3qDL same when create new, looks as something missing on server.

Re: automatic login problem

Posted: Wed May 18, 2016 10:56 pm
by 3Di
Please note that here in this forum you can use attachments, no need to pinball us from a a site to another to watch things. ;)

I already tried those two links tough..
I saw they are not working, but here we are discussing another thing It seems.