Failed Update and Failed Restore

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
velitas
Registered User
Posts: 8
Joined: Mon Jun 11, 2012 5:27 pm

Failed Update and Failed Restore

Post by velitas »

Support Request Template
What version of phpBB are you using? phpBB 3.0.12
What is your board's URL? http://forum.verysrs.com
Who do you host your board with? hostgator
How did you install your board? Someone else installed my board for me
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? Yes
Do you have any extensions installed? No
What MODs do you have installed? Not sure where to see this in the files. But I believe it was Statistics, PmSearch, and Thanks. There may be others.
What styles do you currently have installed? prosilver, subsilver
What language(s) is your board currently using? de, el, en, en_us, es, fi, sv
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I was updating from 3.0.12 to 3.1.9 but when I ran the install I ran into server timeouts. According to Hostgator my shared server couldn't handle running the update. So, I attempted to restore 3.0.12. I used the database back up file I created through hostgator but had to use the backup I have stored on my computer because the Home Directory backup created through Hostgator didn't work.
Please describe your problem. The first time I restored the back up files I ran into this error: SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND t.template_id = s.template_id AND c.theme_id = s.theme_id AND i.im' at line 4 [1064]

I fixed that using the solution I found here: viewtopic.php?p=12973204&sid=fa53349ef5 ... #p12973204

After fixing other errors that showed I eventually ended up with this error that I didn't know how to fix.
Fatal error: SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 6 [1064]

Because I had edited so many things I decided to start over. I have uploaded the database backup as well as my entire directory from my computer. I am given the same initial error. When I try the same solution for that error as the first time I'm given the error I couldn't fix previously. I've tried to use the Repair Tool for 3.0 but get the error: Undefined index: user_id

Not sure what to do from this point.
Generated by SRT Generator
velitas
Registered User
Posts: 8
Joined: Mon Jun 11, 2012 5:27 pm

Re: Failed Update and Failed Restore

Post by velitas »

I actually don't need help with this any longer. Thanks anyway.
Locked

Return to “[3.0.x] Support Forum”