"this board requires account activation" by me but I never get the email message

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Bill_Thompson
Registered User
Posts: 259
Joined: Mon Jun 20, 2005 2:58 am
Location: Bellevue, WA
Contact:

"this board requires account activation" by me but I never get the email message

Post by Bill_Thompson »

When a user registers on my web forum, they get the message:

"Your account has been created. However, this board requires account activation by the administrator group. An e-mail has been sent to them and you will be informed when your account has been activated."

But I never get the email to activate the account. I have done a test on a separate email address pretending to be a user to see what happens. That email address did get an email saying that I would activate the account but said I needed to approve it. I noticed that the sender email address is the correct one. It is the one that is supposed to be from me, the admin.

There must be some sort of account setting on the ACP that I need to set to make this work. Please tell me what it is.
Attachments
problem 001.png
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Brf »

Please fill out the Support Request Template and post it back here to enable us to assist you better.
Bill_Thompson
Registered User
Posts: 259
Joined: Mon Jun 20, 2005 2:58 am
Location: Bellevue, WA
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Bill_Thompson »

Support Request Template
What version of phpBB are you using? phpBB 3.0.12
What is your board's URL? http://www.arguemax.com/_phpBB-3.0.12/index.php
Who do you host your board with? HostMonster.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? Yes
Do you have any extensions installed? Yes
What MODs do you have installed? A MOD that gets paid membership.
A mod that asks users for a security question with they register -- to prevent flood of spam.
What extensions do you have installed? I am not sure
What styles do you currently have installed? Elegance by Artolia
What language(s) is your board currently using? english
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? N/A -- - it is when one signs up for a new account
What password can be used to view this issue? N/A -- - it is when one signs up for a new account
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? It seemed to start happening when I added the security question that the user sees when he registers
Please describe your problem. When a user registers on my web forum, they get the message:

"Your account has been created. However, this board requires account activation by the administrator group. An e-mail has been sent to them and you will be informed when your account has been activated."

But I never get the email to activate the account. I have done a test on a separate email address pretending to be a user to see what happens. That email address did get an email saying that I would activate the account but said I needed to approve it. I noticed that the sender email address is the correct one. It is the one that is supposed to be from me, the admin.

There must be some sort of account setting on the ACP that I need to set to make this work. Please tell me what it is.
Generated by SRT Generator
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Brf »

The activation email should be sent to the Email address in the profiles of any of your admin users.
Bill_Thompson
Registered User
Posts: 259
Joined: Mon Jun 20, 2005 2:58 am
Location: Bellevue, WA
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Bill_Thompson »

The activation email is not sent to the admin listed in the ACP. I made sure that I am listed in the admin group.

What I am thinking of doing is just go ahead and make it so that there is no activation email sent out at all. I already have a security question set up. I think that should be good enough.

So, if I do this, I have another question. How do I remove the email addresses from the database so that users can give it another try and sign up?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Brf »

Bill_Thompson wrote:The activation email is not sent to the admin listed in the ACP.
Brf wrote:The activation email should be sent to the Email address in the profiles of any of your admin users.
It is the Email in your UCP profile.
Bill_Thompson
Registered User
Posts: 259
Joined: Mon Jun 20, 2005 2:58 am
Location: Bellevue, WA
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Bill_Thompson »

at this point, I want to have the people who tried to sign up try again. Which database holds email address or log in attempts where I can delete the entries allowing people to try again?
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: "this board requires account activation" by me but I never get the email message

Post by Brf »

The users table. If you do not want to activate those users, just delete them.
Locked

Return to “[3.0.x] Support Forum”