errors in copying the forum

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
apsorg
Registered User
Posts: 9
Joined: Wed Aug 31, 2016 12:56 am

errors in copying the forum

Post by apsorg » Thu Sep 01, 2016 2:44 am

hello,

in trying to upgrade i decided to copy my forum. i copied all the files to another folder with a different name, i copied the database. however i used the same user and password as the original database. i then edited the config.php with the new database name. the new folder/forum is located in the same root as my original forum. no hosting or server changes.

when i now try to access the new copied version of the forum i get these error messages, that i do not understand. it doesn't allow me to login. i would love some help to point me in the direction to a solution. :(

Code: Select all

Strict Standards: Non-static method utf_normalizer::nfkc() should not be called statically in /home/aps58399/public_html/mcforum/includes/utf/utf_tools.php on line 1663
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4668: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/utf/utf_tools.php:1663)

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69105
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: errors in copying the forum

Post by KevC » Thu Sep 01, 2016 7:32 am

That usually means the server is not running a compatible version of php.

Upload /install and go to

/install/phpinfo.php
and see what it says at the very top of the screen.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

apsorg
Registered User
Posts: 9
Joined: Wed Aug 31, 2016 12:56 am

Re: errors in copying the forum

Post by apsorg » Tue Sep 06, 2016 1:10 am

thank you. i originally had it at 5.3, whilst trying to upgrade i changed my server php settings to 5.4 and also tried 5.5, by reverting back to php5.3 it works again. i'll contact my hosting company and see what the issue is. :D

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10338
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: errors in copying the forum

Post by Noxwizard » Tue Sep 06, 2016 1:42 am

This indicates that your board is running something older than phpBB 3.0.11. You need to update to a newer version of phpBB to run on PHP 5.4+.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

Locked

Return to “[3.0.x] Support Forum”