Can't find debug lines in config.php

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
simon94
Registered User
Posts: 2
Joined: Fri Sep 02, 2016 2:25 am

Can't find debug lines in config.php

Post by simon94 »

phpBB Version: 3.0.5

I'm trying to activate the WP-United wordpress plugin, to integrate my phpbb and wordpress users.
On activating it, this plugin gave the following message:
WARNING: phpBB Debug is set. To prevent notices from showing due to switching between phpBB and WordPress, delete or comment out the two DEBUG lines from your phpBB's config.php. If this is a live site, debug MUST be disabled.
I have been reading many threads about these debug lines in the config.php file.
The trouble is, there are no debug lines in my config.php file, so I cannot uncomment them when they're not there.
Further, I don't know how to turn off debugging, when it doesn't show.
After the first few lines about the host, name, user and passwd, this is the only other bit that is in config.php:
$table_prefix = 'phpbb_' ;
$acm_type = 'file' ;
$load_extensions = '' ;

@define('PHPBB_INSTALLED', true);
Many thanks in advance if anyone knows what's going wrong! I'm a bit mystified...!

I am also experiencing a second issue, although I do not know if it is connected or not.
In the ACP, on doing things like adjusting user settings, I keep getting error messages, such as these:
Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php on line 673

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php on line 673

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php on line 673

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php on line 673

Warning: Cannot modify header information - headers already sent by (output started at /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php:673) in /home2/simon/public_html/access/practitioner-forum/adm/index.php on line 150

Warning: Cannot modify header information - headers already sent by (output started at /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php:673) in /home2/simon/public_html/access/practitioner-forum/adm/index.php on line 152

Warning: Cannot modify header information - headers already sent by (output started at /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php:673) in /home2/simon/public_html/access/practitioner-forum/adm/index.php on line 153

Warning: Cannot modify header information - headers already sent by (output started at /home2/simon/public_html/access/practitioner-forum/includes/functions_content.php:673) in /home2/simon/public_html/access/practitioner-forum/adm/index.php on line 154
User avatar
david63
Registered User
Posts: 18591
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Can't find debug lines in config.php

Post by david63 »

The second issue is, I believe, because you are running on PHP7. Neither phpBB 3.0 nor phpBB 3.1 support PHP7 - you will have to downgrade your version of PHP

I would also suggest that you update your version of phpBB as 3.0.5 is well out of date - the current version in the 3.0 branch is 3.0.14. I would go even further and suggest that you consider updating to the 3.1 branch as phpBB 3.0 is at EOL and support will cease for it at the end of the year.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51682
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Can't find debug lines in config.php

Post by stevemaury »

And if the debug lines are not in the file, they are already disabled - no need to comment out what is not there.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
simon94
Registered User
Posts: 2
Joined: Fri Sep 02, 2016 2:25 am

Re: Can't find debug lines in config.php

Post by simon94 »

Thank you both! I appreciate the help.

david63: I checked to make sure. I'm not using PHP7, but PHP5.4. I use a shared server on hostgator, and it lists PHP7 as unavailable, whereas PHP5.4 is the highest available PHP in my plan. Could 5.4 still be causing the second problem?

Thanks for the advice on upgrading. It's a good idea, I'll need to look into this.

stevemaury: Thanks for confirming this. It therefore seems like the plugin is giving out misinformation. I wonder if it will respond better after I have upgraded phpBB. If it does, I'll let you know here...
Locked

Return to “[3.0.x] Support Forum”