Cannot find module ./../includes/acp/acp_acp_main.php

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
apsorg
Registered User
Posts: 9
Joined: Wed Aug 31, 2016 12:56 am

Cannot find module ./../includes/acp/acp_acp_main.php

Post by apsorg » Wed Sep 07, 2016 2:17 am

hello,

i migrated the database from one hosting company to another. using files from an old backup. in trying to get my board to work i get this error when i log into the ACP.

Cannot find module ./../includes/acp/acp_acp_main.php

i can however, log into the board and read topics but i can't moderate. i get an error:
General Error
Module not accessible

i know the problem is with the modules, i just don't know how to begin to fix this. any help is greatly appreciated.

cheers. :(

User avatar
Lumpy Burgertushie
Registered User
Posts: 66324
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Cannot find module ./../includes/acp/acp_acp_main.php

Post by Lumpy Burgertushie » Wed Sep 07, 2016 3:46 am

have to have more info.
Please fill out the Support Request Template Generator and post it back here to enable us to assist you better.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

apsorg
Registered User
Posts: 9
Joined: Wed Aug 31, 2016 12:56 am

Re: Cannot find module ./../includes/acp/acp_acp_main.php

Post by apsorg » Wed Sep 07, 2016 4:40 am

hi there,


Support Request Template
What version of phpBB are you using? phpBB 3.1.0-a3
What is your board's URL? www.a-p-s.org.au/mcedforum/
Who do you host your board with? Siteground.com
How did you install your board? Someone else installed my board for me
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0.10
What styles do you currently have installed? prosilver, RedSilver, 610nm
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? i inherited this board from another server. i didn't install. i moved the database from the old host and uploaded it to new host at siteground.com. i then uploaded files from a back up. which once again wasn't mine. the database version says it was upgraded from 3.0.10 to 3.1.0-a3. however not sure if that is entirely correct and that it migrated effectively. also not sure what version files i have.
Please describe your problem. when logging into the board, as admin, i can see the posts but i cannot moderate. if i posts it needs to be approved. when i try to approve the post i get this error:
General Error
Module not accessible

also these php errors:
Parse error: syntax error, unexpected ')' in /home/aps58399/public_html/xxxmyforum/includes/functions_module.php(364) : eval()'d code on line 1

Warning: Cannot modify header information - headers already sent by (output started at /../../public_html/xxxmyforum/includes/functions_module.php(364) : eval()'d code:1) in /../../public_html/xxxmyforum/includes/functions.php on line 2715

i cannot log into the ACP. i get this error:
General Error
Cannot find module ./../includes/acp/acp_acp_main.php

i searched for that file and it does not exist. however i have a ../includes/acp/acp_main.php

when one of my moderators/users logs in, they cannot go into the topic, with this error:
General Error
SQL ERROR [ mysqli ]

Unknown column 't.topic_approved' in 'where clause' [1054]
Generated by SRT Generator

User avatar
Lumpy Burgertushie
Registered User
Posts: 66324
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Cannot find module ./../includes/acp/acp_acp_main.php

Post by Lumpy Burgertushie » Wed Sep 07, 2016 5:04 am

you seem to have different versions of the files and the database etc.

the current version is 3.1.9

then, it seems that you are trying to run 3.1 files on a 3.0 database.

what you need to do is to start over.

as long as you still have a copy of your 3.0.10 database that is all you need to get it running correctly.

I suggest you make a complete backup, files and database to your computer, then download a complete new set of files from here:
https://www.phpbb.com/files/release/phpBB-3.1.9.zip
unzip it, remove the config.php file
using your ftp, access your server and remove all of the phpbb files and folders except for the config.php file , the files folder, images folder of your current board.

then, upload all the new files/folders from the download you got from here ( remember, do NOT upload the blank config.php file.

once that is done.
go to: yourdomain.com/yourphpbb/install/database_update.php

click the continue button until you get a success message. this may take some time, be patient.

then, delete the folder named install and you are done.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

apsorg
Registered User
Posts: 9
Joined: Wed Aug 31, 2016 12:56 am

Re: Cannot find module ./../includes/acp/acp_acp_main.php

Post by apsorg » Wed Sep 07, 2016 6:03 am

hi,

thanx for the tip. i did exactly as you said and now i have this drama.
i have had advice to download the toolkit but that is just way to advanced for me. any other idea on how i should next proceed?


Updating database to latest stable release

Database type :: mysqli
Previous version :: 3.1.0-a3
Installing Data: \phpbb\db\migration\data\v310\profilefield_interests.

SQL ERROR [ mysqli ]

Unknown column 'field_show_on_pm' in 'field list' [1054]

SQL

INSERT INTO phpbb_profile_fields (field_name, field_type, field_ident, field_length, field_minlen, field_maxlen, field_novalue, field_default_value, field_validation, field_required, field_show_novalue, field_show_on_reg, field_show_on_pm, field_show_on_vt, field_show_profile, field_hide, field_no_view, field_active, field_order) VALUES ('phpbb_interests', 'profilefields.type.text', 'phpbb_interests', '3|30', '2', '500', '', '', '.*', 0, 0, 0, 0, 0, 1, 0, 0, 1, 1)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/migration/profilefield_base_migration.php
LINE: 98
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\migration\profilefield_base_migration->create_custom_field()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 550
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 496
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 322
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 262
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 202
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 185
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/install/database_update.php
LINE: 205
CALL: phpbb\db\migrator->update()

Locked

Return to “[3.0.x] Support Forum”