3.0.11 with PHP7?

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
marc60
Registered User
Posts: 28
Joined: Thu Mar 21, 2013 2:20 pm

3.0.11 with PHP7?

Post by marc60 »

Hi,

I run a few big 3.0.11 forums with many mods and own mod development. Its not possible for me to do a default migration. Everything runs so perfect at the moment, that I want to keep my 3.0.11 but make the changes for php7.

I know for PHP7 compatibility I will need phpBB 3.2 (when it is released) but is here someone who did that for 3.0.11? I think its "only" the preg_replace callback issue right?

Kind regards
Last edited by Brf on Tue Nov 08, 2016 8:23 pm, edited 1 time in total.
Reason: Removed solicitation
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51682
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: 3.0.11 with PHP7?

Post by stevemaury »

php 7 is NOT compatible with phpBB 3.0.x.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
User avatar
AmigoJack
Registered User
Posts: 5799
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: 3.0.11 with PHP7?

Post by AmigoJack »

marc60 wrote:its "only" the preg_replace callback issue right?
No.
  • The worst thing about censorship is ███████████
  • "The problem is probably not my English but you do not want to understand correctly. ... We will not come anybody anyway, nevertheless, it's best to shit this." Affin, 2018-11-20
  • "But this shit is not here for you. You can follow with your. Maybe the question, instead, was for you, who know, so you shoved us how you are." axe70, 2020-10-10
Locked

Return to “[3.0.x] Support Forum”