Page 1 of 1

cannot backup, if I could backup I would upgrade version

Posted: Sun Nov 20, 2016 1:05 am
by JerryPeck
My board is still using phpBB 3.0.2 as I keep getting a fatal error when I try to back up (been getting this error for a very long time, finally getting around to asking the question):
- Fatal error: Cannot redeclare can_load_dll() (previously declared in /data/18/1/131/85/1620574/user/1746636/htdocs/includes/functions_install.php:22) in /data/18/1/131/85/1620574/user/1746636/htdocs/includes/functions_install.php on line 558

Does anyone know what that error is and how to correct it? That will allow me to backup and then upgrade.

Another question is: can I upgrade all the to current with my same database, and if so, how?

Thank you,

Jerry

Re: cannot backup, if I could backup I would upgrade version

Posted: Sun Nov 20, 2016 2:28 am
by Lumpy Burgertushie
the best way to make a backup is to go to your hosting control panel and use phpmyadmin or whatever your host provides for managing your databases. don't use the built in backup function.

you will be better off updating 3.0.2 to 3.0.14 first and then upgrading to 3.1


robert

Re: cannot backup, if I could backup I would upgrade version

Posted: Sun Nov 20, 2016 3:18 am
by 3Di
3.0.2 -> 3.0.8 -> 3.0.14 to be sure.

https://download.phpbb.com/pub/release/3.0/

Re: cannot backup, if I could backup I would upgrade version

Posted: Wed Nov 23, 2016 10:37 pm
by JerryPeck
Thanks, I'll have to find a way to back up, then update to 3.0.8 first, then update to 3.0.14, then update to 3.1.