[HELP] Database Encoding

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
mardav
Registered User
Posts: 6
Joined: Mon Nov 21, 2016 1:24 pm

[HELP] Database Encoding

Post by mardav »

Hi. I have a forum and when i try to post something in my language (greek) i get this error.
I have install greek language pack. How can this be solved? I need your help please! Thanks.
Attachments
Error
Error
User avatar
AmigoJack
Registered User
Posts: 5799
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: [HELP] Database Encoding

Post by AmigoJack »

The collation of that database table is wrong - it should be utf8_bin. Compare it with /install/schemas/mysql_41_schema.sql:

Code: Select all

CREATE TABLE phpbb_posts (
...
	post_text mediumtext NOT NULL,
...
) CHARACTER SET `utf8` COLLATE `utf8_bin`;
  • The worst thing about censorship is ███████████
  • "The problem is probably not my English but you do not want to understand correctly. ... We will not come anybody anyway, nevertheless, it's best to shit this." Affin, 2018-11-20
  • "But this shit is not here for you. You can follow with your. Maybe the question, instead, was for you, who know, so you shoved us how you are." axe70, 2020-10-10
mardav
Registered User
Posts: 6
Joined: Mon Nov 21, 2016 1:24 pm

Re: [HELP] Database Encoding

Post by mardav »

Thanks for the reply AmigoJack!
I searched for the install/schemas/ path but i could not found anything. Is it on the root dir?
Althought, i went to phpmyAdmin and changed the collation on the phpbb_posts table to utf8_bin. Now the posts print "??????????" instead of a word.
User avatar
AmigoJack
Registered User
Posts: 5799
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: [HELP] Database Encoding

Post by AmigoJack »

mardav wrote:I searched for the install/schemas/ path but i could not found anything. Is it on the root dir?
Yes, that's why I wrote it with a leading slash. Download the installation package of whichever version you're using and it should be in there.
mardav wrote:Now the posts print "??????????" instead of a word
That's another problem. Was the problem "i get this error" solved?

Also: please provide us with the information necessary to assist you by filling out the Support Request Template.
  • The worst thing about censorship is ███████████
  • "The problem is probably not my English but you do not want to understand correctly. ... We will not come anybody anyway, nevertheless, it's best to shit this." Affin, 2018-11-20
  • "But this shit is not here for you. You can follow with your. Maybe the question, instead, was for you, who know, so you shoved us how you are." axe70, 2020-10-10
mardav
Registered User
Posts: 6
Joined: Mon Nov 21, 2016 1:24 pm

Re: [HELP] Database Encoding

Post by mardav »

That's another problem. Was the problem "i get this error" solved?
Yes! it solved the problem.
Now my problem is that every greek character is replaced with a "?" when posting.
User avatar
AmigoJack
Registered User
Posts: 5799
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: [HELP] Database Encoding

Post by AmigoJack »

AmigoJack wrote:please provide us with the information necessary to assist you by filling out the Support Request Template.
I didn't wrote this for fun: at first I must be able to reconstruct your issue, which requires login credentials.
  • The worst thing about censorship is ███████████
  • "The problem is probably not my English but you do not want to understand correctly. ... We will not come anybody anyway, nevertheless, it's best to shit this." Affin, 2018-11-20
  • "But this shit is not here for you. You can follow with your. Maybe the question, instead, was for you, who know, so you shoved us how you are." axe70, 2020-10-10
mardav
Registered User
Posts: 6
Joined: Mon Nov 21, 2016 1:24 pm

Re: [HELP] Database Encoding

Post by mardav »

Support Request Template
What version of phpBB are you using? phpBB 3.0.9
Who do you host your board with? 5Jelly
How did you install your board? I used a tool provided by my host
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? prosilver
What language(s) is your board currently using? English (UK)
Which database type/version are you using? MySQLi
What is your level of experience? New to PHP but not phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Changed the encoding collation to utf8_bin on my database from phpmyAdmin
Please describe your problem. Whenever a user registers or someone tries to post something in greek, every character is being replaced with "?".
Generated by SRT Generator

Login credentials: username: testuser password: 12345
Last edited by mardav on Thu Nov 24, 2016 9:17 pm, edited 1 time in total.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52169
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: [HELP] Database Encoding

Post by Brf »

What is this?

Code: Select all

// www.phpBB-SEO.com SEO TOOLKIT BEGIN
There is no support here for php-seo.
You should start by using the files found here, not those found in your host's installer or phpbb-seo.com
mardav
Registered User
Posts: 6
Joined: Mon Nov 21, 2016 1:24 pm

Re: [HELP] Database Encoding

Post by mardav »

Ahhh... okay... i see. I Auto-installed the forum, from my host. So i have to do it all from the start again?? :o :o :o :cry:
mardav
Registered User
Posts: 6
Joined: Mon Nov 21, 2016 1:24 pm

Re: [HELP] Database Encoding

Post by mardav »

Okay... I installed YOUR files and everything seems to be working... Thanks :)
Locked

Return to “[3.0.x] Support Forum”