error "you are not logged as ....."

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 1:31 am

http://www.spamodeler.com/forum
using phpbb 3.0.x - can't get to ACP to get version.

I am an admin on this site. The other day, dotEasy asked us to remove a number of potential spammer accounts. I used the phpMyAdmin tool to do so and inadvertently deleted the Anonymous account. I know.

After much searching on this site and others, while finding nothing current, I tried some things that didn't work. Came across the need for the Anonymous account, re-created it and all was well for about two hours.

It then went back to not showing any topics/boards, etc. and displaying the "you are not logged...." error any time I and others try to log out. I can do nothing. I can't get to the ACP.

I did probably whack the sessions_keys table some how, but plan on recreating that in a bit.

I am out of guesses and am desperate to get our forum back online. Need some help, please.

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: error "you are not logged as ....."

Post by Lumpy Burgertushie » Fri Dec 23, 2016 3:21 am

you are apparently running 3.0.12
your cookie domain is wrong, it should be .spamodeler.com ( notice the dot in front )

you should not be removing things from the database unless you are certain about what you are doing. even removing the correct users will break things unless you remove all the different parts that relate to each user. most of the database tables are all interconnected and each user has data in several different tables.
there are methods built into the software to remove spammer accounts etc. from the admin panel.

if you removed or messed up the sessions table that could be the problem. the data in that table is not necessary but the table is.
If you need to redo the sessions tables;
using phpmyadmin, copy and paste this into the sql box for your database. be sure to change the table prefix if yours is not phpbb_

Code: Select all

# Table: 'phpbb_sessions'
DROP TABLE IF EXISTS `phpbb_sessions`;
CREATE TABLE phpbb_sessions (
	session_id char(32) DEFAULT '' NOT NULL,
	session_user_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL,
	session_forum_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL,
	session_last_visit int(11) UNSIGNED DEFAULT '0' NOT NULL,
	session_start int(11) UNSIGNED DEFAULT '0' NOT NULL,
	session_time int(11) UNSIGNED DEFAULT '0' NOT NULL,
	session_ip varchar(40) DEFAULT '' NOT NULL,
	session_browser varchar(150) DEFAULT '' NOT NULL,
	session_forwarded_for varchar(255) DEFAULT '' NOT NULL,
	session_page varchar(255) DEFAULT '' NOT NULL,
	session_viewonline tinyint(1) UNSIGNED DEFAULT '1' NOT NULL,
	session_autologin tinyint(1) UNSIGNED DEFAULT '0' NOT NULL,
	session_admin tinyint(1) UNSIGNED DEFAULT '0' NOT NULL,
	PRIMARY KEY (session_id),
	KEY session_time (session_time),
	KEY session_user_id (session_user_id),
	KEY session_fid (session_forum_id)
) CHARACTER SET `utf8` COLLATE `utf8_bin`;


# Table: 'phpbb_sessions_keys'
DROP TABLE IF EXISTS `phpbb_sessions_keys`;
CREATE TABLE phpbb_sessions_keys (
	key_id char(32) DEFAULT '' NOT NULL,
	user_id mediumint(8) UNSIGNED DEFAULT '0' NOT NULL,
	last_ip varchar(40) DEFAULT '' NOT NULL,
	last_login int(11) UNSIGNED DEFAULT '0' NOT NULL,
	PRIMARY KEY (key_id, user_id),
	KEY last_login (last_login)
) CHARACTER SET `utf8` COLLATE `utf8_bin`;
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 1:49 pm

I made the changes at the request of the hosting entity. I fell into the trap of "they should know, right?". . .

How does one update the cookie domain?

I know one should not go mucking around in the db. I spent over 35 yeas in the IT world. However, it was already broken, dotEasy threw up their hands and our site was/is down. Had nothing much to loose.

User avatar
JimA
Community Team Member
Community Team Member
Posts: 6802
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: error "you are not logged as ....."

Post by JimA » Fri Dec 23, 2016 1:56 pm

lylew wrote:How does one update the cookie domain?
Fixing incorrect cookie settings :)
Image Jim Mossing Holsteyn - Community Team Member
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 2:21 pm

Jim, I saw that. I'm still new enough at this side of programming that it gives me the willies. I created the file in Notepad, uploaded it using phpMyAdmin File Manager Upload and then renamed it to get the .txt extension removed. When I try to go to the link in a browser, I get errors.

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 2:33 pm

Id10t error on above. I have a good php file, but there are errors showing in the code from the KB at line 40. Looks ok to me.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 19973
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: error "you are not logged as ....."

Post by RMcGirr83 » Fri Dec 23, 2016 2:55 pm

lylew wrote:I created the file in Notepad..
You shouldn't use windows notepad to create PHP files but rather a strict text editor like Notepad++.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 4:43 pm

downloaded notepad++...same issues. there were some odd hidden characters in the leading spaces of the lines that had them. I removed those the got it to work. Changed the cookie domain to .spamodeler.com

and is still won't work. what else?

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10211
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: error "you are not logged as ....."

Post by Noxwizard » Fri Dec 23, 2016 4:48 pm

You have secure cookies enabled, which is only meant for sites operating completely under HTTPS. You need to disable that.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 4:55 pm

Okay. did that. Still doesn't work.

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10211
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: error "you are not logged as ....."

Post by Noxwizard » Fri Dec 23, 2016 5:16 pm

Your cookies are working, but logged out users are showing as partially logged in.
lylew wrote:Came across the need for the Anonymous account, re-created it and all was well for about two hours.
How did you re-create the account?
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 5:19 pm

Noxwizard wrote:Your cookies are working, but logged out users are showing as partially logged in.
lylew wrote:Came across the need for the Anonymous account, re-created it and all was well for about two hours.
How did you re-create the account?
The first attempt was simply copying mine and renaming it. The I pretty quickly thought better of it and found a code script on this site to re-create it.

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 8:39 pm

...and how do you deal with partially logged in users?

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: error "you are not logged as ....."

Post by Lumpy Burgertushie » Fri Dec 23, 2016 9:17 pm

what is a "partially logged in user"?

that is not possible, you are either logged in or you are not.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

lylew
Registered User
Posts: 14
Joined: Fri Dec 23, 2016 1:24 am

Re: error "you are not logged as ....."

Post by lylew » Fri Dec 23, 2016 9:25 pm

Lumpy Burgertushie wrote:what is a "partially logged in user"?

that is not possible, you are either logged in or you are not.

robert
I don't know. That is what is suggested a couple of posts above.

Locked

Return to “[3.0.x] Support Forum”

Who is online

Users browsing this forum: Bing [Bot], BrokenCrust, Sogou [Spider] and 86 guests

cron