Restore or fix broken forum

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Get Involved
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
vjmtz
Registered User
Posts: 7
Joined: Thu Dec 22, 2016 9:37 pm
Contact:

Restore or fix broken forum

Post by vjmtz » Thu Dec 29, 2016 4:35 pm

I tried to install Inactive Users mod on 3.0.12, it didn't worked, so I uninstalled it and now I can't view profiles.

When I click to view user profile I get this error:

Code: Select all

Parse error: syntax error, unexpected '}' in /home1/vjvisart/public_html/cache/tpl_leisure-ocean_memberlist_view.html.php on line 52
What to do now?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 67238
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Restore or fix broken forum

Post by KevC » Thu Dec 29, 2016 4:59 pm

Support for that MOD is on the page where you downloaded it.

Just a reminder that support itself for 3.0 will end in 2 days.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

vjmtz
Registered User
Posts: 7
Joined: Thu Dec 22, 2016 9:37 pm
Contact:

Re: Restore or fix broken forum

Post by vjmtz » Thu Dec 29, 2016 5:13 pm

Support for that MOD is inactive.

Is there any way to restore forum to previous state? Or if that's not possible, how can I install fresh phpbb 3.0.12 without losing database (users, posts, topics)?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 67238
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Restore or fix broken forum

Post by KevC » Thu Dec 29, 2016 5:36 pm

Not really wise to install MODs from an author that hasn't visited for a long time.

Have you tried clearing the cache?
Open the board’s /cache folder on the server and delete everything except index.htm and .htaccess.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

vjmtz
Registered User
Posts: 7
Joined: Thu Dec 22, 2016 9:37 pm
Contact:

Re: Restore or fix broken forum

Post by vjmtz » Thu Dec 29, 2016 5:43 pm

I tried, and when I click to view a profile I get an error:

Code: Select all

Parse error: syntax error, unexpected '}' in /home1/vjvisart/public_html/includes/template.php(230) : eval()'d code on line 52
And when I refresh, it gets back to the previous error.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 67238
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Restore or fix broken forum

Post by KevC » Thu Dec 29, 2016 5:45 pm

Upload new unedited copies of the files that were changed in the MOD and clear the cache again.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20372
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Restore or fix broken forum

Post by RMcGirr83 » Thu Dec 29, 2016 5:47 pm

You have an edit error in the html file stated.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

vjmtz
Registered User
Posts: 7
Joined: Thu Dec 22, 2016 9:37 pm
Contact:

Re: Restore or fix broken forum

Post by vjmtz » Thu Dec 29, 2016 6:00 pm

KevC wrote:Upload new unedited copies of the files that were changed in the MOD and clear the cache again.
I tried this, and it's still the same.

User avatar
canonknipser
Registered User
Posts: 1139
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Restore or fix broken forum

Post by canonknipser » Thu Dec 29, 2016 6:04 pm

Look at your error message, its in file /includes/template.php - upload a fresh copy from original 3.0.12 zip file, just in case: backup your current file first
Greetings
Frank
phpbb.de support team member
English is not my native language
New arrival - Extensions and scripts for phpBB
no support via PM or mail

User avatar
Brf
Support Team Member
Support Team Member
Posts: 50714
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Restore or fix broken forum

Post by Brf » Thu Dec 29, 2016 6:07 pm

canonknipser wrote:Look at your error message, its in file /includes/template.php
No. The error is in the template being parsed.

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Restore or fix broken forum

Post by Lumpy Burgertushie » Thu Dec 29, 2016 6:08 pm

actually it is not in the template.php file but in the memberlist_view.html file on line 52

you made a mistake when editing the files. fix that mistake and it will probably work.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

vjmtz
Registered User
Posts: 7
Joined: Thu Dec 22, 2016 9:37 pm
Contact:

Re: Restore or fix broken forum

Post by vjmtz » Thu Dec 29, 2016 6:20 pm

I tried to upload fresh copies of both files, and I emptied the cache folder, and it worked. Now it's OK.

Thanks all.

Locked

Return to “[3.0.x] Support Forum”

Who is online

Users browsing this forum: Yandex [Bot] and 64 guests