Sub forums?

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Nothing Sound
Registered User
Posts: 218
Joined: Sun Nov 14, 2004 1:13 pm
Contact:

Post by Nothing Sound » Wed Jul 12, 2006 2:49 pm

matthewf wrote: bangs head against wall for NOT testing sub forums, I was only testing first and second level forums not third level as soon as I did, the option was there, there is no problem here nothing to see, move along now :D


Ok, now I'm confused.
I have all the permissions set so that everyone can view.
I have a Forum and want to create a sub forum with a link on the index page under the main forum.
I create the Parent forum and then a sub forum under that. There is still No option for a link on the index page.

What am I not understanding here?

kmax
Registered User
Posts: 7
Joined: Mon Mar 29, 2004 10:13 pm
Location: Belgrade, MT
Contact:

Post by kmax » Wed Jul 12, 2006 2:57 pm

The behavior that Nothing Sound and mathewf describe is exactly what I am seeing as well.

As to matthewf's last comment, I don't think that is accurate to say it is okay not to have that option for second level. If you set the parent to a category, then go in and set the second level ones to display on the index, then set the parent back to a forum the index shows the parent, with links below it for the subforums. However if you don't go through this process (i.e. the subs are not set to display on the index because you don't have that option) then those links are not present and there is no way to get them there.

kmax
Registered User
Posts: 7
Joined: Mon Mar 29, 2004 10:13 pm
Location: Belgrade, MT
Contact:

Post by kmax » Wed Jul 12, 2006 3:02 pm

Nothing Sound wrote:
matthewf wrote:bangs head against wall for NOT testing sub forums, I was only testing first and second level forums not third level as soon as I did, the option was there, there is no problem here nothing to see, move along now :D


Ok, now I'm confused.
I have all the permissions set so that everyone can view.
I have a Forum and want to create a sub forum with a link on the index page under the main forum.
I create the Parent forum and then a sub forum under that. There is still No option for a link on the index page.

What am I not understanding here?

Exactly what I was saying, you just type faster! This is why I think this option should be available for all subs, regardless of level or parent type.

For now you can get to the point of having the link to the sub on the index page by:
1. Create/Change parent as category.
2. Create/Change subs with setting to display on index.
3. Change parent back to Forum.
4. Reset parent forum permissions.

Now going to the index should show the parent forum as normal, and under the parent description should be a "Subforums: <links>" line.

Nothing Sound
Registered User
Posts: 218
Joined: Sun Nov 14, 2004 1:13 pm
Contact:

Post by Nothing Sound » Wed Jul 12, 2006 3:16 pm

I got it now.
You have to place the main forum in to a category forum. That way the sub forum becomes a 'third level'
and you then have the index link option. I see how it works now, but don't really like it.
This whole thing is a little confusing until you get used to it I guess.

I agree that all sub forums should have the option regardless of the parent forum/category

matthewf
Registered User
Posts: 735
Joined: Sat Mar 12, 2005 12:39 pm

Post by matthewf » Wed Jul 12, 2006 4:33 pm

when I tested this I only tested standard forums and categories

forum 1 /forum 2
but as soon as I placed another forum in forum 2 (third level) and a sub forum it works, hence my last comment, but yeah this should really work rehardless of level

User avatar
Lastof
Registered User
Posts: 743
Joined: Fri Feb 13, 2004 7:29 pm
Location: UK
Contact:

Post by Lastof » Wed Jul 12, 2006 4:44 pm

It sounds like a problem with the fact that a catogory is just another type of forum. So, if it is first an option on the third level, it is first available in the level containing the first subforums if the first level is a catogory. However, the problem occurs when you don't use a catagory.

Sounds like a programmer oversite to me. Someone who's looked at it in detail should make a bug report.
Last edited by Lastof on 04 May 2011, 00:00, edited -1 times in total
----------------------------------------------------------------------------------------------------------------------------------------
Image
Look, I'm officially not a bug!!

Nothing Sound
Registered User
Posts: 218
Joined: Sun Nov 14, 2004 1:13 pm
Contact:

Post by Nothing Sound » Wed Jul 12, 2006 4:52 pm

Lastof wrote: It sounds like a problem with the fact that a catogory is just another type of forum. So, if it is first an option on the third level, it is first available in the level containing the first subforums if the first level is a catogory. However, the problem occurs when you don't use a catagory.

Sounds like a programmer oversite to me. Someone who's looked at it in detail should make a bug report.


Correct.

In V2 you Have to assign a new forum to a category.
In V3 you can have a forum just floating around by itself, not in any category.
If you do that then the index option isn't available until the 2nd sub forum of a forum.

This shit could drive ya nuts

matthewf
Registered User
Posts: 735
Joined: Sat Mar 12, 2005 12:39 pm

Post by matthewf » Wed Jul 12, 2006 6:28 pm

should this be submitted to the bug tracker and is this a bug, what I mean is should this be reharded as a bug?

after a bit more playing around with is, forums that have no parent seem to attach themselves to the last created category even though it isn't link to it, I certainly think this needs looking into and changing
Last edited by matthewf on Wed Jul 12, 2006 6:41 pm, edited 1 time in total.

Nothing Sound
Registered User
Posts: 218
Joined: Sun Nov 14, 2004 1:13 pm
Contact:

Post by Nothing Sound » Wed Jul 12, 2006 6:31 pm

matthewf wrote: should this be submitted to the bug tracker and is this a bug, what I mean is should this be reharded as a bug?


I'm not really sure. That might be the way they wanted it to be.
For what reason, I have no idea. I was a MOD or developer would see this and respond.

matthewf
Registered User
Posts: 735
Joined: Sat Mar 12, 2005 12:39 pm

Post by matthewf » Wed Jul 12, 2006 6:43 pm

I re edited my previous post, I don't understand why you can create a forum that has no parent, its still links to a category regardless, when you go back into the forum index

Nothing Sound
Registered User
Posts: 218
Joined: Sun Nov 14, 2004 1:13 pm
Contact:

Post by Nothing Sound » Wed Jul 12, 2006 6:58 pm

matthewf wrote: I re edited my previous post, I don't understand why you can create a forum that has no parent, its still links to a category regardless, when you go back into the forum index


It looks as if it's linked to that category, but it's not really.
It's just sitting there all by itself.

You can tell when you go in to manage forums.
The Forums that are associated with a category are actually sub forums of that category.
Click on the category and all of the Forums (sub forums) will appear.
That's why the category has a little folder. The forum that's not associated with a category
doesn't have a little folder unless there is a sub forum under it.

matthewf
Registered User
Posts: 735
Joined: Sat Mar 12, 2005 12:39 pm

Post by matthewf » Wed Jul 12, 2006 7:15 pm

did a small test, the forum that had no parent I gave standard access to it for guests, everything else no access, as guest it is on its own, but it does has forum at the top, I think if this was to work these types for forums should look seperate on the index page rather then appearing to link to the last category created, so it should have forum at the top of it, otherwise it might get confusing. especaily if you have a lot of them

User avatar
manuxtreme
Registered User
Posts: 48
Joined: Tue Aug 23, 2005 11:54 am

Post by manuxtreme » Sat Aug 19, 2006 3:16 am

It a nice feature but would have been better if it had a new post icon if its listen on index like the one with CH.

aquarelle
Registered User
Posts: 306
Joined: Mon Feb 20, 2006 6:32 pm

Post by aquarelle » Sat Aug 19, 2006 4:01 am

I have also experienced all of what you are saying here with the categories. It's way too confusing.

On a related, (hopefully), note:
Has anyone figured out how to have one of those links forums that uses the icon_folder_link.gif graphic? They have one at area51.

User avatar
cyberken
Registered User
Posts: 185
Joined: Wed Jul 27, 2005 11:51 am
Location: Edinburgh

Post by cyberken » Sat Aug 19, 2006 9:09 am

aquarelle wrote: On a related, (hopefully), note:
Has anyone figured out how to have one of those links forums that uses the icon_folder_link.gif graphic? They have one at area51.


Are you talking of the folder icon with the globe in it? if so its easy to set up.

Go to ACP ----->Manage Forums
Enter in a name that you like to call it - in my example I called it Test Link To Phpbb, click on Create New Forum.

At the next page on the first option "Forum Type" select "Link"
At the bottom of the acreen enter in the full URL that you wish to be the redirect - making sure you have set the permissions properly.

Click on "Submit" and it should be shown on your forum index:

Image

Locked

Return to “[3.0.x] Support Forum”