attachment

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
manan_kakkar
Registered User
Posts: 131
Joined: Sun Jan 08, 2006 2:40 pm

attachment

Post by manan_kakkar » Sat Jul 15, 2006 8:07 pm

i tried to attach *.eml files (email files of outlook express) and had set the doenload option as physical yet when i click the attachment it opens it in a new browser window and dispals the entire mail in html ..... i want this mail tob downloaded to the person's pc and he can view the mail in outlook ..... any suggestions

User avatar
Drexion
Former Team Member
Posts: 8892
Joined: Sat Jan 25, 2003 9:54 pm
Location: City 17

Post by Drexion » Sun Jul 16, 2006 12:57 am

You cannot control other people's PCs remotely in that manner. Most likely your pc is configured somewhere to auto-open that filetype and you dont even realise it.
Other people may have it set to download to a specific folder, its up to the setting of their browser (or otherwise).

Which browser do you use ? It may be set to Auto-Open a specific filetype instead of download to a certain location on the HD.
For example in Firefox its tools -> options -> downloads -> view and edit actions.

manan_kakkar
Registered User
Posts: 131
Joined: Sun Jan 08, 2006 2:40 pm

Post by manan_kakkar » Sun Jul 16, 2006 5:14 am

the thing is i am myself configuring the forum and i was testing it and i chked it in IE and firefox both do the same ..... and if i attach something else such as zip archives it is all well ..... but for some reason eml files are acting up ..... i also tried this in phpbb 2.0.19 and i get the same result ..... please help

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Post by karlsemple » Sun Jul 16, 2006 5:32 am

manan_kakkar wrote: the thing is i am myself configuring the forum and i was testing it and i chked it in IE and firefox both do the same ..... and if i attach something else such as zip archives it is all well ..... but for some reason eml files are acting up ..... i also tried this in phpbb 2.0.19 and i get the same result ..... please help



it is not likely a forum setting that controls this. This will be down to how your computer hadles the file type, its the same as downloading a text file, on my computer it never saves but instead opens in word. I could be wrong but i think you need to configure the browser not to open the file type in question but rather download them.
Image

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Post by karlsemple » Sun Jul 16, 2006 5:35 am

in firefox for example in the download options you have

Image
Image

manan_kakkar
Registered User
Posts: 131
Joined: Sun Jan 08, 2006 2:40 pm

Post by manan_kakkar » Sun Jul 16, 2006 6:06 am

guys thanx but the thing for whom i am setting this up use IE so configuring the browser is not possible for each user ...... even if i will do it tell me how can i do it for IE i am aware about Firefox ..... need for IE

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Post by karlsemple » Sun Jul 16, 2006 6:09 am

manan_kakkar wrote: guys thanx but the thing for whom i am setting this up use IE so configuring the browser is not possible for each user ...... even if i will do it tell me how can i do it for IE i am aware about Firefox ..... need for IE



your missing the point, this is not a phpbb isssue, it depends one the users browser settings, in other words each user will have to set their browser to dwnload it without opening it.
Image

manan_kakkar
Registered User
Posts: 131
Joined: Sun Jan 08, 2006 2:40 pm

Post by manan_kakkar » Sun Jul 16, 2006 7:15 am

ok accepted what u r saying in that case if i create a file type in opera and set it to open download box for eml extension why does the attachment still open in the browser window :?:

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Post by ToonArmy » Sun Jul 16, 2006 5:02 pm

I have played around with this, its boils down to mime types and how different browsers handle them. phpBB sends the general application/octet-stream mime type with every download that is not an image, this is because guessing the correct mime type with PHP is unreliable and the wrong one can lead to complications on the client side. Firefox on my Windows XP installation (zero extensions) and pretty much no config changes asks me when I download an eml from phpBB if I want to open with Outlook Express or save it. IE insists on opening the email itself and making a mash of it, I have no idea why this is and cannot appear to prevent it in the options.

As said before this boils down to a browser issue, a simple File -> Save As when IE opens the file itself will sort you out.
Chris SmithGitHub

manan_kakkar
Registered User
Posts: 131
Joined: Sun Jan 08, 2006 2:40 pm

Post by manan_kakkar » Sun Jul 16, 2006 5:49 pm

yeah that is what i am using right now, a forum rule that says to right click and download the file, but i request phpbb coders to find a way to overcome this as the mime thing you said and the way phpbb handles it is what is at the core of the issue

Locked

Return to “[3.0.x] Support Forum”