Extreme Load Times

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
saberj
Registered User
Posts: 55
Joined: Sun May 28, 2006 1:11 am

Extreme Load Times

Post by saberj »

I run two forums, both using phpbb. The first one is located at Http://www.minbarifederation.com. It has been running phpbb3b5 for more than a month, as I needed some of the features present for the style of board I needed. My second board was at Http://www.geekshow.us/msgbd up until RC1, it's been using phpbb2. However, after RC1 came out, I began using phpbb3 as well.

Now, the problem is this. Both boards are running /extremely/ slow. And for no apparent reason. I've checked with the host. The load levels are fine, according to them. When I was running phpbb2, the speeds were just fine for the phpbb2 forum, but phpbb3 has been running slow for a while. Also, I run MovableType at http://www.geekshow.us ...it loads just fine as well.

I don't expect that anyone will know a fix for this, but I have to ask anyway. Dreamhost is a rather popular host, and I hope that someone else that hosts there will speak up and let me know if there has been some odd change that may cause this issue. However, if anyone knows of any problems that may cause this, that would be great. Take a look around, and see if you can notice any problems.

I have had this issue reported to me dozens of times, so I know it's not just my connection. I don't see a lot of use on these forums(3 or 4 people at a time), so I don't believe that the program is being overloaded or anything similar.

Questions about setup or anything? Any help would be much appreciated.


Edit: Couldn't leave the system up any longer, so it's been moved to Http://www.geekshow.us/newmsgbd while phpbb2 is back in place at http://www.geekshow.us/msgbd

Notice the difference in the speeds between the two versions.
Last edited by saberj on Wed May 23, 2007 11:05 pm, edited 1 time in total.
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

WELL . IS THIS BOARD PHPBB.COM SEEMS SLOW WITH YOU ALSO ?
Hello All
saberj
Registered User
Posts: 55
Joined: Sun May 28, 2006 1:11 am

Re: Extreme Load Times

Post by saberj »

No.
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

so it s a host issue :)
Hello All
saberj
Registered User
Posts: 55
Joined: Sun May 28, 2006 1:11 am

Re: Extreme Load Times

Post by saberj »

Quite possibly. But in what way is the question. It's not a bandwidth issue, as the other pages load just fine. It's not an easily detectable load issue, as I had them check that.
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

yeah , so it s not a detectable load issue , maybe your host used old virsion of DB my sql :!:
Hello All
saberj
Registered User
Posts: 55
Joined: Sun May 28, 2006 1:11 am

Re: Extreme Load Times

Post by saberj »

From the Admin panel, if this helps:

Code: Select all

System 	Linux fundip 2.6.18.1-grsec+e+f6b+gr219+opt+c4a+gr2b-grsec #1 SMP Thu Oct 19 12:50:29 PDT 2006 i686
Build Date 	Nov 7 2006 13:12:41
Configure Command 	'./configure' '--with-mysql=/usr' '--enable-calendar' '--enable-force-cgi-redirect' '--with-config-file-path=/etc/php/cgi' '--enable-trans-sid' '--with-gd' '--with-ttf=/usr' '--with-freetype-dir=/usr' '--enable-exif' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-zlib-dir=/usr' '--enable-ftp' '--with-curl=/usr' '--with-mcrypt=/usr' '--with-pspell=/usr' '--enable-xslt' '--with-dom-xslt=/usr' '--with-dom=/usr' '--with-xslt-sablot=/usr' '--with-openssl=/usr' '--enable-mbstring=all' '--with-gettext'
Server API 	CGI
Virtual Directory Support 	disabled
Configuration File (php.ini) Path 	/etc/php/cgi/php.ini
PHP API 	20020918
PHP Extension 	20020429
Zend Extension 	20050606
Debug Build 	no
Zend Memory Manager 	enabled
Thread Safety 	disabled
Registered PHP Streams 	php, http, ftp, https, ftps, compress.zlib



mysql
MySQL Support	enabled
Active Persistent Links 	0
Active Links 	1
Client API version 	5.0.16
MYSQL_MODULE_TYPE 	external
MYSQL_SOCKET 	/var/run/mysqld/mysqld.sock
MYSQL_INCLUDE 	-I/usr/include/mysql
MYSQL_LIBS 	-L/usr/lib -lmysqlclient

Directive	Local Value	Master Value
mysql.allow_persistent	On	On
mysql.connect_timeout	60	60
mysql.default_host	no value	no value
mysql.default_password	no value	no value
mysql.default_port	no value	no value
mysql.default_socket	no value	no value
mysql.default_user	no value	no value
mysql.max_links	Unlimited	Unlimited
mysql.max_persistent	Unlimited	Unlimited
mysql.trace_mode	Off	Off
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

i,m sure it is a server issue , well , can you link another html page in your site ?
Hello All
saberj
Registered User
Posts: 55
Joined: Sun May 28, 2006 1:11 am

Re: Extreme Load Times

Post by saberj »

I already did. Http://www.geekshow.us is the main site. Http://www.geekshow.us/msgbd is the forum. Everything besides PHPBB3 works fine for everyone. PHPBB3 has 10+ second load times on each page.
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

you better ask your host for this as it ,s sure not a phpbb3 issue
Hello All
User avatar
Kieran007
Registered User
Posts: 273
Joined: Sun Aug 29, 2004 9:28 am
Location: London, UK
Name: Kieran O'Shea
Contact:

Re: Extreme Load Times

Post by Kieran007 »

Have you tried installing a brand new, vanilla phpBB3 RC1 in a subdirectory and seeing how it performs? It strikes me that you've only tried it with conversions so far, at least that we can see anyway. Also, what are the full specs of your server (php version, mysql version, apache version)? Unless I missed something I could only see the version of MySQL from the info you posted.
Kieran
[ RouterTech - Tech Support for all things networking ]
Useful phpBB links: Use the Forum Search!
No support via PM, please ask your questions in the forum!
RooMeat
Registered User
Posts: 204
Joined: Sat Jun 24, 2006 10:39 pm
Contact:

Re: Extreme Load Times

Post by RooMeat »

Server Issues.. Thats a excuse for people that want to tiptoe around the real problem.
I lease my own server (brand new in fact.. and just recently moved all my sites to this server).
Server is fresh, new install of everything, paid good money and had it secured and optimized.
Several sites that I run (all motorcycle related)
http://www.ozsportsbikes.com <-- runs postnuke and pnphpbb. Runs well.. no slow load times.
http://www.ozstuntbikes.com <-- as above.. no issues.
http://www.ozcruisers.com <-- runs phpbb2 with about 20 odd mods. No problems, no slow load times

http://www.ozchopper.com <--- just loaded a fresh copy of phpbb3. No members, no posts except mine.. and it loads like a dog.
Live site: http://www.ozsportsbikes.com (Converted from Nuked phpbb2 to stand alone phpBB3)
Test site: http://www.ozsuperbikes.com
Local Test site with XAMPP
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

RooMeat wrote:Server Issues.. Thats a excuse for people that want to tiptoe around the real problem.
I lease my own server (brand new in fact.. and just recently moved all my sites to this server).
Server is fresh, new install of everything, paid good money and had it secured and optimized.
Several sites that I run (all motorcycle related)
http://www.ozsportsbikes.com <-- runs postnuke and pnphpbb. Runs well.. no slow load times.
http://www.ozstuntbikes.com <-- as above.. no issues.
http://www.ozcruisers.com <-- runs phpbb2 with about 20 odd mods. No problems, no slow load times

http://www.ozchopper.com <--- just loaded a fresh copy of phpbb3. No members, no posts except mine.. and it loads like a dog.

well . is this board phpbb.com loading like a dog also with you :?: it s phpbb3 i think . :D
Hello All
RooMeat
Registered User
Posts: 204
Joined: Sat Jun 24, 2006 10:39 pm
Contact:

Re: Extreme Load Times

Post by RooMeat »

And is this not the site that belongs to the developers of phpbb3?
Dont you think that they would have optimised and tweaked it for best performance on their own site??
I doubt they would want it to run "like a dog" as that just wouldnt look good would it?? :roll:
Live site: http://www.ozsportsbikes.com (Converted from Nuked phpbb2 to stand alone phpBB3)
Test site: http://www.ozsuperbikes.com
Local Test site with XAMPP
User avatar
kber
Registered User
Posts: 986
Joined: Sun May 07, 2006 9:22 am
Location: Egypt
Contact:

Re: Extreme Load Times

Post by kber »

well. try to test my phpbb3 board in my sign ( i,m not in developers of phpbb3 team :) )
Hello All
Locked

Return to “[3.0.x] Support Forum”