Cannot run conversion scripts

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Suggested Hosts
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Cannot run conversion scripts

Post by ab9db »

I can install the board okay but after clicking conversion I only get the option to download a index.php file,

My server load is low by the way, already checked that.

Anyone experienced this or know what to do?

Thanks, Darren

Converting from 2.0.20 to RC1
Last edited by ab9db on Sun Jun 10, 2007 9:56 pm, edited 4 times in total.

Nathanmxx
Registered User
Posts: 2
Joined: Tue Sep 05, 2006 11:45 am
Contact:

Re: Cannot run conversion scripts

Post by Nathanmxx »

Yeah this same thing happens to me - basically the first part of the conversion works but then it just prompts me to download a blank index.php file. I got my categories to convert but no users or posts. :(

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Post by ab9db »

please delete this post mods
Last edited by ab9db on Sun Jun 10, 2007 10:28 pm, edited 2 times in total.

User avatar
lurttinen
Translator
Posts: 4670
Joined: Tue Sep 21, 2004 12:05 pm

Re: Cannot run conversion scripts - [Support?]

Post by lurttinen »

What browser did you use? If it was a a firefox it has a feature wich tries to download the file if the server doesnt reply in x amount of time.
Try internet explorer and see if you get any other error messages.

Generally, if the browser tries to download the .php file. It means there is something wrong with the server config and you would need to check the error logs for more information.

Hope this helps to get started... :)

EDIT: also, update your phpBB 2 to the latest version, wich is 2.0.22 at the moment i write this.
The converter has been designed to work on that version.
Signature is here

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

Thank you lurttinen,

I am running 2.0.20, and through FireFox.

I have successfully used FireFox on a 2.0.22 installation and that worked fine, so updating to phpBB 2.0.22 will be my first port of call.

Thank you again,
Last edited by ab9db on Sun Jun 10, 2007 10:29 pm, edited 1 time in total.

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

http://www.arsenal-land.co.uk/forum3/install/index.php

I have upgraded to 2.0.22 and the same problem occurs.

In FireFox it tries to download, in Internet Explorer it cannot find page.

magicfun
Registered User
Posts: 382
Joined: Fri Apr 28, 2006 8:50 pm

Re: Cannot run conversion scripts

Post by magicfun »

I'm having the same issue. I get my categories converted, but no users...When I do the conversion process, it takes me to a "500 internal server error" page. Any help?

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

Not the same for me, I get nothing. The script doesn't run fullstop

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

Hello again,

Support template added:
The following is the basic SRT
Your board's URL: http://www.arsenal-land.co.uk/forum/
Version of phpBB3: phpBB 2.0.22 - trying to convert to phpBB 3 RC1
Was this a fresh install or a(n) update/upgrade/conversion? Upgraded various times to phpBB 2.0.22
Was this an install through your host? Initially yes
MODs you have installed: None
When the problem started: Unable to run conversion script at all. Worked once, however it did not contain all of the data. Cannot figure out why it worked that one time though.

Additionally, you may wish to provide the following (where applicable)
Template(s) used: subSilver
Version of PHP used: 4.4.7
Database and version used: ?
Do you have a test account for us? http://www.arsenal-land.co.uk/forum3/install/index.php

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Re: Cannot run conversion scripts

Post by ToonArmy »

Check the server error logs if you can.
Chris SmithGitHub

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

Error logs:

[Mon Jun 11 17:18:18 2007] [error] [client 74.6.85.213] File does not exist: /home/arseland/public_html/robots.txt

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

robots.txt doesn't exist do I need one?

where do I get one if so?

ToonArmy
Former Team Member
Posts: 4608
Joined: Sat Mar 06, 2004 5:29 pm
Location: Worcestershire, UK
Name: Chris Smith
Contact:

Re: Cannot run conversion scripts

Post by ToonArmy »

That is not the problem.
Chris SmithGitHub

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

It was the error I got at the time of trying, but that error no longer appears when trying so I guessed as much.

No server errors logged,

Back to square one without the foggiest idea what to do.

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Cannot run conversion scripts

Post by ab9db »

Okay, /forum from 2.0.22 to RC1 is not working.

but I have successfully been able to set up a test board and update that from /testforum 2.0.22 to RC1 /forum3

http://www.arsenal-land.co.uk/forum3/ - RC1 phpBB3
http://www.arsenal-land.co.uk/testforum/ - 2.0.22

So the process works on my server, that's good news. It struck me that maybe something with my current board is not quite right, I have updated it often with changed files only so maybe /forum is not 100% as designed. So what about copying phpBB2 database to another database? Or setting up a new phpBB2 board that uses the same one and trying that? Or maybe doing a fresh phpBB install to my current board?

Any of those ideas worth a punt?

1. Copy database to new database (not sure that'll do anything new though)
2. Start new phpBB2 forum with fresh install and link to original database (maybe using concept 1)
3. Reinstall 2.022 over my current files.

Cheers

Darren

Edit: I think 3 is essentially the same as 1 & 2 in combination and less risky, how does fresh install compare to change files only?

Locked

Return to “[3.0.x] Support Forum”