Conversion does not complete

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
rsdoran
Registered User
Posts: 3
Joined: Mon Jun 11, 2007 1:30 am

Conversion does not complete

Post by rsdoran »

I have sucessfully installed phpbb 3.0 RC1. I can go completely through the conversion process till it say "continue conversion"; which appears to be the final stage. I have IE and a "bar" appears at the bottom as if it is doing something then it takes me to a page that says "Page not available", this happens fairly quick. I can rename the install folder then access the newly created forum but it is not complete i.e. no forums created, members and/or memberlist not correct, plus other things.

I read, but can not find now, something about a timing or uploading issue with some hosts where I may need them to increase a setting, if anyone can tell me what I should ask them to increase that may help.

I also read a thread, can not find now, that talked about a php.ini file. I was not sure how to do it but would like to find that thread again if possible. It also had a link to tips and tricks, BT or something along those lines.

Any assistance is highly appreciated. A side note: I have been using phpbb for 4 years and very happy with it, the only issues overall is mainly me not knowing as much as I could or should. Thank you and keep up the good work.

BTW I can provide anything you may need like screenshots etc., just let me know.

edorf
Registered User
Posts: 10
Joined: Fri May 25, 2007 9:38 am

Re: Conversion does not complete

Post by edorf »


rsdoran
Registered User
Posts: 3
Joined: Mon Jun 11, 2007 1:30 am

Re: Conversion does not complete

Post by rsdoran »

I do not get an error message, and it is just a few seconds before it goes to the IE page saying unavaiable. I will redo the process and get screenshots

rsdoran
Registered User
Posts: 3
Joined: Mon Jun 11, 2007 1:30 am

Re: Conversion does not complete

Post by rsdoran »

This is my original forum: http://www.patchn.com/forum1/

This is the new forum: http://www.patchn.com/phpBB3/

If interested this is a screen recording of what I did to install phpbb3, then using the convertor, and what happened: http://www.patchn.com/phpbb3install.avi

BTW: Ignore the Start Screen jumping up, I did that by accident and with it recording I had some response lag. I can make it cleaner if necessary.

AlyxTakla
Registered User
Posts: 50
Joined: Sun May 20, 2007 3:52 pm

Re: Conversion does not complete

Post by AlyxTakla »

Hi,

I'm encountering this same problem. Internet explorer times out and Firefox attempts to download the black index.php page after around 10-15 seconds of loading.

I've read through many threads on this forum, however I haven't been able to find a proper answer to the problem.

The host asked me before they could do anything further to fixing whatever they need to fix, they would need to find out (via the "script developers", but in this case anybody at all) whether there was a way to fix this problem known.

If anybody knows, what causes this and what should I tell my host to do so I can run this conversion without interruption?

Thanks,
Alyx

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Conversion does not complete

Post by ab9db »

Exact same problem here,

Note that I don't feel it's a server issue, I have successfully converted a fresh phpBB 2.0.22 to RC1 on my server. I suspect it may be database related. Maybe those of use having this same issue should collate our circumstances to see if we can find a pattern that may give a clue to the problem?

AlyxTakla
Registered User
Posts: 50
Joined: Sun May 20, 2007 3:52 pm

Re: Conversion does not complete

Post by AlyxTakla »

Okay, well here's my basic database details. Not sure what is relevant and what's not.

Size: 34.0MB
Posts: 12,500
Users: 257
Boards: 25
Categories: 9
phpBB Version: 2.0.22
Hosting: Shared hosting
Conversion problem: Conversion times out/fails are approx. 10-15 seconds each time. Firefox attempts to download index.php

AlyxTakla
Registered User
Posts: 50
Joined: Sun May 20, 2007 3:52 pm

Re: Conversion does not complete

Post by AlyxTakla »

I've just discovered the "failed" conversion imported the board names, and (after "resynchronizing") each board, the topic and post totals appear, however they fail to appear on the home page, and only appear in the admin panel. Members also don't seem to have been imported.

Edit: I probably shouldn't have but I fiddled around with one of the install files.
I don't know what I did, but I returned to the convert page which had three errors at the top, however I ran the installer anyway just to see how it would go and I managed to end up with an installed forum with all users in tact but all avatars and around 4,250 posts were missing. It's a step closer to getting there at least, and has given me some hope...

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Conversion does not complete

Post by ab9db »

AlyxTakla wrote:Okay, well here's my basic database details. Not sure what is relevant and what's not.

Size: 34.0MB
Posts: 12,500
Users: 257
Boards: 25
Categories: 9
phpBB Version: 2.0.22
Hosting: Shared hosting
Conversion problem: Conversion times out/fails are approx. 10-15 seconds each time. Firefox attempts to download index.php
Size: 91.0MB
Posts: 81,307
Users: 3897
Boards: 15
Categories: 3
phpBB Version: 2.0.22
Hosting: Shared hosting
Conversion problem: Conversion times out. Firefox attempts to download index.php

edorf
Registered User
Posts: 10
Joined: Fri May 25, 2007 9:38 am

Re: Conversion does not complete

Post by edorf »

Does the cpu run at 100% or so until it dies ?
Have you seen if any posts are being converted at all in the posts table ?

User avatar
TraXy
Registered User
Posts: 46
Joined: Sat Feb 12, 2005 11:46 pm
Location: Nottingham
Contact:

Re: Conversion does not complete

Post by TraXy »

Size: 34.79 MB
Posts: 49087
Users: 278
Boards: 100+
Categories: 12
phpBB Version: 2.0.22
Hosting: Shared hosting
Conversion problem: Conversion times out. Same as described above. Clicking "Continue Conversion", then it just goes to a blank page with the address /install/index.php?mode=convert&sub=in_progress&tag=phpbb20&confirm=1

It doesn't work to remove all the posts over 4096 in length either (as suggested in another thread).

Weird thing is, when I tried converting the same forum into the B5 release, I didn't have any problems whatsoever.

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Conversion does not complete

Post by ab9db »

All 3 of our databases are 35Mb+,

Maybe there is a server memory issue?

I can set up fresh phpBB2 boards and convert to phpBB3 no problem,

Further When I try exporting my database all I get is another download prompt for export.php

AlyxTakla
Registered User
Posts: 50
Joined: Sun May 20, 2007 3:52 pm

Re: Conversion does not complete

Post by AlyxTakla »

I'm not sure what my friend did, but he has my phpBB3 forum working now. :D

I'll ask and see whether he can shed some light on it that may help everybody else having these troubles.

ab9db
Registered User
Posts: 212
Joined: Tue Apr 22, 2003 5:57 pm
Location: Swindon, UK
Contact:

Re: Conversion does not complete

Post by ab9db »

AlyxTakla wrote:I'm not sure what my friend did, but he has my phpBB3 forum working now. :D

I'll ask and see whether he can shed some light on it that may help everybody else having these troubles.
That would be much appreciated.

ZetecRy
Registered User
Posts: 17
Joined: Thu Jun 14, 2007 12:44 pm

Re: Conversion does not complete

Post by ZetecRy »

ab9db wrote:
AlyxTakla wrote:I'm not sure what my friend did, but he has my phpBB3 forum working now. :D

I'll ask and see whether he can shed some light on it that may help everybody else having these troubles.
That would be much appreciated.
Yes totally, as i'm having the same problem. Though my db is over 160mb with more than 900 members so i do wonder if it is the DB MySQL server.

Locked

Return to “[3.0.x] Support Forum”