Page 1 of 1

Upgrade from 2.0.22 > RC4 error

Posted: Sun Aug 12, 2007 10:21 am
by sp3ctre
Hi,

I have been trying to run an upgrade from my v2 board to RC4. I seem to be getting there, but finally came across this error:

Code: Select all

SQL ERROR [ mysql4 ]

Column 'user_lang' cannot be null [1048]

SQL

INSERT INTO phpbb_users (username, username_clean, user_password, user_pass_convert, user_email, user_email_hash, group_id, user_type, user_permissions, user_timezone, user_dateformat, user_lang, user_style, user_allow_pm, user_actkey, user_ip, user_regdate, user_passchg, user_inactive_reason, user_inactive_time, user_lastmark, user_lastvisit, user_lastpost_time, user_lastpage, user_posts, user_dst, user_colour, user_occ, user_interests, user_avatar, user_avatar_type, user_avatar_width, user_avatar_height, user_new_privmsg, user_unread_privmsg, user_last_privmsg, user_message_rules, user_full_folder, user_emailtime, user_notify, user_notify_pm, user_notify_type, user_allow_viewonline, user_allow_viewemail, user_allow_massemail, user_sig, user_sig_bbcode_uid, user_sig_bbcode_bitfield) VALUES ('AdsBot [Google]', 'adsbot [google]', '', 0, '', '00', 39, 2, '', 0, 'D M d, Y g:i a', NULL, 1, 1, '', '', 1186909057, 1186909057, 0, 0, 1186909057, 0, 0, '', 0, 0, '9E8DA7', '', '', '', 0, 0, 0, 0, 0, 0, 0, -3, 0, 0, 1, 0, 1, 1, 0, '', '', '')

This seems like static data, so how come it is trying to insert a NULL value into a non null column?

Is this a bug? I imagine I could get around it by allowing NULL's on that column, then sort out the data and amend it back, but not sure that's the way forward.

Any ideas?

Thanks,

J

Re: Upgrade from 2.0.22 > RC4 error

Posted: Sun Aug 12, 2007 10:44 am
by david63
Could you be a bit more specific as to the steps you have gone through and where you are getting this error, with a screenshot if possible.

You should not be getting that error when upgrading from phpbb2 > phpbb3 because the data that is trying to be inserted into the database would only occur when you install phpbb3

Re: Upgrade from 2.0.22 > RC4 error

Posted: Sun Aug 12, 2007 11:15 am
by sp3ctre
Thanks for the reply... here is a screenshot. It occurs on the "final step" when running through the upgrade pages.:

Image

Re: Upgrade from 2.0.22 > RC4 error

Posted: Sun Aug 12, 2007 12:12 pm
by sp3ctre
ok, fixed... I did another fresh install and tried again.. ir worked.

As far as I can see the problem was I binned off the data in the database earlier, and manually ran the install SQL and data SQL... should've worked I guess but must have done something wrong... anyway, working now, so onward and upward!

Thanks for the reply though

Re: Upgrade from 2.0.22 > RC4 error

Posted: Sun Aug 12, 2007 12:15 pm
by david63
After doing a bit of searching through the code I know what is causing the error but I have no idea why. The reason why the "user_lang" field is NULL is because you do not have a default language set in your config table - this should have been set when you started the conversion. The only time I have know for this to happen is when you do not have the language files available in your phpbb2 installation.

As for why it is installing the bots again is another mystery as to quote from the code
* This code should be used in execute_last if the source database did not have bots
and I do not know how this situation would arise.