Error When Viewing Users Posts

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
andeh_ab
Registered User
Posts: 19
Joined: Thu Mar 01, 2007 5:12 pm

Error When Viewing Users Posts

Post by andeh_ab » Fri Aug 31, 2007 10:59 am

Your board's URL: http://www.alexisblue.co.uk/forum/index.php
Version of phpBB3: RC5
Was this a fresh install or a(n) update/upgrade/conversion (please be specific)? RC4 -> RC5
MODs you have installed: evil quick reply, evil post redirect, topic titles on index
When the problem started: After the update


When I go to search users posts, I get this error:

Code: Select all

[phpBB Debug] PHP Notice: in file /includes/search/fulltext_native.php on line 781: implode() [function.implode]: Bad arguments.
[phpBB Debug] PHP Notice: in file /includes/search/fulltext_native.php on line 783: implode() [function.implode]: Bad arguments.

General Error
SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'DESC LIMIT 250' at line 9 [1064]

SQL

SELECT SQL_CALC_FOUND_ROWS p.post_id FROM phpbb_posts p, phpbb_topics t WHERE p.poster_id = 0 AND p.topic_id = 1 AND p.post_approved = 1 AND p.forum_id <> 0 AND p.post_time >= 1188556493 ORDER BY DESC LIMIT 250

BACKTRACE

FILE: includes/db/mysqli.php
LINE: 143
CALL: dbal->sql_error()

FILE: includes/db/mysqli.php
LINE: 185
CALL: dbal_mysqli->sql_query()

FILE: includes/db/dbal.php
LINE: 145
CALL: dbal_mysqli->_sql_query_limit()

FILE: includes/search/fulltext_native.php
LINE: 924
CALL: dbal->sql_query_limit()

FILE: search.php
LINE: 423
CALL: fulltext_native->author_search()
(http://www.alexisblue.co.uk/forum/searc ... 2&sr=posts)

Same for when anyone else searches their own.. It wont be a template problem as the same thing happens on another board that I run. Only thing I can think of is the MODS affecting it, but they were fine until I upgraded to RC5

User avatar
david63
Registered User
Posts: 16073
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Error When Viewing Users Posts

Post by david63 » Fri Aug 31, 2007 1:19 pm

andeh_ab wrote:Only thing I can think of is the MODS affecting it, but they were fine until I upgraded to RC5
Are the mods RC5 compatible? Have you checked if there is an upgrade for any of them for RC5?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

proton2112
Registered User
Posts: 19
Joined: Sun Nov 27, 2005 1:02 am

Re: Error When Viewing Users Posts

Post by proton2112 » Sun Sep 09, 2007 10:53 pm

also getting this. one tiny mod installed (itemstats for world of warcraft item links). pretty sure it only appeared in rc5.

Locked

Return to “[3.0.x] Support Forum”