Page 1 of 1

Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Tue Sep 04, 2007 6:12 pm
by thetoolsmith
I've read through the forum, searched the knowledge base for answers to my problem without any luck. Here is my issue:

I'm currently running version 2.0.21 and have tried upgrading to the 3.0 Beta 5 build. All is well until I start the conversion, after a minute or so I get the follwoing error:
General Error
SQL ERROR [ mysql4 ]

MySQL server has gone away [2006]

SQL

SELECT MAX(forum_id) AS max_forum_id FROM phpbb_forums

BACKTRACE


FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: install/convertors/functions_phpbb20.php
LINE: 56
CALL: dbal_mysql->sql_query()

FILE: install/install_convert.php(1004) : eval()'d code
LINE: 5
CALL: phpbb_insert_forums()

FILE: install/install_convert.php
LINE: 1004
CALL: eval()

FILE: install/install_convert.php
LINE: 203
CALL: install_convert->convert_data()

FILE: install/index.php
LINE: 363
CALL: install_convert->main()

FILE: install/index.php
LINE: 235
CALL: module->load()
I've contacted my host provider and they say the issue is with phpBB. I'd be willing to provide someone with my credentials and DB information to troubleshoot the issue.

Thanks in advance for the help,
-Paul

Re: Upgrade from 2.0.21 to 3.0 Beta 5 - MySql ERROR

Posted: Tue Sep 04, 2007 6:21 pm
by KevC
I assume you mean RC5 and not beta5?
thetoolsmith wrote:MySQL server has gone away
If you google for that you'll find it means the server has timed out and dropped the connection.
It's your hosts fault.

http://dev.mysql.com/doc/refman/5.0/en/gone-away.html

An alternative would be to download the database, convert it locally (using easyPHP or XAMPP) and then uploading it back to the new installation.

Re: Upgrade from 2.0.21 to 3.0 Beta 5 - MySql ERROR

Posted: Tue Sep 04, 2007 6:43 pm
by thetoolsmith
Kevin Clark wrote:An alternative would be to download the database, convert it locally (using easyPHP or XAMPP) and then uploading it back to the new installation.
Sorry I did mean RC5, are there instructions or any documentaion I can follow to do the conversion myself? My host provider is convinced it's a phpBB issue, and I know it isn't.

Thanks,
-Paul

Re: Upgrade from 2.0.21 to 3.0 Beta 5 - MySql ERROR

Posted: Tue Sep 04, 2007 7:05 pm
by Larrodan
"MySQL server has gone away [2006]" this is host problem, btw first update to 2.0.22 after that covert to RC5 ;)

Re: Upgrade from 2.0.21 to 3.0 Beta 5 - MySql ERROR

Posted: Tue Sep 04, 2007 7:48 pm
by KevC
thetoolsmith wrote:
Kevin Clark wrote:An alternative would be to download the database, convert it locally (using easyPHP or XAMPP) and then uploading it back to the new installation.
Sorry I did mean RC5, are there instructions or any documentaion I can follow to do the conversion myself? My host provider is convinced it's a phpBB issue, and I know it isn't.

Thanks,
-Paul
To back up the database follow that section in this KB article.
http://www.phpbb.com/kb/article/how-to- ... ew-server/

Google for easyphp or XAMPP and decide which you want to try.

Install it.

They give you a www folder into which you need to put phpBB2 and phpBB3.
You need to install phpBB2 by putting it into the www folder, making a database (using phpmyadmin that comes with the offline app you installed) and then restoring the database to it. You might need to use bigdump for that (again just google it).

Then you need to install phpBB3 the same way and then run the converter.
Back up the resulting database and restore it to your online phpBB3 installation.

Re: Upgrade from 2.0.21 to 3.0 Beta 5 - MySql ERROR

Posted: Tue Sep 04, 2007 7:55 pm
by thetoolsmith
Kevin Clark wrote:To back up the database follow that section in this KB article.
Did you mean to include a link ?

Thanks,
-Paul

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Tue Sep 04, 2007 8:09 pm
by KevC

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Tue Sep 04, 2007 8:28 pm
by Dace
i have the same problem with sql have gone away... but it only happen with update to RC5.. i have made all the upadate (RC1->RC2...) without any problem with same host... and now with RC5 i read in this forum that a lot of users can't update to RC5...

my host said that the update script must use persistant connection..mysql pconect()

if a lot of host can't support phpbb update, it's a big problem... isn't it

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Fri Dec 14, 2007 11:09 pm
by Alex Zuyev
Hallo.
Have the same error but Upgrade from 2.0.22 to 3.0.0 Final. I'm afraid I am not the one who will have this problem. Hope there is a Wizadr to fix or at least to make the convertion scriop working with all our hosting-providers.
SQL ERROR [ mysql4 ]
MySQL server has gone away [2006]
SQL
SELECT MAX(forum_id) AS max_forum_id FROM phpbb_forums
BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: install/convertors/functions_phpbb20.php
LINE: 61
CALL: dbal_mysql->sql_query()

FILE: install/install_convert.php(1004) : eval()'d code
LINE: 5
CALL: phpbb_insert_forums()

FILE: install/install_convert.php
LINE: 1004
CALL: eval()

FILE: install/install_convert.php
LINE: 203
CALL: install_convert->convert_data()

FILE: install/index.php
LINE: 402
CALL: install_convert->main()

FILE: install/index.php
LINE: 274
CALL: module->load()

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Sat Dec 15, 2007 3:28 am
by neps
Same thing for me too I'm afraid. Tried increasing the timeout as mentioned in another thread, but no value worked even -1.

Code: Select all

SQL ERROR [ mysql4 ]

MySQL server has gone away [2006]

SQL

SELECT MAX(forum_id) AS max_forum_id FROM phpbb_forums

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal_mysql->sql_error()

FILE: install/convertors/functions_phpbb20.php
LINE: 61
CALL: dbal_mysql->sql_query()

FILE: install/install_convert.php(1004) : eval()'d code
LINE: 5
CALL: phpbb_insert_forums()

FILE: install/install_convert.php
LINE: 1004
CALL: eval()

FILE: install/install_convert.php
LINE: 203
CALL: install_convert->convert_data()

FILE: install/index.php
LINE: 402
CALL: install_convert->main()

FILE: install/index.php
LINE: 274
CALL: module->load()

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Sat Dec 29, 2007 11:08 am
by karlosthestick
Hi all, just reading through and I have the exact same error. Did any of you manage to get the conversion working after all?

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Sat Dec 29, 2007 11:40 am
by KevC
'MySQL server has gone away' is just what it says. The connection to the server has been lost during the process.

I explained above how to convert offline to avoid this problem. There is also now a KB article on how to do it that way.

Knowledge Base - Offline Conversions

Re: Upgrade from 2.0.21 to 3.0 RC 5 - MySql ERROR

Posted: Sat Dec 29, 2007 1:10 pm
by karlosthestick
Thanks, the article in the Knowledge Base is excellent and thorough.