Style Pictures

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Style Pictures

Post by Gunnar » Fri Sep 14, 2007 8:00 am

Hello,

I am making a theme for phpBB 3 but i am having problems...

I changed a few files to .png's because they offer more than .gif's

Now i have a problem finding where in the style code i change it so it uses the png's instead of the gif's

for example, i can not find anywhere the line that puts the picture button_topic_new.gif where it is supposed to be.

even used an application to search the source of the entire style folder, was not found...

any help greatly appreciated :)

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Style Pictures

Post by karlsemple » Fri Sep 14, 2007 8:06 am

you should be editing the imageset.cfg in the style/imageset/ folder
Image

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style Pictures

Post by Gunnar » Fri Sep 14, 2007 6:43 pm

i changed it this way


# Images
img_icon_contact_pm = icon_contact_pm.png*20*28

img_icon_post_edit = icon_post_edit.png*20*42
img_icon_post_quote = icon_post_quote.png*20*54

img_icon_user_online = icon_user_online.png*58*58
img_icon_user_offline = icon_user_offline.png
img_icon_user_search = icon_user_search.png

img_button_pm_forward = button_pm_forward.png*25*96
img_button_pm_new = button_pm_new.png*25*84
img_button_pm_reply = button_pm_reply.png*25*96

img_button_topic_locked = button_topic_locked.png*25*88
img_button_topic_new = button_topic_new.png*25*96
img_button_topic_reply = button_topic_reply.png*25*96


but that doesnt work...

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style Pictures

Post by Gunnar » Sat Sep 15, 2007 1:48 am

can anyone help me figure this out ?

i have looked everywhere for the place where i use the png instead of gif and no luck...

editing the imageset.cfg file was no help at all

i am trying to use pngs instead of gifs in styles\{style name}\imageset\en

please help

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style Pictures

Post by Gunnar » Sun Sep 16, 2007 2:29 am

bump, still need help, submitted this as a bug, got closed as a "Support request" so i guess they dont think this is a bug

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51785
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Style Pictures

Post by Brf » Sun Sep 16, 2007 2:32 am

After you changed the imageset.cfg did you refresh your imageset from the ACP styles/imagesets page?

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style Pictures

Post by Gunnar » Sun Sep 16, 2007 2:51 am

now it FINALLY works

that really should happen when i purge the cache...

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Style Pictures

Post by karlsemple » Sun Sep 16, 2007 2:54 am

Gunnar wrote:now it FINALLY works

that really should happen when i purge the cache...

purging the cache clears the cache folder, imagesets for prosilver based templates are stored in the database so any changes to the files need to be refreshed into the database, same with the templates and theme :)
Image

Gunnar
Registered User
Posts: 55
Joined: Sun Sep 09, 2007 11:54 am

Re: Style Pictures

Post by Gunnar » Sun Sep 16, 2007 3:03 am

but why then do css changes appear immediately after upload

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51785
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Style Pictures

Post by Brf » Sun Sep 16, 2007 3:08 am

The imageset data that you see in the imageset.cfg file is stored in the database when you refresh. That is where the forum reads it from, not the cfg file.

Locked

Return to “[3.0.x] Support Forum”