Incorrect time issue

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Ideas Centre
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
mexus
Registered User
Posts: 4
Joined: Wed Feb 11, 2004 5:44 pm

Incorrect time issue

Post by mexus » Wed Oct 10, 2007 9:09 am

I have the following problem:
My server time is correct (i'm running the most current CentOS5).
My phpbb is 3 RC5.
The time and date in phpbb are incorrect. Phpbb shows the date in 1 day difference, and 1 hour difference.
Example if today its 23 march 07 10:00 in phpbb it shows 22 march 07 9:00. The timezone is set correctly.... that problem messes the birthday reminders too. As i sad the server time is correct set by NTP.

How to fix the problem in phpbb? Can i make phpbb showing my server time?

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Incorrect time issue

Post by karlsemple » Wed Oct 10, 2007 9:13 am

phpBB3 has no such problem, either the board time-zone or the time-zone in your profile are incorrect or the server time is incorrect. Remember when setting time-zones you have to set the one in the board config and your own in your profile.
Image

mexus
Registered User
Posts: 4
Joined: Wed Feb 11, 2004 5:44 pm

Re: Incorrect time issue

Post by mexus » Wed Oct 10, 2007 9:51 am

It's correctly set. Bulgaria is in the +2 timezone, but the time in phpbb is incorrect ( i must set it to +3 to show the correct time). As i said my server time is 100% correct.

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Incorrect time issue

Post by karlsemple » Wed Oct 10, 2007 10:09 am

mexus wrote:It's correctly set. Bulgaria is in the +2 timezone, but the time in phpbb is incorrect ( i must set it to +3 to show the correct time). As i said my server time is 100% correct.

if its is one hour out it might be as a result of DST, so make sure you check the option for
Summer Time/DST is in effect:
to yes ;
:)
Image

Locked

Return to “[3.0.x] Support Forum”