The submitted form was invalid. Try submitting again.

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Scam Warning
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
User avatar
Flash619 [GN]
Registered User
Posts: 240
Joined: Fri Apr 27, 2007 8:54 pm
Contact:

The submitted form was invalid. Try submitting again.

Post by Flash619 [GN] » Wed Oct 17, 2007 7:36 pm

When i try to post it will say at the top of the screen

Code: Select all

The submitted form was invalid. Try submitting again.
i don't exactly know what is causeing it i just upgraded to RC7 and this just started to happen...any suggestions? :shock:
and i have read the Sticky that talks about what to do in case of errors.
it will also ecure when trying to change you signature,and sen private messages.

Your board's URL: http://www.gameplayerznews.com
This was a upgrade/update.
MODs you have installed: NONE
When the problem started: Oct/17/07
Template(s) used: Bloo, Dark Bloo
Language(s) used: English
Version of PHP used: 3.0 RC7
Last edited by pentapenguin on Sat Oct 27, 2007 5:33 am, edited 1 time in total.
Reason: Topic icon changed
Image

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Re: The submitted form was invalid. Try submitting again.

Post by A_Jelly_Doughnut » Wed Oct 17, 2007 9:17 pm

If you read the sticky, you would know that you'll need to wait for an update to your custom styles to be compatible with RC7. You can use one of phpBB's default styles until then.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: The submitted form was invalid. Try submitting again.

Post by Highway of Life » Wed Oct 17, 2007 9:21 pm

The problem is that your template has not been updated for use with RC7.
Your list of options:
  1. Set prosilver as your default style and use it until the custom template is updated for RC7
  2. Update the template yourself by performing doing a mass FIND:

    Code: Select all

    </form>
    REPLACE:

    Code: Select all

    {S_FORM_TOKEN}</form>
    If you have Shell (SSH) Access to your server, cd (change directory) to your custom style template directory and run the following command...

    Code: Select all

    perl -pi -w -e 's/<\/form>/{S_FORM_TOKEN}<\/form>/g;' *.html
    This will add the S_FORM_TOKEN variable to the template and make it possible to use your custom template.
In addition, read the second post in This Topic for directions on how to enable yourself to login to the ACP.
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

sammyboy405
Registered User
Posts: 21
Joined: Sat Aug 18, 2007 10:48 pm

Re: The submitted form was invalid. Try submitting again.

Post by sammyboy405 » Mon Oct 22, 2007 5:37 am

Highway of Life wrote:The problem is that your template has not been updated for use with RC7.
Your list of options:
  1. Set prosilver as your default style and use it until the custom template is updated for RC7
  2. Update the template yourself by performing doing a mass FIND:

    Code: Select all

    </form>
    REPLACE:

    Code: Select all

    {S_FORM_TOKEN}</form>
    If you have Shell (SSH) Access to your server, cd (change directory) to your custom style template directory and run the following command...

    Code: Select all

    perl -pi -w -e 's/<\/form>/{S_FORM_TOKEN}<\/form>/g;' *.html
    This will add the S_FORM_TOKEN variable to the template and make it possible to use your custom template.
In addition, read the second post in This Topic for directions on how to enable yourself to login to the ACP.

Awesome.. thanks for the Perl setup luckily i had shell access. this saved a ton of time. This information is much appreciative. I didn't want to have to modify my theme by hand again.

XFFreakyK
Registered User
Posts: 36
Joined: Tue Oct 18, 2005 12:16 am

Re: The submitted form was invalid. Try submitting again.

Post by XFFreakyK » Fri Oct 26, 2007 4:34 pm

I'm in the same situation. At this point however, instead of changing every instance of </form> in my template folder, I'd rather just go back to my admin panel and revert to a RC7 skin, like ProSilver. the catch is that I can't log in to the admin panel as I'm using an RC4 skin and I can't override it unless I go into the admin panel. So the simple question is, which individual file(s) do I need to apply the {S_FORM_TOKEN} to just to allow me to login in to the ACP?

Thanks,

Keven
ThatForumPlace.com - Laughs, Tears, and Free Forum Hosting

almsamim
Registered User
Posts: 290
Joined: Tue Oct 23, 2007 5:08 am
Location: Faculty of Medicine

Re: The submitted form was invalid. Try submitting again.

Post by almsamim » Fri Oct 26, 2007 5:20 pm

I'm in the same situation.

User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Re: The submitted form was invalid. Try submitting again.

Post by pentapenguin » Fri Oct 26, 2007 5:36 pm

You would need to change styles/prosilver/template/login_body.html
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.

XFFreakyK
Registered User
Posts: 36
Joined: Tue Oct 18, 2005 12:16 am

Re: The submitted form was invalid. Try submitting again.

Post by XFFreakyK » Fri Oct 26, 2007 5:57 pm

I changed login_body.html for both the RC4 skin as well as for the ProSilver skin (though it's the Prosilver skin that came with my RC7 installation). Triple checked that I'm entering the correct password to log in to the admin panel.

Still not working.

Getting this message:

General Error
You need to enter your password to access the Administration Control Panel.
ThatForumPlace.com - Laughs, Tears, and Free Forum Hosting

User avatar
Flash619 [GN]
Registered User
Posts: 240
Joined: Fri Apr 27, 2007 8:54 pm
Contact:

Re: The submitted form was invalid. Try submitting again.

Post by Flash619 [GN] » Fri Oct 26, 2007 6:17 pm

did you put in the password box correctly thats all i can think of.
Image

XFFreakyK
Registered User
Posts: 36
Joined: Tue Oct 18, 2005 12:16 am

Re: The submitted form was invalid. Try submitting again.

Post by XFFreakyK » Fri Oct 26, 2007 6:22 pm

yes I did
ThatForumPlace.com - Laughs, Tears, and Free Forum Hosting

User avatar
Flash619 [GN]
Registered User
Posts: 240
Joined: Fri Apr 27, 2007 8:54 pm
Contact:

Re: The submitted form was invalid. Try submitting again.

Post by Flash619 [GN] » Fri Oct 26, 2007 7:09 pm

Hm maybe it is not reading the field correctly.
Image

User avatar
Highway of Life
Former Team Member
Posts: 6048
Joined: Wed Feb 02, 2005 5:41 pm
Location: Seattle, WA
Name: David Lewis
Contact:

Re: The submitted form was invalid. Try submitting again.

Post by Highway of Life » Fri Oct 26, 2007 7:16 pm

Highway of Life wrote:Sounds like you need to clear your template cache...

Try running the following script to reset your cache as well as set your default style to prosilver so that you can login to the ACP.
  1. Save This file as "reset_style.php" to your forum root (same location as your config.php file)
  2. Browse to the file: e.g.: http://yourwebsite.com/reset_style.php
  3. Click the link to clear style cache
  4. Delete the script from your server
  5. login to your ACP
The phpBB Weekly Podcast - Discussing the developments of phpBB4 and beyond.

New to phpBB3? Want to learn about programing?
Visit phpBB Academy at StarTrekGuide to learn how.

XFFreakyK
Registered User
Posts: 36
Joined: Tue Oct 18, 2005 12:16 am

Re: The submitted form was invalid. Try submitting again.

Post by XFFreakyK » Fri Oct 26, 2007 7:38 pm

@Highway of Life, thank you. It definitely seems like it would do the trick, though at this point I've already deleted the whole forum and reuploded. Very handy tool, I'll bookmark this for future reference.

Thanks again,

K
ThatForumPlace.com - Laughs, Tears, and Free Forum Hosting

User avatar
Flash619 [GN]
Registered User
Posts: 240
Joined: Fri Apr 27, 2007 8:54 pm
Contact:

Re: The submitted form was invalid. Try submitting again.

Post by Flash619 [GN] » Fri Oct 26, 2007 7:51 pm

can't believe i didn't think of that! :shock:
Image

aeronox
Registered User
Posts: 8
Joined: Wed Mar 21, 2007 12:06 pm

Re: The submitted form was invalid. Try submitting again.

Post by aeronox » Sat Nov 03, 2007 5:25 am

I was constantly getting this error within the Admin Panel.

It's the new feature, "Minimum time to submit forms". And (imo) it shouldn't apply to the Admin Panel.

And it should really have it's own Error message. The form is NOT invalid!

Locked

Return to “[3.0.x] Support Forum”